1. #1

    Just tried to install the beta [Operating system?]

    It gave me an error saying my OS didn't meet the requirements? I have Windows XP and on the Swtor website it says that is fine. Has anyone had the same issue or have you run the beta on windows fine?

    I just want to know before I download 30 gigs worth of content for nothing and have it not load.

  2. #2
    Quote Originally Posted by Dio the Holy Diver View Post
    It gave me an error saying my OS didn't meet the requirements? I have Windows XP and on the Swtor website it says that is fine. Has anyone had the same issue or have you run the beta on windows fine?

    I just want to know before I download 30 gigs worth of content for nothing and have it not load.
    Do you have all service packs installed?

  3. #3
    Scarab Lord Trollsbane's Avatar
    Join Date
    Jan 2011
    Location
    Portland, Oregon
    Posts
    4,484
    Use the beta forums that you now haw acces to in order to solve this. They can help you over there. No one here can.

    My SWTOR guild: www.radguild.com
    USA West Coast PvP server: The Bastion
    Get your Game of Thrones on at Winteriscoming.net

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •