1. #1
    Bloodsail Admiral TheCrusader's Avatar
    Join Date
    Nov 2010
    Location
    Graz (Austria)
    Posts
    1,120

    Graphics Bug - 1920x1200 looks like 800x600

    Hi guys!
    I'm having a problem with my SWTOR client...

    First of all: here are the specs:

    CPU: Intel 2600k
    MoBo: Intel DP67BG
    Ram: 8GB Kingston
    GPU: nVidia GTX460 (2GB) made by Palit
    Drivers: all up to date ... (nVidia Driver Beta 290.36)

    Let's come to the problem ...
    If I want to play the game in standard resolution (1920x1200) the game turns all pixels ... it's hard to read any texts on the screen and it just looks ugly ...
    If I change to windowed Fullscreen mode, the resolution seems to do it's job. the game looks simply wonderful BUT my graphics card get's hotter and hotter and hotter ... last time it reached about 90°C after some time playing. It was horribly loud (due to the fan) and finally my computer shut down due to overheating ...
    Since playing in fullscreen 1920x1200 doesn't work properly and windowed fullscreen 1920x1200 is hard on my gpu i changed to 1600xsomething which seems to work so far ... the resolution seems sharp (texts perfectly readable) and the graphics card likes the setting ... but it isn't 1920x1200 ...

    What's the problem? Has anybody of you experienced this issue so far and maybe knows a way to solve it ?
    Would be glad!

    Thx up front
    Last edited by TheCrusader; 2011-12-17 at 10:52 PM. Reason: Edited title for better understanding
    My signature was too big, so now I use this one.

  2. #2
    Scarab Lord Kazomir's Avatar
    Join Date
    May 2010
    Location
    Sofia/Bulgaria
    Posts
    4,059
    Maybe 1920x1200 just is too heavy on your graphics card. Keep it on the 1600xsomething if it does its job. Better than having your graphics card melt.
    Quote Originally Posted by biolink22 View Post
    rogue "glory hole helm"

  3. #3
    Bloodsail Admiral TheCrusader's Avatar
    Join Date
    Nov 2010
    Location
    Graz (Austria)
    Posts
    1,120
    Quote Originally Posted by Kazomir View Post
    Maybe 1920x1200 just is too heavy on your graphics card. Keep it on the 1600xsomething if it does its job. Better than having your graphics card melt.
    can't be ... i played all other games (e.g. WoW, Dungeon Siege 3, The Witcher 2, StarCraft 2, Skyrim ........) also in 1920x1200 and it has never been a problem before ... it has to do with SWTOR ... something there doesn't seem to work properly.
    My signature was too big, so now I use this one.

  4. #4
    High Overlord
    Join Date
    Dec 2011
    Posts
    107
    Do you have vsync off? Try turning it on to cap your fps.
    Starcraft 2 had an issue like this, where cutscenes and menu were rendered without vsync, making the card generate unnecessary frames and overheat.

  5. #5
    Scarab Lord Kazomir's Avatar
    Join Date
    May 2010
    Location
    Sofia/Bulgaria
    Posts
    4,059
    Quote Originally Posted by TheCrusader View Post
    can't be ... i played all other games (e.g. WoW, Dungeon Siege 3, The Witcher 2, StarCraft 2, Skyrim ........) also in 1920x1200 and it has never been a problem before ... it has to do with SWTOR ... something there doesn't seem to work properly.
    Maybe its a problem with the game, and the options are still not optimized.
    perhaps they can fix it.
    Quote Originally Posted by biolink22 View Post
    rogue "glory hole helm"

  6. #6
    Bloodsail Admiral TheCrusader's Avatar
    Join Date
    Nov 2010
    Location
    Graz (Austria)
    Posts
    1,120
    Quote Originally Posted by vault View Post
    Do you have vsync off? Try turning it on to cap your fps.
    i have it forced from the nVidia Settings because SWTOR isn't able to turn it on on the clients side.

    ---------- Post added 2011-12-17 at 02:06 PM ----------

    Instead of you guys focusing why my graphics card is overheating I rather would like to solve the initial problem.

    The problem I really would like to solve is:
    When I'm playing full screen in 1920x1200 the resolution seems to be totally messed up ... it is pixelish, texts can't be read properly and so on ... when playing like this, my graphics card does not become overheated!
    It is as if - when I set the resolution to 1920x1200 in Fullscreen Mode - the client renders game in 800x600 (just in 16:10 ratio) ...

    That is my problem ...

    ---------- Post added 2011-12-17 at 11:51 PM ----------

    sry that i have to bump this thread ... but i really would like to see my problem solved ...
    My signature was too big, so now I use this one.

  7. #7
    Bloodsail Admiral TheCrusader's Avatar
    Join Date
    Nov 2010
    Location
    Graz (Austria)
    Posts
    1,120
    I did some research and came up with the following:

    - GTX460 has trouble showing SWTOR in Full HD resolution. Better stick with 1680x1050
    - Shadows in SWTOR are heavy - I mean REALLY heavy - on your GPU. Better set them to "Minimum".
    - The SWTOR has a problem with properly adjusting Hertz values. Try to change your Monitor Frequency setting and see if it works better.

    Hope that BioWare will fix those issues some day in the near future.
    My signature was too big, so now I use this one.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •