1. #1
    The Lightbringer Tehterokkar's Avatar
    Join Date
    Feb 2011
    Location
    Finland
    Posts
    3,727

    Exclamation Minecraft running at +600 FPS, but small freezes every 5 sec

    Hey!

    Ever since I got my new computer for Christmas, Minecraft has been the only game that I have lag in, Battlefield 3 runs on All Ultra 1920x1080[50 FPS]. WoW runs on All Ultra 1920x1080[120 FPS]. But then Minecraft, The lowest requiring game, lags.

    The game runs fine, other than small freezes that happen every 3-10 seconds and they freeze the game for 1-3 seconds and then returns

    I have Windows 7 Professional 64-bit and I have downloaded 64bit Java, but no help, I tried setting Javaw.exe to High priority but no help.

    Specs:

    Intel i5-2500K @ 3.3GHz
    Asus GTX 580 DirectCU II
    8gb(2x 4GB) Kingston 1333Mhz RAM
    64 GB SSD boot drive for Win7
    1.0 TB HDD for all other crap

    Help?

  2. #2
    change the view distance to normal It worked for me.

  3. #3
    The Lightbringer Tehterokkar's Avatar
    Join Date
    Feb 2011
    Location
    Finland
    Posts
    3,727
    I have tried it, doesn't help

  4. #4
    Mechagnome ThewF's Avatar
    Join Date
    Oct 2010
    Location
    Canada
    Posts
    528
    Turn off the sounds. From what I hear their is a bug with the sound files not working correctly on all systems. If this doesn't work try re-creating a new world and disabling sounds. Doing this has fixed about 80% of all the peoples problems with minecraft freezing every 5 - 10 seconds for a varying amount of time. The other possibility is that you have the Auto-Save feature enabled and is causing the issue due to the size of your world and the amount of data it's writing to your harddrive.

    PS: Helpful Topic.

    ---------- Post added 2012-01-15 at 07:32 AM ----------

    Turn off the sounds. From what I hear their is a bug with the sound files not working correctly on all systems. If this doesn't work try re-creating a new world and disabling sounds. Doing this has fixed about 80% of all the peoples problems with minecraft freezing every 5 - 10 seconds for a varying amount of time. The other possibility is that you have the Auto-Save feature enabled and is causing the issue due to the size of your world and the amount of data it's writing to your harddrive.

    PS: Helpful Topic.

    From that URL.


    - Defrag Harddrive
    - Set Javaw.exe to high priority and one CPU in Task Bar
    - Tried performance improving mods: Optimine, Optifog
    - Tried performance improving programs: Gamebooster
    - Format harddrive and reinstall OS and Minecraft
    - Updated all drivers for any possible hardware, including the Joystick, though you don't use it for Minecraft
    - Allocated more memory to Java like this
    - Searched anything on this Website to get help
    - Tried the game in offline mode, browser based and with the minecraft.exe
    - Defraged your RAM
    - Turned of all unnecessary background programms
    - Turned the graphics to low as possible
    - Specially experience this after 1.5.1
    - Used 40, 60, 90 or 200 FPS framerate Cap
    - Switched your Windows style
    - Downgrade or entirely deinstall your GPU drivers
    - Turning off vertical synchronisation/vertical refreshment on your GPU
    - Turning of auto update for Windows and/or your Antivirus software

  5. #5
    The Lightbringer Tehterokkar's Avatar
    Join Date
    Feb 2011
    Location
    Finland
    Posts
    3,727
    Quote Originally Posted by ThewF View Post
    snip!

    Alright.. How do I Config the Auto-save feature? To like every 3 minutes?

    Edit: Here is a picture of the lag spike click you can see the spike, they happen every 2-5 seconds :/
    Last edited by Tehterokkar; 2012-01-15 at 09:58 AM.

  6. #6
    you can install optifine, it has an option to change it

  7. #7
    Brewmaster Chry's Avatar
    Join Date
    Mar 2011
    Location
    Washington
    Posts
    1,380
    Yeah it's the autosave that's built in. I'm not sure if there's any way to manually configure it, but OptiFine will help you with that, and a whole bunch of other things.

  8. #8
    You should force vsync trough nvidia control panel on minecraft, will make your gfx a happy little puppy and also reduce the heat/noise level from your card. Mine goes totaly berserk without vsync.

    Maybe it solves the freezing to

  9. #9
    I'm guessing that your computer screen is at 60Hz, which makes any FPS over 60 obsolete.
    A screen at 60Hz is updated 60 times per second, if your game is updating the frames 60 times per second then you will not see any FPS lag at all.
    But if your screen is at 60Hz and your FPS is at 300 you can notice FPS lag because the game is updating the frames more frequently than your screen are.

    Any FPS above the Frequency Rate of your screen is 100% obsolete.

    Like NormySan said, activate vsync. Vsync will cap your FPS so that it will be at the same frequency rate as your screen.

    Made by Resentful

  10. #10
    Pit Lord
    Join Date
    Jan 2009
    Location
    Orlando, FL
    Posts
    2,392
    +600 FPS is useless for anything other than just seeing how many frames you can get. And I can't imagine the ungodly tearing you'd get from that.

    As was mentioned, force VSYNC and your system will be a lot happier, even if it doesn't completely solve your intermittent freezing issue.
    ^ The above should be taken with two grains of salt and a fistful of "chill the F* out".

  11. #11
    Quote Originally Posted by Peninja45 View Post
    Well java dosnt give you your operating systems java but the java you have on your browser so go here: h t t p:/ /w i n d o w s 7 t h emes. net/windows-7-java-64-bit-download .html, and download the "Windows x64 self-extracting JDK file" it gives you a 64 bit java. assuming you have pc, sorry had to put spaces dosnt let me put in links

    - - - Updated - - -

    First off had to include spaces so it would let me post. Well java dosnt give you your operating systems java but the java you have on your browser so go here: h t t p:/ /w i n d o w s 7themes.net/windows-7-java-64-bit-download.html, and download the "Windows x64 self-extracting JDK file" it gives you a 64 bit java. assuming you have pc
    And... You couldn't have linked him to Oracle's site for the files, instead of Windows7themes? That definitely looks... You know, legitimate.

  12. #12
    OMG 600 FPS, mine doesn't even scale upto 100

  13. #13

  14. #14
    Force Vsync, running at such high fps can never be good. As it will not maintain a constant 600 fps.

  15. #15
    I had the same problem with my game. Thanks.

  16. #16
    Force vsync and set your fps limit to 60. That should keep it running smooth.

  17. #17
    Super Moderator Darsithis's Avatar
    Join Date
    Jan 2011
    Location
    Chicago
    Posts
    33,655
    We can stop necro'ing this thread



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •