1. #1
    Bloodsail Admiral Devorawn's Avatar
    Join Date
    Aug 2010
    Location
    England
    Posts
    1,071

    Unexplained Lag - Please Help!

    I recently set my computer to factory setting to clear it up since it was getting a bit full, re-installed SW:TOR and I was running at a constant 30FPS+, normally around 40.

    The other day I logged in on my level 4 Warrior, suddenly everything was lagging. My FPS was down to say 15/20and there was a small gap between clicking on something or highlighting something and it actually doing that.

    It's not my internet, i've not noticed any problems and my latency hasn't changed (around 40/50 or so) so don't even bother mentioning that.

    I'll give you an example, when i type fast I have to wait because the words and letters appearing are a few letters behind what I'm typing. Also when I mouse over an icon it'll take a second or so before it highlights. Before it would keep up just like how I'm typing this post now.

    My setting haven't changed, i play in windowed at 1920x1080, but nothing changes in full screen. Big FPS beaters like Shadows are off and my setting are generally around the low margin.

    Once again, this is a massive change, everything is uncomfortable to actually do and it's not a small change like an FPS drop of 4 or 5 it's been really noticable.

    Anyway, this all started happening a few days ago and it's still going on, does anyone have any suggestions? I'm not looking for ways to increase my FPS, i'm sure this isn't just because my PC isn't super powerfull, like I said it was running fine a few days ago and now everythings gone tits up.

    Thanks in advance
    Desp
    If you spend your entire life getting senpai to notice you, you'll never notice anyone else.

    2philosophical4me

  2. #2
    Scarab Lord
    Join Date
    Oct 2007
    Location
    Comox Valley, BC
    Posts
    4,403
    Since restoring your computer have you installed the latest graphics drivers and chipset drivers? Did you make sure your power options are set to high performance? Have you tried a system restore to when the game was playing optimally?

  3. #3
    Bloodsail Admiral Devorawn's Avatar
    Join Date
    Aug 2010
    Location
    England
    Posts
    1,071
    If I don't get any other suggestions I'll try the restore, thanks.

    And yes, updated my drivers a few days ago, everything was working fine afterwards.

    And I'll check for high performance.
    If you spend your entire life getting senpai to notice you, you'll never notice anyone else.

    2philosophical4me

  4. #4
    Scarab Lord
    Join Date
    Oct 2007
    Location
    Comox Valley, BC
    Posts
    4,403
    Be sure your PC is clean of viruses too since they can affect the overall performance of the PC. I'd suggest utilizing the virus removal guide in my sig.

  5. #5
    Bloodsail Admiral Devorawn's Avatar
    Join Date
    Aug 2010
    Location
    England
    Posts
    1,071
    Ok, I'll give it a look, thanks
    If you spend your entire life getting senpai to notice you, you'll never notice anyone else.

    2philosophical4me

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •