Page 56 of 66 FirstFirst ...
6
46
54
55
56
57
58
... LastLast
  1. #1101
    Should just get a HD7950. You can find it for less than 300 USD atm and it is amazing bang for the buck.

  2. #1102
    I am Murloc! Xuvial's Avatar
    Join Date
    Apr 2010
    Location
    New Zealand
    Posts
    5,040
    The price wars are pretty intense right now, so get whatever you can find at the lowest price - 7870, 660Ti and 7950 should all perform very close to each other in GW2.

    IN THEORY.

    Because the game is having batshit unpredictable performance right now, it's mostly smooth for me but I still get huge fps drops out of nowhere.

  3. #1103
    Quote Originally Posted by Razoril View Post
    Hi guys wondering how you guys think this setup will perform at 1920x1080

    i52500k at 4.5GHz
    4870x2
    16gb ddr3 1333mhz
    Check out my post above yours.

    I'm getting terrible results from my system and we're in a pretty similar situation, processor aside.

  4. #1104
    Now obviously I'm not looking to run the game at ultra with my desktop "computer," but I would appreciate it if somebody could give me an FPS guess on everything low/disabled if at all possible:

    CPU: AMD 64 X2 4600+ 2.4 gig
    GPU: GeForce 7900 GS
    3 Gigs of Ram

    And hey, if that sounds nearly exactly like the minimum system requirements, that's because it is. It should be noted that the fps estimation would also be for a 1024x768 resolution (or worse if it's allowed), because hey, my monitor sucks also.

  5. #1105
    Herald of the Titans Jigain's Avatar
    Join Date
    Dec 2011
    Location
    Sweden
    Posts
    2,718
    Quote Originally Posted by Xuvial View Post
    Latest beta drivers are 306.02 (nVidia) and Catalyst 12.7 (AMD).
    Overall a very good and informative post, but I have to correct you here. I've been running Catalyst 12.8 for about two weeks now. :P

    http://support.amd.com/us/kbarticles...easeNotes.aspx

  6. #1106
    I am Murloc! Xuvial's Avatar
    Join Date
    Apr 2010
    Location
    New Zealand
    Posts
    5,040
    Eeek I made a whoopsie, thanks. Turns out AMD's beta drivers are behind their official drivers, i.e. they haven't started the 12.9 (or whatever) beta yet.

    I hate that my build-recommendation thread got merged with an extremely generic thread asking "will my pc run gw2?", my huge post got thrown onto page 54 who pretty much nobody will ever see.

    Page 54 mr. moderators, do you know how far into a thread that is? Too damn far.

    Evil mods.
    Last edited by Xuvial; 2012-08-30 at 09:21 AM.

  7. #1107
    Stood in the Fire
    Join Date
    May 2010
    Location
    London, UK
    Posts
    370
    Just for general information:

    Phenom X4 960T (2 unlockable cores but not currently unlocked for stability)
    Radeon HD 6870 from Sapphire (on stock clocks to avoid giving bad advice to regular users)
    8GB Corsair XMS3 (on stock volts)
    500GB Seagate ST500DM002 (not exactly hot shit but there you go)

    I haven't defragged since install, with the constant patches going out at the moment I didn't consider it worth the time.
    All driver settings squeaky clean with no modifications. As in, "let app decide AA and AF", no vsync, no triple buffer.

    While generally out in the world I rarely drop below 50 FPS unless there's some weird "this rock has half the level's polycount and textures on it" kind of things. This has happened twice so far, dropped to 20 and when turning a little away it'd go back up to 60ish.
    Charr main city on zone in drops me to about 25 when looking out over the terrain, then goes back up to 50 once I start moving around. The Grove (Sylvari area) and Hoelbrak (Norn area) are 70 FPS+. The whole way through, not just when there's no one in there. I'm generally only online during prime time anyway (6pm-12pm).
    In story instances it's around 100-120 FPS.
    WvW is sucky, sub-20s is common when more than 100 people are around. In smaller engagements (say 20v20) I'm getting around 35-40 FPS with dips to 25 when all eles and necros decide to go off at the same time.

    I play with four of my friends and they run similar spec rigs (some on Intel, some AMD, some Ati, some Nvidia). They report, point for point, the same performance or slightly worse.

    GW2 setting that get me these frame rates:

    Resolution: Full Screen - 1920x1080
    Refresh Rate: Default (60)
    Frame Limiter: Unlimited
    Interface Size: Small
    Full Screen Gamma: 1.00
    Settings Preset: Auto-detect
    Animation: High
    Anti-Aliasing: None
    Render Sampling: Default
    Textures: High
    Environment: High
    Shadows: Low
    Shaders: High
    Reflections: Terrain and Sky
    Post Processing: Medium
    Vertical Sync: OFF
    High Res Character Textures: ON
    Enable Stereoscopic Rendering: OFF

    Points of improvement: Turning shadows off helps about 10-15 fps in general, doesn't help WvW much (as expected, same as in most games). Turning reflections off helps a lot in places with water but not my general frame rate. High Res Character Textures setting doesn't help / hurt at all.

    I'll have a go at trying out a combination of driver settings and GW2 settings, I think I can squeeze out maybe 10 fps more in general. Obviously the game is well playable and though I haven't done any of the SPVP yet, I'm confident that I'll get good FPS in there. The issue really is the WvW. Other than that the game's been an absolute breeze and only when I actually started recording my FPS (not with fraps or anything, just using the old trusty pen and paper + options screen) that I noticed the dips. The game is smooth save for the Charr city really.
    Last edited by KtN; 2012-08-30 at 10:53 AM. Reason: missed some words, mang

    If you wanted skill-based PvP, why didn't you start playing DotA?
    GENERATION 26: The first time you see this, copy it into your sig on any forum and add 1 to the generation. Social experiment.

  8. #1108
    Quote Originally Posted by Jigain View Post
    Overall a very good and informative post, but I have to correct you here. I've been running Catalyst 12.8 for about two weeks now. :P

    http://support.amd.com/us/kbarticles...easeNotes.aspx
    He's right too .

    My 4850 gains nothing from 12.8 or 12.7, 12.6 ftw! Jk need new card.

  9. #1109
    Looks like folks are into debating rather than actually helping folks out in some cases. lol. Replaced my AMD X2 255 with a X6 1045T. That was my bottleneck. I know get 50-60 frames on average and at times it will shoot up over 70.

  10. #1110
    So I'm curious if anyone else is getting random split second artifacts with their AMD card, and if you're not, what driver version are you on? I suspect it's either a problem with GW2, or AMD drivers. I know for a fact it isn't my 7970, since every other game is fine, and I can put it through Kombustor and Furmark with absolutely no issues.
    Last edited by nbm02ss; 2012-08-30 at 09:22 PM.

  11. #1111
    Hello all i am needing help n deciding which to upgrade first for guild wars 2 my CPU or graphics card my specs are
    Processor AMD Athlon II 250 x2 250 processor 3.00 GHz
    4.00 GB ram
    Graphics card geforce gt 240

  12. #1112
    Hey guys.. Have a quick question about GW2.. I haven't gotten it yet.. Would like to know how much FPS i should expect with a:

    2.4 GHz Core 2 DUO
    4 GB of Ram
    260 GTX Nvidia w 2G Ram
    Windows 7 64 Bit

    Would the gameplay be choppy for me? at say medium settings with shadows disabled? Let me know.. Thanks

  13. #1113
    I have the feeling that my PC is either way under performing or people aren't being truthful about their settings under which they are reporting extremely high and stable fps.

    My current system:

    Intel Core i7 2600k @ 3.4ghz
    MSI Geforce GTX 660 Power Edition OC
    8gb ram
    Asus Maximus Gene-Z z77 mobo
    Gaming @ 1680x1050 resolution
    306.02 Nvidia Drivers

    I'm currently just questing in the Charr starting area, my settings are as high as they possibly can be. This includes supersampling and FXAA, if it can be turned to an ultra setting it is. I'm getting anywhere from 18-68 fps as I move through the zone, rotate my camera, or engage in combat. I would say my average is around 45 fps. Ambient occlusion is turned on in the nvidia control panel as well.

    I just purchased the 660ti and I'm pretty disappointed with its performance. Is my FPS where it should be for my system? Does anyone know if I could have made a better video card purchase in the $300 to $350 price range?

  14. #1114
    My Computer Spec Is
    Motherboard: Foxconn A74GA
    Operating System: Windows 7 Ultimate 64-bit
    Processor: AMD Athlon(TM) II X2 B22 Processor 2.80ghz
    RAM: 6GB DDR3 PC3-10600
    Video Card: Sapphire AMD Radeon 6450 1GB DDR3
    Resolution: 1440 x 900
    Fraps On: 10-15fps
    Fraps Off: 25-30 *sometimes a little less depending the place and i can WvWvW*

    I made this video yesterday for friends to check out the pvp part of guild wars 2 and how it looks its not the best but gives them a idea. With fraps i was running 10-15fps without i run 20-30 depending where i am at but mostly around 25fps.

    what is holding me back is my CPU cause its a duel core and i plan to upgrade it at some point.
    I made this computer on the cheap cause i wanted to play diablo III and Guild wars 2 and didn't matter to me if it was on max settings. cost me around 220$ total my Dvd buner/HD was gave to me and i already had a custom case. Not the best in the world but runs the game really well for what it is.
    *remember to watch the video in 1080p if u can*

    Edit: fraps was making the loading screens longer then they should be so i did edit them a little.


    Edit: for those still not sure go to http://www.systemrequirementslab.com/cyri/intro.aspx and chose guild wars 2.
    Last edited by Jtbrig7390; 2012-08-31 at 01:13 AM.
    My Youtube: http://www.youtube.com/user/jtbrig7390
    PSN: Jtbrig7390
    Nintendo ID: Jtbrig7390
    XBL: Jtbrig7390 "Inactive at this time"
    My Twitch Streaming Games All The Time: http://www.twitch.tv/jtbrig7390

  15. #1115
    Legendary! Holo's Avatar
    Join Date
    Nov 2009
    Location
    In the Shadows
    Posts
    6,288
    Quote Originally Posted by Darlok View Post
    Hey guys.. Have a quick question about GW2.. I haven't gotten it yet.. Would like to know how much FPS i should expect with a:

    2.4 GHz Core 2 DUO
    4 GB of Ram
    260 GTX Nvidia w 2G Ram
    Windows 7 64 Bit

    Would the gameplay be choppy for me? at say medium settings with shadows disabled? Let me know.. Thanks
    It will run. But not likely on anything higher than the lowest posseble settings with native sampling.

    Quote Originally Posted by Needshelps View Post
    Hello all i am needing help n deciding which to upgrade first for guild wars 2 my CPU or graphics card my specs are
    Processor AMD Athlon II 250 x2 250 processor 3.00 GHz
    4.00 GB ram
    Graphics card geforce gt 240
    Same as above, you are able to run the game, but going above the lowest settings is just going to cripple you in competative play.
    Last edited by Holo; 2012-08-31 at 12:51 AM.

    i5-3570k @ 4.4GHz|8GB DDR3 1600MHz|EVGA GTX 670 FTW x2 SLI|Samsung 830 128GB SSD

  16. #1116
    Quote Originally Posted by Holo View Post
    It will run. But not likely on anything higher than the lowest posseble settings with native sampling.



    Same as above, you are able to run the game, but going above the lowest settings is just going to cripple you in competative play.
    Really is it that bad? Lowest settings? eeek :\ That sux... Debating whether to give the game a try or not with those options.. Not really sure yet.. But thanks

  17. #1117
    Quote Originally Posted by Darlok View Post
    Really is it that bad? Lowest settings? eeek :\ That sux... Debating whether to give the game a try or not with those options.. Not really sure yet.. But thanks
    check out my video and spec above im slightly better then u on CPU and not sure about GPU but it should give u a idea.

    edit: also go to http://www.systemrequirementslab.com/cyri/intro.aspx see if u meet the min spec.
    Last edited by Jtbrig7390; 2012-08-31 at 01:12 AM.
    My Youtube: http://www.youtube.com/user/jtbrig7390
    PSN: Jtbrig7390
    Nintendo ID: Jtbrig7390
    XBL: Jtbrig7390 "Inactive at this time"
    My Twitch Streaming Games All The Time: http://www.twitch.tv/jtbrig7390

  18. #1118
    MS Windows 7 Ultimate 64-bit
    CPU: Intel Core 2 Duo E7300 @ 2.66GHz
    RAM: 4.0GB Dual-Channel DDR2 @ 398MHz (6-6-6-18)
    Motherboard Dell: Inc. 0RY007 (Socket 775)
    Graphics: NVIDIA GeForce 210

    Can I run it on atleast lowest settings? System Requirements Lab says i'm good but I'd like to get some more input.
    Last edited by Johnx014; 2012-08-31 at 03:07 AM.

  19. #1119
    Quote Originally Posted by Johnx014 View Post
    MS Windows 7 Ultimate 64-bit
    CPU: Intel Core 2 Duo E7300 @ 2.66GHz
    RAM: 4.0GB Dual-Channel DDR2 @ 398MHz (6-6-6-18)
    Motherboard Dell: Inc. 0RY007 (Socket 775)
    Graphics: NVIDIA GeForce 210

    Can I run it on atleast lowest settings?
    ya u should be able to like i told the other guy check out my video able and my system spec and if u want compare ur Nvidia to my AMD Readon 6450 and see what u find. like google or youtube things comparing them. but yes u should be able to low it on a mix of low/mid depending the setting.

    but i would say mostly low settings questing u should be fine but WvWvW and really high pop citys u may down hard in fps.
    Last edited by Jtbrig7390; 2012-08-31 at 02:41 AM.
    My Youtube: http://www.youtube.com/user/jtbrig7390
    PSN: Jtbrig7390
    Nintendo ID: Jtbrig7390
    XBL: Jtbrig7390 "Inactive at this time"
    My Twitch Streaming Games All The Time: http://www.twitch.tv/jtbrig7390

  20. #1120
    Herald of the Titans Jigain's Avatar
    Join Date
    Dec 2011
    Location
    Sweden
    Posts
    2,718
    Quote Originally Posted by nbm02ss View Post
    So I'm curious if anyone else is getting random split second artifacts with their AMD card, and if you're not, what driver version are you on? I suspect it's either a problem with GW2, or AMD drivers. I know for a fact it isn't my 7970, since every other game is fine, and I can put it through Kombustor and Furmark with absolutely no issues.
    Occasionally, yeah - but so far I've assumed it's because Crossfire isn't fully supported yet. I run 2xSapphire Radeon 6950.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •