1. #1
    Dreadlord joepesci's Avatar
    Join Date
    Sep 2010
    Location
    Germany (EU Outland)
    Posts
    782

    [Solved] Shift modifier focus macro

    I'm trying to make silencing shot hit my current target, or if I also press Shift it should hit my focus target instead. It just doesn't work, searched google for half an hour now.

    Latest version I found:

    #showtooltip silencing shot
    /use [mod:shift,@focus] silencing shot
    /use [nomod,@target] silencing shot

    I can silence my current target, but it does nothing when I press shift.

    Also seen this version:
    /cast [@target,nomod] silencing shot
    /cast [@focus,mod:shift] silencing shot

    None of them work. Must be something with the shift button...

    /edit: yeah it works when I put in "alt" instead of "shift", but why?
    Last edited by joepesci; 2012-03-05 at 06:14 PM.

  2. #2
    Moderator Sj's Avatar
    Join Date
    Jan 2011
    Location
    New Orleans
    Posts
    5,752
    You need [nomod:shift] in your version of the macro, but you can simplify it.

    Try this:

    /cast [mod:shift, @focus] Silencing Shot; Silencing Shot

  3. #3
    The Lightbringer
    Join Date
    Feb 2012
    Location
    Silvermoon City
    Posts
    3,661
    Silly questions, but:
    - Is your shift+X (X being the macro button) bound to something else?
    - Issues with German client maybe (idk if you use one, just that you're from Germany).

  4. #4
    Dreadlord joepesci's Avatar
    Join Date
    Sep 2010
    Location
    Germany (EU Outland)
    Posts
    782
    Quote Originally Posted by Tomana View Post
    Silly questions, but:
    - Is your shift+X (X being the macro button) bound to something else?
    Yes, shift+2 was bound in the default wow key bind settings to some action bar thing. I removed that, and now my macros work. Thank you!

    I have two layers of macros anyway, as I use the Logitech G13 insteand of a Keyboard, but those are "hardware" macros, where a G13 key is assigned to be the shift key for example. It didn't have to do with this anyway, as you found the issue I had.

  5. #5
    Use a macro format like this first of all.

    Code:
    #showtooltip
    /cast [mod:shift,@focus][]Silencing Shot
    Also check of course that the key is unbound. Easiest way is bind Shift+Button to Move Forward, then bind it back to W so for sure it's cleared.

    Also check your Interface -> Combat options to check that Shift isn't set to cast on your Focus or Self Cast which could mess things up.

    Edit: Glad you found the issue.

    Gershuun @ Borean Tundra US - Interface & Macros Moderator

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •