1. #1

    Post auto tabbing me out of wow

    Any Idea why this is happening to me?

  2. #2
    Two guesses:
    1) Your "Alt" key became "stuck" [the OS did not register the KeyUp event and still believes the key is held down]. Thus, pressing Tab will register as Alt-Tab and switch you out of WoW. Simply press the Alt key once and release it to fix this.
    2) Some other window is taking focus. What window is focused when WoW minimizes?
    UI & AddOns expert | Interface & Macros moderator - My work

  3. #3
    Ok i used a different keyboard and that didn't help it still auto tabs me every 3-10mins.
    I also don't have any other window opened or other programs running that i know of. All i have is wow opened.

  4. #4
    Quote Originally Posted by Treeston View Post
    Two guesses:
    1) Your "Alt" key became "stuck" [the OS did not register the KeyUp event and still believes the key is held down]. Thus, pressing Tab will register as Alt-Tab and switch you out of WoW. Simply press the Alt key once and release it to fix this.
    That doesn't happen to me often, but when it does, it's always during inopportune times. "Oh, I just pull a pack of mobs, and I was holding down alt because I like to macro alt-toggle frequently used abilities, and I hit tab to change targets... oh, gee, I'm not looking at WoW now while that pack of mobs is smacking me around. /nerdrage! "

    That, or having fat-finger syndrome and hitting that stupid ass window key "conveniently" stuck between the Ctrl and Alt key.

    As to the OP, if it is random, yeah, that sounds like something is taking focus, like your browser might have been loading up something in the background/auto refreshed/etc and once complete, it tried to auto-focus to that.

  5. #5
    My antivirus likes to tell me that it's out of date during every hour of twilight ever.
    i5 2500k Powercolor HD 6950
    8gb 1600mhz RAM
    96gb Kingston SSD, 1TB Caviar Black 64mb cache
    Basic P67 motherboard
    800 watt PSU
    NZXT Phantom Case: If you think this case is ugly, you are wrong.

  6. #6
    So how do you check what is taking focus? Can it be done in Windows Task Manager some how?

  7. #7
    I have the same problem but its not just with WoW. It happens with any game even when nothing is open in the background, it will just go to my desktop for no reason. Been going on for about a year now and havent been able to find any viruses or anything so ive just learned to live with it.

  8. #8
    So what your saying is get a new computer? There has to be a way to fix this problem.

  9. #9
    Quote Originally Posted by kinglock View Post
    So what your saying is get a new computer? There has to be a way to fix this problem.
    There will be a way. A bug in the operating system is software only, you have no need to get a new computer.

    Something has got to be taking focus and alt-tabbing you. Open msconfig (Start -> type msconfig (in the little search bar) -> startup -> un-tick all the programs you don't use or recognize) and restart see how it goes.

    Heck it could be a display driver issue, update your graphics drivers.

  10. #10
    Quote Originally Posted by Fawxey View Post
    Something has got to be taking focus and alt-tabbing you. Open msconfig (Start -> type msconfig (in the little search bar) -> startup -> un-tick all the programs you don't use or recognize) and restart see how it goes.
    Had the same problem as you a while back, what Fawxey said is exactly what I did back then, and it worked like a charm for me.

    Another option might if you use VMware and you pressed alt while not actually ''in'' the virtual server, wich gets your Alt key stuck in pressed down. But restarting the computer usually fixes that, wich I'm sure you've done already.

  11. #11
    Stood in the Fire uzumati's Avatar
    Join Date
    Sep 2010
    Location
    Zul'jin
    Posts
    466
    I noticed this after the Latest ATI update but it only does it once or twice at the beginning when i start WoW
    Victoria Aut Mors

  12. #12
    noob question how do you update your drivers?

  13. #13
    Legendary! Asmekiel's Avatar
    Join Date
    Sep 2010
    Location
    Maybe over there
    Posts
    6,654
    nVidia --- Ati

    Select from which company your card is, follow the instructions, download the driver and install.

  14. #14
    thanks all my shit is updated and i went through msconfig and got rid of some of the startup stuff but its still doing what the OP described... sometimes it will be like every 10 minutes and then sometimes its like once every 45 minutes.. i used malwarebytes to scan for malware and then have avast antivirus and that came up with nothing as well. i mean like i said i have gotten used to it but it would be nice to have it fixed if anybody has anymore suggestions to try.

  15. #15
    This is an old Post but i have had this recently happen to me and was able to get it to stop, so i wanted to post it because there is little information on the web with solutions to correct this. This does not actually fix the issue but only stops the auto tabbing. Just to clarify when i say auto tabs, i am not pressing any buttons or the key is stuck, but the OS is "auto focusing" to another running process.

    Issue: Windows auto tabs to another running process while wow or any other application is running.

    Discovery: Using "Task Manager" in windows to view the list of running applications at small intervals a application would pop up and then disappear after no more than about a sec. With the help of ALT- Print Screen and Photoshop i was able to determine that the application was "wermgr.exe". This process is a service that windows reports errors in your system and this was what being auto focused to. I found a post on Techguy.org with a user having a similar issue with this process and posted this solution to stop the reporting and end the auto focusing(auto tabbing)

    Here is what he said:

    Try disabling the Windows Error Reporting service:
    Press the Windows key + R to open a Run box.
    Type services.msc
    Press Enter.
    Scroll down to the Windows Error Reporting service. Double-click it, Stop it and Disable it.

    To disable it i had to right click the process and click on the properties and then choose "Disable" from the pull down menu.

    Since I have done this, its been about an hour and no auto focusing and i was able to write this without any interruptions.

    I hope this helps someone.
    Thanks
    Nightvale

  16. #16
    Have you ever installed autohotkey (AHK) on this computer?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •