1. #1

    Diablo 3 Windowed Mode

    Hey guys, I really need some help on how to get the Diablo 3 to run in a smaller windowed mode than its fullscreen. I play on a 32" (I think) Samsung TV and I think its the resolution or something to do with the size of the game my TV goes black and says "Mode Not Supported" and I have to close Diablo 3 afterwards with Alt Tab. I tried putting -w on the shortcut path in the properties section of the Diablo 3 shortcut, but that didn't work. Anyone know a solution or can help me out with this problem?

    Thanks a lot.
    Enigmaz.

  2. #2
    Bloodsail Admiral Blackspur's Avatar
    Join Date
    Oct 2010
    Location
    United Kingdom
    Posts
    1,180
    Put it in windowed mode? Options > Video > Display > Windowed. Then you can resize it to how you want.
    Amazing signature created by Caiti
    Warlock since '06

  3. #3
    Quote Originally Posted by Blackspur View Post
    Put it in windowed mode? Options > Video > Display > Windowed. Then you can resize it to how you want.
    Is that in game? Because I don't even get to that stage if it is. I open the launcher, click play and as its trying to load the game, it just goes black and says "Mode Not Supported" as its trying to go fullscreen. I'm just wondering if anyone else knows about this "Mode Not Supported" thing on a Samsung TV and how I can make Diablo 3 minimized without actually getting into the game.

    Hope that makes sence
    Enigmaz

  4. #4
    What resolution are you using natively? Try lowering it in windows and opening the game and see if that helps.

  5. #5
    Bloodsail Admiral Blackspur's Avatar
    Join Date
    Oct 2010
    Location
    United Kingdom
    Posts
    1,180
    Quote Originally Posted by Enigmaz View Post
    Is that in game? Because I don't even get to that stage if it is. I open the launcher, click play and as its trying to load the game, it just goes black and says "Mode Not Supported" as its trying to go fullscreen. I'm just wondering if anyone else knows about this "Mode Not Supported" thing on a Samsung TV and how I can make Diablo 3 minimized without actually getting into the game.

    Hope that makes sence
    Enigmaz
    It is on the main menu where you log in, not much I can help with if you cant even get to that point.
    Amazing signature created by Caiti
    Warlock since '06

  6. #6
    Moderator Shamanic's Avatar
    Join Date
    Jul 2009
    Location
    Cardiff, Wales
    Posts
    10,311
    Have you tried

    -window

    at the end of the shortcut instead of just -w?
    Moderator of Professions | General Discussion | Diablo 3 | Guild Wars 2
    Please take the time to read the Forum Guidelines & Sig Guidelines

    Currently playing: Wildstar | Elder Scrolls Online | Diablo 3 | LoL | Hex TCG
    Steam | Twitter

  7. #7
    Quote Originally Posted by Skrototem View Post
    What resolution are you using natively? Try lowering it in windows and opening the game and see if that helps.
    My current screen resolution is 1366 x 768 I tried lowering it and my screen just went black lol. Had to restart my PC and it went back to normal, wierd o.O.

    ---------- Post added 2012-04-21 at 05:42 PM ----------

    Quote Originally Posted by Shamanic View Post
    Have you tried

    -window

    at the end of the shortcut instead of just -w?
    Yeah I tried this, I ran the client and pressed play again and it just went black and said "Mode Not Supported". I can hear the sounds of the game though lol but no game showing..

  8. #8
    Try to set it in the config file. Should be located at C:\Users\<your username>\Documents\Diablo III

    Look for the line "DisplayModeWindowMode "0" and set it to 1.

  9. #9
    Quote Originally Posted by Calz View Post
    Try to set it in the config file. Should be located at C:\Users\<your username>\Documents\Diablo III

    Look for the line "DisplayModeWindowMode "0" and set it to 1.
    I love you. Cheers mate<3333333333

  10. #10
    Quote Originally Posted by Calz View Post
    Try to set it in the config file. Should be located at C:\Users\<your username>\Documents\Diablo III

    Look for the line "DisplayModeWindowMode "0" and set it to 1.
    Sorry if this is counted as a necro bump but, this guy just fixed the problem i've been having for 3 hours. Thanks so much man.

  11. #11
    Herald of the Titans Yakobro's Avatar
    Join Date
    Nov 2010
    Location
    England
    Posts
    2,620
    Quote Originally Posted by Calz View Post
    Try to set it in the config file. Should be located at C:\Users\<your username>\Documents\Diablo III

    Look for the line "DisplayModeWindowMode "0" and set it to 1.
    You can also change the resolutions there to run smaller than fullscreen windowed.
    Mine was setting it to 1080p no matter what I selected.

  12. #12
    thx, that worked for me too. My videocard won't work in full screen mode. Thanks do this i can still play diablo 3.

  13. #13
    This (like every other game) is unpolayble without without windowed mode.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •