1. #1

    D3 Installer Stopping @ 42%

    This is on Mac System, i've closed to and tried again and at 42% it has happened again.



    (SORRY FOR THE BABY HEAD, DAMN BROTHER ALWAYS TRYING TO SHOW OFF!)

  2. #2
    Have you tried the digital download? If you activate your account with your physical CD key you should be able to download the digital version free of charge with plenty of time to spare. This is assuming of course your actually using CD's like the error message suggests.

  3. #3
    This is from the Downloader i got from the Battle net website, i haven't purchased the game, its from Annual Pass.

  4. #4
    With mine I've had to reinstall the downloader, tome3 didn't download right or something because it kept getting to a point and saying that tome3 is broken and to fix it

  5. #5
    I installed the NEW Installer thingie this morning, was an 7.6gig downloader. So i'm sure that cannot be the problem

  6. #6
    Could possibly be an issue with the Mac version of the installer. Are other peeps on B.net having the same issue?

    I am using the downloaded installer too(windows version though). Currently at 77% getting the launch day patch.

    Hope it gets sorted soon. Good luck.

  7. #7
    getting stopped at tome 2 on my stationary pc, got stopped at tome 3 on my laptop....

  8. #8
    dont just download new installer, make sure you run it as well as being in same directory as before, it will download a small file, maybe your missing that ?
    "Have you had the dream again? A black goat with seven eyes that watches from the outside."

  9. #9
    Epic! Blockygame's Avatar
    Join Date
    Jul 2011
    Location
    Shrike Abyssal
    Posts
    1,565
    I didn't get past 1% for some reason getting the same message, trying to install from folder, went to my account and just got the downloader from there and now it seems to be going fine, still a while to go though.
    HOOKED ON DIABLOL, GOOD TIMES ARE BEING HAD

  10. #10
    If you get the disk error check your D3 map and check if there are files that end with .part

    If you have that redownload the installer to the same map because its not finished. I had to do that 3 times and then It worked for me.

  11. #11
    http://eu.battle.net/d3/en/blog/4410912/ get this and download it to the location of your current installer. Although you mention you already downloaded the new one, so this will probably do nothing

  12. #12
    Thanks for all the tips, however this baby is still messing me around, so i have deleted everything, again, and am currently downloading the Setup thingie again. Hopefully get this thing to work! :P

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •