1. #1
    Pandaren Monk Fred the Hunter's Avatar
    Join Date
    Apr 2010
    Location
    United States & Germany
    Posts
    1,985

    Exclamation Razer Naga 2012 Issue

    So I got a the Naga 2012 last week and it works great.. But sometimes it'll run into an invisible barrier as if it was at the edge of the screen and can't move any further. In addition sometimes it will skip around when I click or just have my mouse over another tab.

    I used the original Naga, Deathadder and Logitech G500 without ever having this problem. If it matters at all I am using the Razer Goliathus Control mouse mat. I have also tried plugging it into other ports on the computer.

  2. #2
    Fluffy Kitten Marest's Avatar
    Join Date
    Aug 2009
    Location
    Sweden
    Posts
    4,232
    Sounds like a bug or firmware issue. Have you tested with another mouse to see if the issues persists?

  3. #3
    Pandaren Monk Fred the Hunter's Avatar
    Join Date
    Apr 2010
    Location
    United States & Germany
    Posts
    1,985
    I have and it appears to only be happening with the new Naga 2012.

  4. #4
    Sometimes you just get a lemon. I got one last year and had to exchange it the day after I bought it because I was having right click issues, and the new one hasn't given me any problems.

    I get the 'invisible wall' thing sometimes too, but it's because there's a dog hair in the laser.

  5. #5
    The Lightbringer CheezusCrust's Avatar
    Join Date
    Feb 2011
    Location
    Nuuk, Greenland
    Posts
    3,338
    Return it & get a replacement, Razer tends to sell faulty equipment.
    i5-4670k 4.2GHz | EVGA GTX 980 | 16GB Kingston HyperX | 256GB 840 EVO | Corsair H100i | Noctua IndustialPPC
    ASUS PB298Q 4K | 2x QNIX QH2710 | CM Storm Rapid w/ Reds | Steelseries Rival | Schiit Stack w/ Sennheiser HD8

  6. #6
    Mechagnome Stravs's Avatar
    Join Date
    Jul 2011
    Location
    Uk Cumbrian Lake District
    Posts
    728
    Is this the Epic Naga? And are you using it wireless? I get a little twitching sometimes with mine but its dust on the lazer. I did have a problem you describe whilst using it in wireless mode but that was an easy fix with the latest Firmware.
    i5 2500k @ 4.2ghz-Asus Sabertooth P67 B3 8gb Corsair XMS-3
    EVGA GTX 670 4tw 4gb
    CreativeX-Fi Titanium Pro paired with (Corsair SP2500)
    Corsair HX850
    250gb Samsung 840 ssd
    Silverstone Raven 3

  7. #7
    Warchief sizzlinsauce's Avatar
    Join Date
    May 2010
    Location
    Bellforest, Tower state
    Posts
    2,139
    I've got the razor naga molten edition and it does the same thing once a month or something. check make sure nothings on the laser.

  8. #8
    Blademaster
    Join Date
    Jun 2012
    Location
    Canaada
    Posts
    35
    I'm using the molten as well. Try updating the firmware. Not the drivers, but specifically the firmware.

  9. #9
    the invisible wall problem is a something in the laser like they said, but twitchyness might be a firmware problem, I bought a naga epic and after having to sadly exchange the first one I double patched the firmware of the second one and finally got it to work. I love my naga and razer makes so well designed products but they have a tendancy to be a bit buggy or require an extra step in care to get them to truly work properly.
    Side note anyone else find that the naga is a dust trap from hell, no mattter how much i dust off my desk and mouse pad the bloody thing gets caked up dust in all it's grooves with in secs anyone have a suggestion for that?

  10. #10
    Had the same issue with mine. Had to get a replacement, 'cause it was broken. So, just go get a new one :O

    Too bad there're so many faulty Nagas out there. Of the 3 I bought so far, all 3 went nuts after 2-6 months. Had the wall-bug twice and my current one always double-rightclicks, even thou I hit the "button" just once.

  11. #11
    weird the double right click is usually from a mouse aging and the switch getting worn out, actually the reason I finally got a naga was my old Logitech Mx700 had been doing that for months as well as not clicking when i needed it to.
    the problem i was having with my first naga was sensitivity would drastically change on a whim(yes I know changing it on a whim is a function you can have set up no it wasn't enabled and it wasn't changing on anything i did in particular), it wouldn't always charge and the wired functionality wasn't working so when it did die I couldn't plug it in and keep playing.
    Second one wouldn't run wireless at first but then i updated the firmware and it stopped running wired then i found a second firmware update( it aparently has a wired and wireless firmware update) and that fixed the problem.
    Both have had the invisible wall but like i said that's just a matter of debris in the laser.

  12. #12
    Pandaren Monk Fred the Hunter's Avatar
    Join Date
    Apr 2010
    Location
    United States & Germany
    Posts
    1,985
    Just tried to run the Firmware Updater as suggested and I'm getting "No Naga Mouse detected".

    Also, it's not the Epic, it's the 2012 edition of the regular Naga. Clicky

  13. #13
    Yahh I was just saying what I had to do to make my razer products work, there is currently no firmware updater for the Naga 2012 it's still too new. So what ever firmware updater you grabbed was for the wrong naga. Have you tried contacting their tech support team, they're pretty useful and have a good sense of humor. not that good sense of humore helps fix it but you know what I mean.

  14. #14
    High Overlord Reaped's Avatar
    Join Date
    Feb 2012
    Location
    Graveyard
    Posts
    113
    you sure its not just a hair over the laser? i got a naga and this happens quite alot to me (invisible barrier) its usually a hair thats stuck in the middle of the laser circle.

    My Char - Signature made by Shyama

  15. #15
    I love you for reminding me of Firmwares! I had an issue that I unplugged my Naga on accident while switching profiles, so it wouldn't respond any click lesser than 1 second. Thankfully, installling the firmware 1.04 fixed that issue!

  16. #16
    Quote Originally Posted by BleedingHollowVeteran View Post
    But sometimes it'll run into an invisible barrier as if it was at the edge of the screen and can't move any further.
    this sounds like there's a hair or something under your laser. clean it and it should be gone.

  17. #17
    Pandaren Monk Fred the Hunter's Avatar
    Join Date
    Apr 2010
    Location
    United States & Germany
    Posts
    1,985
    I called Razer today about the Firmware updater about it saying I didn't have a Naga connected, and according to the person I talked to,
    Synapse 2.0 updates itself. So the Firmware Updater is useless. (at least for the Naga 2012)

    I also found that it was just a cat hair in the laser as well. Strange how that never happened with my other mice. '


    Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •