Thread: Low FPS!

  1. #1

    Low FPS!

    Hi everyone. I come to you today with a huge problem of mine, and I would be glad if you could point out what could cause the issue, and how it could be solved.
    I have recently started playing wow again ( yay ) and as soon as I logged in, I noticed my gameplay was laggy, I checked the connection, and it was pretty good ( about 70 ms home 80 ms world latency ), so I went on and checked my fps, noticing they had dropped to 6 fps.
    I immediately set my graphic options to low, but not much changed, and I only reached the quote of 15fps. I went on and downloaded new video drivers, I set my Cache, Interface and WTF folders to CacheOld, InterfaceOld and WTFOld, and disabled all addons. Still no change, and my gameplay was boring as hell due to the lag.
    If any of you could be so kind to help me out here, I would be very grateful
    Thanks a lot anyways ^^

    P.S.
    Here are my system informations
    Win Vista 32 bit version
    3.07 GB RAM
    Nvidia Geforce 9500 GS
    (I'm not good at computers so tell me whatever else you need to know :P and thanks again)

  2. #2
    I have a powerful iMac and I had the same issue. The thing to look for (for me anyway) was the Resolution I was running it at. I ran World of Warcraft at 2560 x 1440 (Wide) and I barely got 30 FPS. I now run at 1920 x 1080 (Wide) and have a much smoother experience.

    Also one thing to remember is that World of Warcraft has massively updated their graphics in the last year or two. What was Ultra in Wrath of the Lich King, is now actually between Good & High.

  3. #3
    Quote Originally Posted by Hyve View Post
    I have a powerful iMac and I had the same issue. The thing to look for (for me anyway) was the Resolution I was running it at. I ran World of Warcraft at 2560 x 1440 (Wide) and I barely got 30 FPS. I now run at 1920 x 1080 (Wide) and have a much smoother experience.

    Also one thing to remember is that World of Warcraft has massively updated their graphics in the last year or two. What was Ultra in Wrath of the Lich King, is now actually between Good & High.
    Yeah I remember my graphs in Wotlk were set on high and I had a great gameplay experience ( No lag at all, game running smoothly ) Ill try setting the resolution in another way now, thanks

    ---------- Post added 2012-06-29 at 01:29 PM ----------

    It didn't really work, I fixed it from 1440x900 (wide) to 1152x720 (wide) but my fps only got up to 20/21 perhaps it's a video card problem?

  4. #4
    My first suggestion would be if you had recently updated your Nvidia drivers, to try rolling back to a previous version.
    The newest version has caused significant performance issues with some cards, particularly with factory overclocked ones.

  5. #5
    Try updating your drivers, or downgrading if you've recently upgraded. also try deleting all your adons + wtf folders (make a backup!) and reconfigure your graphics settings, see if that helps.addons that are out of date can cause low fps in some way or another, i've had the same thing before myself. was usually recount/skada style mods that did that to me.

  6. #6
    If you are using DBM, try turning it off. especially if you are running older instances at all like ulduar, and ICC. for some reason DBM is causing my FPS to shoot down in those places and turning it off solved the issue.

    http://www.youtube.com/watch?v=IBmNL...ature=youtu.be (#1 SSB Gold run on Bleeding Hollow)
    "Your lights will go out. The darkness will envelop you. And you will fear the shadows that move within it."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •