Thread: comp freezes

  1. #1

    comp freezes

    hi all hoping some1 who knows about comps can help me i am complete noob about pcs i know nothing but i bought a new pc about year ago to come back to play wow it worked fine till bout 3 weeks ago now every now and then it freezes the screen will be frozen my char will have the casting anamation but nothing happens then it sort of speeds up like its catching up then it goes normal i would guess it happens 2-3 times a hour any help would be appreciated

  2. #2
    sounds more like internet latency issues. whats your ms?


    AddOn Author of: SpellNotReadyYet, Rune of Powa

  3. #3
    Mechagnome Stravs's Avatar
    Join Date
    Jul 2011
    Location
    Uk Cumbrian Lake District
    Posts
    728
    Sounds like an internet problem have you tried www.speedtest.net
    i5 2500k @ 4.2ghz-Asus Sabertooth P67 B3 8gb Corsair XMS-3
    EVGA GTX 670 4tw 4gb
    CreativeX-Fi Titanium Pro paired with (Corsair SP2500)
    Corsair HX850
    250gb Samsung 840 ssd
    Silverstone Raven 3

  4. #4
    thnks for replys i did the test and results are pretty bad i think lol download was 2.95 mbs and upload was 0.20 mbs

  5. #5
    High Overlord Roblivion's Avatar
    Join Date
    Dec 2011
    Location
    Virginia Beach, VA
    Posts
    173
    Quote Originally Posted by razzapool View Post
    thnks for replys i did the test and results are pretty bad i think lol download was 2.95 mbs and upload was 0.20 mbs
    Wow those numbers are eghhh... Are you on a cable connection? If so contact your provider.
    4670k @ 4.4GHz - MSI Z87 G45 - Silverstone AR03 - Gigabyte Windforce GTX 770 OC - Antec 620W High Current Gamer

    8GB Crucial Ballistix 1600MHz - Samsung 840 250GB - 1TB WD Blue - ASUS VG248QE @ 144Hz - Fractal Design Define R4 - Windows 8.1 64-Bit - Razer Death Adder 2013
    Cooler Master QuickFire Rapid MX Cherry Red Switches - Steelseries QCK+ - Logitech G930

  6. #6
    While the speeds seem bad by todays standarts, its more than enought to play WoW. I've played WoW on 512kbps 3g modem and had no problems. I suggest you run a trace route to your realm and post the results here. Then we can know is it yours connection thats bad ir is it Blizzaard's side.

  7. #7
    Mechagnome Stravs's Avatar
    Join Date
    Jul 2011
    Location
    Uk Cumbrian Lake District
    Posts
    728
    Yep it's fast enough but it's ping/latency that's the killer :/
    i5 2500k @ 4.2ghz-Asus Sabertooth P67 B3 8gb Corsair XMS-3
    EVGA GTX 670 4tw 4gb
    CreativeX-Fi Titanium Pro paired with (Corsair SP2500)
    Corsair HX850
    250gb Samsung 840 ssd
    Silverstone Raven 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •