1. #1

    Guild wars 2 overheats my GPU to 82C :/

    im running i5 2500k and asus 5770 i updated drivers but the issue remains :/

    Settings are on auto detect generally low/mid
    Last edited by Proshitmon; 2012-09-07 at 12:24 PM.
    Live and die by the sword!

  2. #2
    Banned Lucas Ashrock's Avatar
    Join Date
    Jul 2012
    Location
    Asia (always around)
    Posts
    554
    Did you overclock the card maybe?
    Be sure to provide an adeguate environment, inside your case.

  3. #3
    As far as I can tell GW2 is kind of CPU bound at the moment, I'm only getting around 50% usage of my 6990M. So I don't see how it could overheat your card, maybe with a bad CPU?

    Secondly, 82 degrees isn't much, especially by AMD standards. When things get above 90 that's when you should start worrying.

  4. #4
    Happened with me all through the BWE's. Ive now got my graphics card fan set to running at 60% speed constantly so I no longer have the problem. Its loud, but it works.

  5. #5
    Mechagnome alteam's Avatar
    Join Date
    Aug 2009
    Location
    In your mom's bed
    Posts
    712
    82c isn't hot for that card. Maybe there is a lot of dust in the GPU-fan/pc?

  6. #6
    not sure if it applies to ati but on my nvidia had to use beta drivers to fix the issue but Gw2 on login suggests that auto good luck mate

  7. #7
    It only runs that hot in GW2 even when i open x2 diablo 3s it runs at 65c

    ---------- Post added 2012-09-07 at 12:41 PM ----------

    also it makes my CPU run hot about 68c
    Live and die by the sword!

  8. #8
    Mechagnome alteam's Avatar
    Join Date
    Aug 2009
    Location
    In your mom's bed
    Posts
    712
    Quote Originally Posted by Proshitmon View Post
    It only runs that hot in GW2 even when i open x2 diablo 3s it runs at 65c

    ---------- Post added 2012-09-07 at 12:41 PM ----------

    also it makes my CPU run hot about 68c
    68c for a CPU is pretty hot. Clean your computer. Add more fans.

  9. #9
    I am Murloc! Xuvial's Avatar
    Join Date
    Apr 2010
    Location
    New Zealand
    Posts
    5,042
    HD5770 is supposed to be a low-power card that runs cool, 82c seems pretty high considering my old HD5770 only peaked ~66c at the absolute highest under Crysis/Heaven-level stress (it was a Sapphire cooler).

    What kind of framerates are you getting on your specified settings? You can set a framerate limiter in the ingame options, limit it to 50-60 (or whatever you're comfy with) if the game is pushing out more than that.

    FYI GW2 makes almost everyone's GPU run hot. My GTX580 easily hits 79-82c,

  10. #10
    Herald of the Titans Jigain's Avatar
    Join Date
    Dec 2011
    Location
    Sweden
    Posts
    2,718
    Quote Originally Posted by alteam View Post
    68c for a CPU is pretty hot. Clean your computer. Add more fans.
    As a heads-up, never tell someone to "clean their computer"; they'll just grab a vacuum cleaner and then wonder why the computer isn't working.

    Static electricity, people.

    Buy compressed air, you can get it on a can for dirt cheap, then use that to blow the dust out of your casing every ~2 months.

    Also make sure the heatsink is properly attached, and might also be a good idea to check if the thermal paste is still okay. Be ready to replace it. Thermal paste is also dirt cheap.

  11. #11
    Enable virtual sync, keeps the temp of your card lower (because he sync the fps with your screen) and manually set the cooling of the card higher, they are always a bit low when they come from the factory.

  12. #12
    Quote Originally Posted by Proshitmon View Post
    im running i5 2500k and asus 5770 i updated drivers but the issue remains :/

    Settings are on auto detect generally low/mid
    5770 is an aging 4-5 yrs old card. That's it.
    ENGLISH ISNT MY MAIN SPEC
    YOU NOW BREATH CONSCIOUSLY

  13. #13
    Quote Originally Posted by Jigain View Post
    As a heads-up, never tell someone to "clean their computer"; they'll just grab a vacuum cleaner and then wonder why the computer isn't working.

    Static electricity, people.

    Buy compressed air, you can get it on a can for dirt cheap, then use that to blow the dust out of your casing every ~2 months.

    Also make sure the heatsink is properly attached, and might also be a good idea to check if the thermal paste is still okay. Be ready to replace it. Thermal paste is also dirt cheap.
    You're telling him not to tell people to use a vacuum, but are telling people to check the HSF...

    Point is that if someone even knew what that was they would know enough how to vacuum their PC.

  14. #14
    Warchief theWocky's Avatar
    Join Date
    Aug 2012
    Location
    South Africa
    Posts
    2,120
    If you have a factor OC (also called SOC) card, just download MSI Afterburner and set fan to 100% and down the core CPU MHz by 15~20MHz

    Problem solved.

    I had it with my Windforce 560ti OC and today, when I installed my Gigabyte 660ti, I saw the temperature increase as well. Just downloading the OC app from the Gigabyte site to clock it down as well. Haven't had issues yet, but better safe than sorry. My video card used to lose signal in BF3, Rift and GW2 before I clocked it down.

    Funny enough, I haven't noticed a heck of a difference in Rift or GW2 between the 560ti and the 660ti - looks like both games are more CPU dependant. I am sure I will see a diffference in BF3, however, so money well spent I say.

    EDIT: Soz - I just noticed OP didn't have Gigabyte 560 and 660 like I had - so, pls disregard.

  15. #15
    I am Murloc! Xuvial's Avatar
    Join Date
    Apr 2010
    Location
    New Zealand
    Posts
    5,042
    Quote Originally Posted by Jigain View Post
    As a heads-up, never tell someone to "clean their computer"; they'll just grab a vacuum cleaner and then wonder why the computer isn't working.

    Static electricity, people.

    Buy compressed air, you can get it on a can for dirt cheap, then use that to blow the dust out of your casing every ~2 months.

    Also make sure the heatsink is properly attached, and might also be a good idea to check if the thermal paste is still okay. Be ready to replace it. Thermal paste is also dirt cheap.
    Hmm? I've been building and vacuuming computers for a while now, as long as you're gentle there's absolutely nothing wrong with it.

    Last time I checked vacuum cleaners don't exactly discharge hoards of static.

  16. #16
    To all those suggesting cleaning the fans etc, be aware that I also have this issue and the inside of my PC is absolutely spotless. My CPU is watercooled, so I cant really comment on the issues of the CPU overheating, but my GPU does overheat. This issue only happens in 2 games, those being Guild Wars 2 and Tribes Ascend. The card is an AMD 6970 2Gb and I own a lot of high end games that do not give me similar issues, like Sleeping Dogs, Crysis 2, Mass Effect 3 etc. Its an issue with Guild Wars 2 and hopefully it gets rectified in the future.

  17. #17
    Running a 5870 and it never creeps above 70 >.> if you have proper cooling and aren't gaming in an 80 degree room, not sure whats different for you. Latest drivers maybe?

  18. #18
    Don't turn on Vsync, that's just silly.

    In the options menu there is one called Framerate Limiter (not a check box like the Vsync). Set this to 30 and see how the game feels and how your temps do. On my comp this drops the used GPU down to 60% or so and the game still feels fluid to me.


    As a more extreme option... you can launch the game with a -fps "Number" flag and it will limit your FPS to that number.

    Edit: I should add that the above recommendation is a workaround until your cooling/drivers/gremlins that are causing this gets resolved. I remember when Doom3 came out it used an uncommonly used part of the core and caused issues, dunno if that's what is happening here.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •