Thread: Wat is this?

  1. #1

    Wat is this?

    Ello,

    Since the new patch I see the following black squares everywhere, and no i'm not high on meth or anything . Also my xp bar is looking kinda strange.

    Pic:


    I hope someone can help me with it! Thanks in advance!

    Greetings,
    Raptar

  2. #2
    Field Marshal Holykey's Avatar
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    88
    Moin moin,
    Have you change somethink on the settings in the video option.

    Turn the shadow effekt off
    or get the hole grafik on low even then you have no black shit there..

    Your,
    Holy

  3. #3
    After trying messing with your video settings, if it doesn't fix it, I'd suggest running the repair utility.
    Moo.

  4. #4
    I'm pretty sure the repair utility doesn't exist anymore. If it does, please let me know how to access it.

    What video options are you running, as well as your graphics card?

    Try sliding the Video Options slider to low. If it's already on low, drag it around a bit so that all the settings reset.
    Try setting Multisampling to 1x if it isn't already.
    Try disabling Vertical Sync if it isn't already.
    Try setting your Graphics API to DirectX 9 if it's an option for you.

    Do any of these suggestions help?

  5. #5
    Quote Originally Posted by Yimmeryams View Post
    I'm pretty sure the repair utility doesn't exist anymore. If it does, please let me know how to access it.

    What video options are you running, as well as your graphics card?

    Try sliding the Video Options slider to low. If it's already on low, drag it around a bit so that all the settings reset.
    Try setting Multisampling to 1x if it isn't already.
    Try disabling Vertical Sync if it isn't already.
    Try setting your Graphics API to DirectX 9 if it's an option for you.

    Do any of these suggestions help?
    Tried all these things, doesn't work unfortunatly. The strange thing is, when I pust the button "Recommended settings" WoW puts it on high. I only have 17fps then, so way too low but every strange thing is gone. When I put it on good, everything is gone too... but when I put it on fair or low these strange things appear.

    Thnx for the answers btw!

  6. #6
    I think the next thing to do is figure out which setting causes the black shading.

    My guesses are one of these:
    Texture Resolution, Texture Filtering, Projected Textures, Shadow Quality, Sunshafts, and SSAO.

    If you have the time and want to figure out what the problem is, I recommend changing one setting at a time until the problem goes away, and then posting the results back here.

    ---------- Post added 2012-09-19 at 10:00 PM ----------

    I just flew over there and didn't have any problems.

    My guess is you have an overheating graphics card, old graphics drivers, or some sort of weird setting in your graphics drivers options. It's also possible that it's a problem that I don't see because I have different hardware and software.

  7. #7
    Thnx for the help mate!

    If it's possible for you to come back at this tomorrow, I would really appreciate it. I need to go to sleep because my lovely alarm goes of again at 7 o'clock.

    Night Night,
    Raptar

  8. #8
    Overheating GPU, or you need to update the drivers.

  9. #9
    It was gone this morning, but now it's back. So I think it's an overheated CPU too. Can I do anything about it? Maybe it's good to mention that I'm playing WoW on a laptop.

  10. #10
    Stood in the Fire Chaltione's Avatar
    Join Date
    Jul 2010
    Location
    Norway
    Posts
    395
    I'd recommmend downloading and installing GPU-Z and see what sort of temperatures you're getting on your GPU, and then look up what sort of temperatures are deemed good for your GPU (which GPU-Z will identify for you)

    link: http://www.techpowerup.com/gpuz/

  11. #11
    Its not an overheating GPU that would not cause the above
    thats more than likley a single setting in wow.

    The first thing to do is this
    Delete the Config.wtf file from C:\World of Warcraft\WTF (or C:\Users\Public\World of Warcraft or wherever you have it located)
    then do the following.

    firstly start in Direct X 9 mode by selecting the option from the launcher and run the 32bit client not 64
    seccondly switch your graphics settings to windowed mode full screen (better for testing not playing) and Enable Vertical Sync
    thirdly change everything to the very minimum you can and try to set the following.

    change them to this
    Multisampling x 1
    Anti Aisaling (or however you spell it) set this to 2x and work upwards
    Texture Resolution - Medium
    Texture Filtering Bilinear
    Projected Textures - Medium / high
    Shadow Quality - If you start with Super low and work upwards, if you can disable them even better
    Sunshafts - set this to off if possible, then start with the lowest and work upwards
    SSAO - disable or start with lowest and work up.


    that should at the very least help you find out whats causing it. i seriously doubt thats a hardware fault.

  12. #12
    I am also playing wow on a laptop, a lenovo z570 with nvidia 630m. I was not having these black squares at all till i updated to the most recent driver just the other day. Now I see the same thing when flying.

  13. #13
    Quote Originally Posted by Raptar View Post
    It was gone this morning, but now it's back. So I think it's an overheated CPU too. Can I do anything about it? Maybe it's good to mention that I'm playing WoW on a laptop.
    GPU, not CPU. As in your graphics unit. Your processor is probably fine, but there's no reason to rule it out if you decide to run some diagnostics anyway.

    What is your laptop model?

    Did you recently update any drivers, and if so, where did you get the updates from (manufacturer website like HP or Acer, Windows Update, Intel website, Nvidia website, etc.)?

    What do you put your laptop on when you play? Is it on a hard surface or a soft one? Is there anything blocking the air vents? Can you feel any fans pushing air out the back of your laptop?

    As someone said above, try getting GPU-Z to monitor your graphics unit. If you want to monitor your other stuff, I recommend HWMonitor. HWMonitor will give you your system temps and GPU-Z will give you your GPU temps.

    Korallis thinks it is a WoW setting. While I disagree with his assessment, I respect his opinion, and there is no harm in trying his suggestion. I recommend making a backup of your config files, though, instead of deleting them, so you can restore them later if they are not the problem.
    I recommend making a folder on your desktop called "WoW Backup Folder", and then cut + paste your Interface and WTF folders into that folder. Then delete the Cache folder.

    The reason I think it's an overheating issue is because you said it was gone this morning, but then it came back. That sounds like you turned it on, and it worked fine because the temperatures were still low from the computer not being in use, but then later in the day they came back because your computer was on longer and the temperatures built up.

    ---------- Post added 2012-09-22 at 07:25 PM ----------

    Something you might want to try. Go into the WoW options.
    Enable Vertical Sync.
    Enable Triple Buffering.
    Set the framerate limiter to 30 FPS in the foreground, and 30 FPS or lower in the background.

    If it's an overheating issue, and you just need to play, you can set those things and hopefully it will prevent your GPU from working as hard as it would normally.

  14. #14
    Thnx for the answers! Yimmeryams, like you said. I enabled vertical sync and after that, everything was instantly good again! Thnx for the help man!

    Btw, nothing is blocking the fans.. just cleaned them. My lappie is standing on a wooden table (always).

  15. #15
    It's solved. I find it nice to mention over here, because you guys helped me good . The only thing that was the problem is that I playing with Dirextx 11, it used to be Directx 9 for me. My fps went to 50 and I even can play on "good" now! Thanks again guys!

    Raptar

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •