1. #801
    Was listening to DW20's spotlight review on the new Forestry release and he stated at the end of his vid that you have to also update your Railcraft to the latest version when you update Forestry since it uses the Forestry API. According to what he said if you only update Forestry and don't do the Railcraft update also you will get a crash during early game launch. Just thought I would pass this along.

  2. #802
    LOAD"*",8,1 Fuzzzie's Avatar
    Join Date
    Nov 2008
    Location
    Legion of Doom Headquarters
    Posts
    20,318
    Quote Originally Posted by laguy442 View Post
    Was listening to DW20's spotlight review on the new Forestry release and he stated at the end of his vid that you have to also update your Railcraft to the latest version when you update Forestry since it uses the Forestry API. According to what he said if you only update Forestry and don't do the Railcraft update also you will get a crash during early game launch. Just thought I would pass this along.
    According to the changelog of Railcraft for version 6.13.0.0 it's updated for the new Forestry API. It's possible that he recorded the spotlight before these changes were made since it was only recently. The newest version of Railcraft 6.13.1.0 is available on the front page of this thread.

    ---

    Working on config updates today. Will probably post them sometime tonight after testing.

  3. #803
    Umm. Isn't that what I said? Railcraft uses the new Forestry API so if you update Forestry make sure you update Railcraft also since it uses the latest Forestry API.

  4. #804
    hope what ever is playing on your mind buggers off soon bummer to start new year on a low, and just seemed short with us or never responded to any posts did not even say happy new year back

  5. #805
    Quote Originally Posted by skedone View Post
    hope what ever is playing on your mind buggers off soon bummer to start new year on a low, and just seemed short with us or never responded to any posts did not even say happy new year back
    I am so confused or something. Is there a page missing on the forums or something? I haven't read anything even hinting at this!
    Check out what I'm selling in ESO HERE!

    Interested in joining the MMO-Champion US guild? Whisper me in-game! @greevir

  6. #806
    LOAD"*",8,1 Fuzzzie's Avatar
    Join Date
    Nov 2008
    Location
    Legion of Doom Headquarters
    Posts
    20,318
    Quote Originally Posted by laguy442 View Post
    Umm. Isn't that what I said? Railcraft uses the new Forestry API so if you update Forestry make sure you update Railcraft also since it uses the latest Forestry API.
    Cool. I may have missread.

    Quote Originally Posted by skedone View Post
    hope what ever is playing on your mind buggers off soon bummer to start new year on a low, and just seemed short with us or never responded to any posts did not even say happy new year back
    Dunno what you mean man. I do my best to get around to responding to thing but answering every post is a bit much. Sorry, I guess.

  7. #807
    So, looks like I'll be getting my server this evening. Most likely gonna stick with an FTB pack due to how easy it is to keep everyone on the same track. I really want to use Fuzzies list to do it but I think it's simply gonna be too much work to maintain it. Fuzzies list is constantly changing, evolving on a daily basis. Trying to keep a server up to date with it along with its users will be a bit much. So now I have to figure out which modpack to do. Right now it's the DireWolf20, Mindcrack, or THE SUPER AWESOME BRONY MOD PACK! (no, I will not do the Brony Mod Pack, haha) I'm pretty sure I'll move to the "Ultimate Pack" when it releases but it seems like that will be a while. The FTB team wants to wait till all the mods are "stable". And as anyone who has done Minecraft modding knows, its next to impossible to get every mod in a stable state.
    Check out what I'm selling in ESO HERE!

    Interested in joining the MMO-Champion US guild? Whisper me in-game! @greevir

  8. #808
    LOAD"*",8,1 Fuzzzie's Avatar
    Join Date
    Nov 2008
    Location
    Legion of Doom Headquarters
    Posts
    20,318
    Yeah, I wouldn't use anything but FTB or Tekkit for a server. Trying to get everyone on the same page with regular downloads is a huge undertaking.

    Also, I tested 1.4.7 today with all the most up to date mods. It lagged very badly. Check out episode 26 going up tomorrow to see what I mean. I've since reverted to a backup keeping the world and its fixed. I have no idea whats actually causing it. 1.4.7 might just not be stable in its pre-release form. I would recommend not updating just yet until I track down the issues. Going to test 1 by 1 to track it down.

    In the mean time. Working on configs after dinner. Maybe I'm just taking on too much work and that's whats stressing me. /shrug. It would be less stressful if things just worked properly for a change. lol

  9. #809
    Quote Originally Posted by Fuzzzie View Post
    Yeah, I wouldn't use anything but FTB or Tekkit for a server. Trying to get everyone on the same page with regular downloads is a huge undertaking.

    Also, I tested 1.4.7 today with all the most up to date mods. It lagged very badly. Check out episode 26 going up tomorrow to see what I mean. I've since reverted to a backup keeping the world and its fixed. I have no idea whats actually causing it. 1.4.7 might just not be stable in its pre-release form. I would recommend not updating just yet until I track down the issues. Going to test 1 by 1 to track it down.

    In the mean time. Working on configs after dinner. Maybe I'm just taking on too much work and that's whats stressing me. /shrug. It would be less stressful if things just worked properly for a change. lol
    Haha, totally feel ya man. Yeah, I tried out a 1.4.7 instance and it was really out of whack. Simply deleted it and ignored it. Will just worry about it when it releases.
    Check out what I'm selling in ESO HERE!

    Interested in joining the MMO-Champion US guild? Whisper me in-game! @greevir

  10. #810
    LOAD"*",8,1 Fuzzzie's Avatar
    Join Date
    Nov 2008
    Location
    Legion of Doom Headquarters
    Posts
    20,318
    Quote Originally Posted by Greevir View Post
    Haha, totally feel ya man. Yeah, I tried out a 1.4.7 instance and it was really out of whack. Simply deleted it and ignored it. Will just worry about it when it releases.
    1.4.7 seems to be fine with Forge and Optifine (latest) installed and just my old pack of mods. Must have been something else that I updated today that was causing the issues. Going to have to go through 1 by 1 now.

    ---------- Post added 2013-01-03 at 06:33 PM ----------

    Updated most of the mods and it still seems okay. Unless it's something small like a Logistics Pipes Update or Soul Shards update then maybe it was just me. There are a few I still have to install and test, but the major ones I did today like Forestry and Railcraft and EB,TB all seemed to not cause any issues.

    ---------- Post added 2013-01-03 at 06:55 PM ----------

    Version 1.4.0 of the config pack is out!

    This pack is now the only set of configs I'm maintaining. The old 1.0.3 pack is removed. They resolve all known item/block ID conflicts that I could find. They also address a number of recipe changes that can bee seen below the download on the main page.

    Download link: http://www.mediafire.com/?infyenbcex2rmi6

  11. #811
    Quote Originally Posted by Fuzzzie View Post
    1.4.7 seems to be fine with Forge and Optifine (latest) installed and just my old pack of mods. Must have been something else that I updated today that was causing the issues. Going to have to go through 1 by 1 now.

    ---------- Post added 2013-01-03 at 06:33 PM ----------

    Updated most of the mods and it still seems okay. Unless it's something small like a Logistics Pipes Update or Soul Shards update then maybe it was just me. There are a few I still have to install and test, but the major ones I did today like Forestry and Railcraft and EB,TB all seemed to not cause any issues.

    ---------- Post added 2013-01-03 at 06:55 PM ----------

    Version 1.4.0 of the config pack is out!

    This pack is now the only set of configs I'm maintaining. The old 1.0.3 pack is removed. They resolve all known item/block ID conflicts that I could find. They also address a number of recipe changes that can bee seen below the download on the main page.

    Download link: http://www.mediafire.com/?infyenbcex2rmi6
    Thanks for the new configs. Glad you did the recipes so I didn't have to!
    Check out what I'm selling in ESO HERE!

    Interested in joining the MMO-Champion US guild? Whisper me in-game! @greevir

  12. #812
    LOAD"*",8,1 Fuzzzie's Avatar
    Join Date
    Nov 2008
    Location
    Legion of Doom Headquarters
    Posts
    20,318
    Quote Originally Posted by Greevir View Post
    Thanks for the new configs. Glad you did the recipes so I didn't have to!
    More good stuff for today.

    I've introduced the "Additional Mods" section in the OP. This contains other mods that I personally don't use but feel that they should be on the list for people to see. My config files do not cover them, so you'll have to install them on your own. I am however looking for a little help. If you wish to see a mod added to the additional mods section then please let me know. I ask that the mod satisfy a few criteria however:

    • The mod must be Forge Compatible. Non forge mods have never been something I've wanted to cover and this will continue.
    • The mod must be available for Minecraft 1.4.6/7. Meaning I do not want mods for Minecraft 1.3.2, even if it's "In Development".
    • You must have tried the mod for yourself. This is so that you can confirm that it works.
    • I do not want mods that don't add much to the game. For example, A mod that adds 20 new types of stairs is not something I'm interested in.

    Other than that, I'm open to just about anything. I'll eventually get around to testing them and If I like them I may add them to the permanent list and include configs for them. Note that updates for these mods may be overlooked for a day or two if I am very busy. Please don't hound me about them!!

    Thanks for those few that have been submitted so far. Sorry it took so long to getting around to this. Let me know what you want added!

  13. #813
    WOOT! It's been so long since I had a working world with mods! Minecraftjesus thank you!

    @Fuzzie
    Wow, thanks for updating configs and for the help with my weird issue. Found out that my Twilight forest zip file was corrupted so I re-downloaded it. YAY It finally works!

    Also
    Just wanted to let you know that Smart moving mod works with forge. I absolutely can't play without it anymore since it is so fun to use. Need to extract the file then put the right folder in the jar for it to work though (readme).

    and it seems like extra bees is still being a royal pain in the a** but that is nothing new.
    Last edited by Moonmonk; 2013-01-04 at 01:55 AM.

  14. #814
    Fuzzie, Could you add a date column to the mods spreadsheet? That way we could see from the list what had been updated since they last time we updated our mods.

    ---------- Post added 2013-01-03 at 07:16 PM ----------

    Here are three additional mods that I have working with your entire mod list.

    Mod: Single Player Commands
    Version: 4.4
    Credit: simo_415
    Download: adf.ly/GOESF
    Thread: http://www.minecraftmine.org/single-...-commands-mod/
    Its adds a lot of command line commands. You have to add it to the minecraft.jar.
    Includes worldedit. Allows you to load schematics and edit the world.

    Mod: Millenaire
    Version: 3.2.2
    Credit: Kinniken
    Download: millenaire.org/php/dl.php?file=Millenaire3.3.2.zip
    Thread: http://www.minecraftforum.net/topic/...y-major-fixes/
    Adds new types of NPC villages to the game. Mostly self reliant NPCs that you can trade with and help them build.

    Mod: Jammy Furniture
    Version: 4
    Credit: Jammy780
    Download: adf.ly/GL1D6
    Thread: http://www.minecraftforum.net/topic/...furniture-mod/
    Adds a lot of modern furniture. I couldn't get MrCrayFishes furniture mod to work so switched to this one.

    I had to change some item IDs to get these working.

  15. #815
    LOAD"*",8,1 Fuzzzie's Avatar
    Join Date
    Nov 2008
    Location
    Legion of Doom Headquarters
    Posts
    20,318
    Quote Originally Posted by OldFarmerJoe View Post
    Fuzzie, Could you add a date column to the mods spreadsheet? That way we could see from the list what had been updated since they last time we updated our mods.
    Hmm. That would be a lot of work. I guess I could change the "notes" section. I may impliment this, but not tonight!

    I'll add those mods too later tomorrow!

  16. #816
    Cool u put pacman there

  17. #817
    Grunt Dodge34's Avatar
    Join Date
    Dec 2012
    Location
    Laval, Québec
    Posts
    12
    I got a serious problem that drives me crazy, I want to update my server to the latest 1.4.6/7 MC with all the mods including RP2 and everything works #1, except the damn vanilla server is spamming messages about Advanced Machines constantly, I get around 10-20 lines each second telling me that some machines require some power and aren't powered or something similar, the advanced machines works fine and everything else seems to be OK but when I want to turn off the server, I can't cause the spamming prevent any commands from being sent to the server, this drives me insane cause its the only part that prevent me from updating my private family server, all the mods are out but because of the spamming in the console, I won't be able to stop the server properly. I've heard it could be related to IC2 so I was looking for an updated version but can't find any other link than the one you posted here and its not even on the official IC2 forums, I've searched for beta build or jenkins but to no luck, I know they don't want people to play with new versions because they don't want bug reports at all about them, but if you could send me a link in PM to a jenkins or something where they post their recent versions, that could help me a lot, I've posted a message on the official thread of Advanced Machines and I'm not the only one with that problem but the author doesn't seem to care too much about it.

  18. #818
    LOAD"*",8,1 Fuzzzie's Avatar
    Join Date
    Nov 2008
    Location
    Legion of Doom Headquarters
    Posts
    20,318
    Quote Originally Posted by skedone View Post
    Cool u put pacman there
    Yeah, I've been meaning to add additional mods for a while. Finally got around to it

    Quote Originally Posted by Dodge34 View Post
    I got a serious problem that drives me crazy, I want to update my server to the latest 1.4.6/7 MC with all the mods including RP2 and everything works #1, except the damn vanilla server is spamming messages about Advanced Machines constantly, I get around 10-20 lines each second telling me that some machines require some power and aren't powered or something similar, the advanced machines works fine and everything else seems to be OK but when I want to turn off the server, I can't cause the spamming prevent any commands from being sent to the server, this drives me insane cause its the only part that prevent me from updating my private family server, all the mods are out but because of the spamming in the console, I won't be able to stop the server properly. I've heard it could be related to IC2 so I was looking for an updated version but can't find any other link than the one you posted here and its not even on the official IC2 forums, I've searched for beta build or jenkins but to no luck, I know they don't want people to play with new versions because they don't want bug reports at all about them, but if you could send me a link in PM to a jenkins or something where they post their recent versions, that could help me a lot, I've posted a message on the official thread of Advanced Machines and I'm not the only one with that problem but the author doesn't seem to care too much about it.
    The official beta thread for IC2 is: http://forum.industrial-craft.net/in...&threadID=8607

    There's no jenkins site as far as I'm aware. I don't think they do their development in that way. There are also two versions of Advanced Machines, although one doesn't look like it's being updated anymore.

    Make sure you're running the latest version is all I can suggest. If you want to post in the Advanced Machines thread for the version I list the thread is here:
    http://forum.industrial-craft.net/in...&threadID=4907

    Other than that I'm not sure what I can really do to help. If it's a bug in your installation or a corrupted file, re-downloading may help.

  19. #819
    Grunt Dodge34's Avatar
    Join Date
    Dec 2012
    Location
    Laval, Québec
    Posts
    12
    I got my problem solved, I've found a jenkins of IC2 if my sources are correct its made by Player so its a trusted IC2 developer, I got a 187 edition and now my server run smoothly without the spamming and my advanced machines work well there, still have some more tests to do to make sure but so far so good, I'm not sure if I should link the jenkins directly here because I'm well aware that this could cause problems if some unexperienced people grab them and ask for support here, let me know if you want the link to test them out yourself and see if you should post them here...

  20. #820
    LOAD"*",8,1 Fuzzzie's Avatar
    Join Date
    Nov 2008
    Location
    Legion of Doom Headquarters
    Posts
    20,318
    Quote Originally Posted by Dodge34 View Post
    I got my problem solved, I've found a jenkins of IC2 if my sources are correct its made by Player so its a trusted IC2 developer, I got a 187 edition and now my server run smoothly without the spamming and my advanced machines work well there, still have some more tests to do to make sure but so far so good, I'm not sure if I should link the jenkins directly here because I'm well aware that this could cause problems if some unexperienced people grab them and ask for support here, let me know if you want the link to test them out yourself and see if you should post them here...
    That's good, and no we probably don't need the jenkins site for it. I'm sure the release version of IC2 will be out soon now that the holidays are over.

    ---

    I've added a few more mods that were suggested. Updates coming later.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •