Page 1 of 11
1
2
3
... LastLast
  1. #1

    Game Performance Issues

    Post here if you have performance problems with the game.

    Helpful Information:

    Your graphics card
    Your drivers
    OS
    Speccy screenshot or other useful information about your system

    State your FPS estimate "Eg 10-20" and state your settings. Explain your issue "Eg No matter what settings I get 10-20fps"

    When GW2 Official forums are released, I will link them to this thread.
    Last edited by FearGX; 2012-08-26 at 03:56 PM.

  2. #2
    Epic! Milanor's Avatar
    Join Date
    Jul 2009
    Location
    That place...with the stuff.
    Posts
    1,564
    Quote Originally Posted by FearGX View Post
    I saw on gw2status that the game launched early, so I am now in game. Made my character all that jazz. In game I have 8-12 frames per second and the movement is very laggy. I've tried performance settings, auto detect, setting it up myself. I have 10 fps in game.

    This is absurd, I have a HD 6850 and a beast machine well over the minimum requirements, any1 else getting really unplayable performance?
    What Video Card/Drivers are you using? If you're using the NVIDIA 301.42, you need to upgrade or downgrade, as it doesn't get along with GW2 very well.
    Last edited by Milanor; 2012-08-25 at 05:52 AM.

    Just Your Average Lurking Huntard LOLPRIEST forum lurker now.

  3. #3
    Keyboard Turner Kyphael's Avatar
    Join Date
    Apr 2012
    Location
    Chicago
    Posts
    9
    Oh... I thought this was a terrible sexual performance thread.
    Yeah, no -- Kel
    Last edited by Kelesti; 2012-08-25 at 07:00 AM.

  4. #4
    Buy a gts 460 :P
    52 fps
    Last edited by Plzbegentle; 2012-08-25 at 05:54 AM.
    GW2 : Plzbegentle - Ruins of Surmia EU - Sylvari Engineer
    WoW: Vergin - Deathwing EU - Elf Resto Druid (27/05/05 - 02/04/12 Perma-Banned- Unhappy whinning PvP customer - whos begged from 4.1 to get rid of the RNG of Regrowth ... )
    It seems ppl have the energy to whine for a game , for not beeing exactly like their <<main>> game , while it dont have a SUB , and they dont have the courage to whine at their Game Master for slacking and producing few PvE content ...

  5. #5
    I didn't have any issues. Regardless, it JUST launched, give it time. There are going to be bugs, there always are with any game right upon launch.

  6. #6
    Stood in the Fire LummyBear's Avatar
    Join Date
    Nov 2010
    Location
    The Brigher Side
    Posts
    433
    Quote Originally Posted by VibrantViolet View Post
    I didn't have any issues. Regardless, it JUST launched, give it time. There are going to be bugs, there always are with any game right upon launch.
    People don't expect there to be anybugs :P

  7. #7
    Quote Originally Posted by Milanor View Post
    What Video Card/Drivers are you using? If you're using the NVIDIA 301.42, you need to upgrade or downgrade, as it doesn't get along with GW2 very well.
    Well, if he has NVIDIA 301.42 that would explain bad performance, because HD 6850 is an ATI card

  8. #8
    Quote Originally Posted by mafao View Post
    Well, if he has NVIDIA 301.42 that would explain bad performance, because HD 6850 is an ATI card
    Pretty accurate deduction if you ask me.

    6850 isn't a top end card, but unless you're trying to play with all settings maxxed out you should do better than 15 fps.

    Try another driver if you can, otherwise maybe a card issue?

  9. #9
    I've been having the same issue. I have an AMD 6750M and during the BWE's I had 60 fps on medium settings no problem. Now, I can't break 5. I can't make a character other than the warrior because the models don't show up for other classes. I don't know what happened between now and then but I'm trying all sorts of drivers to no avail. Im installing older RAGE drivers to test those as they are pretty solid from the sounds of it.

    Hopefully this is not something on our side and will be fixed promptly. If it is client side it is going to take some searching.

  10. #10
    Using a 5770 card myself and still had close to 40 fps not sure why you had problems.

  11. #11
    Don't worry man, game isn't very well optimized as of now. I have a 570GTX and I am only getting about 30fps max, just got to wait it out. It's luck of the draw unfortuately.
    Last edited by Adalas; 2012-08-25 at 06:57 AM.

  12. #12
    Dreadlord Darkrulerxxx's Avatar
    Join Date
    Oct 2011
    Location
    Southern California
    Posts
    936
    Quote Originally Posted by Adalas View Post
    Don't worry man, game isn't very well optimized as of now. I have a 570GTX and I am only getting about 30fps max, just got to wait it out. It's luck of the draw unfortuately.
    i have a gtx 570 too i have about the same amount of FPS as you...yup as you say just gotta wait it out

  13. #13
    Quote Originally Posted by VibrantViolet View Post
    I didn't have any issues. Regardless, it JUST launched, give it time. There are going to be bugs, there always are with any game right upon launch.
    Cata was surprisingly very smooth.

  14. #14
    Not to discount your troubles, but honestly...I'm running a 4 year old rig that I haven't touched except to update the mouse to a $39 job. GTS 250 on a Dell comp I grabbed outa BB years ago and it's running flawlessly for me /shrug. Good performance and zero dc's.

  15. #15
    P9300 CPU and 9800GT GPU here, and I'm getting 30+ fps in crowded areas on medium/high settings. Also running very old drivers due to a problem with my graphics card where if I upgrade the driver my screen turns black until I roll it back.
    Last edited by Maelstrom51; 2012-08-25 at 07:08 AM.

  16. #16
    Quote Originally Posted by sTyLnK View Post
    Cata was surprisingly very smooth.
    Well of course it was with those graphics and almost a decade old game. I doubt WoW stresses a Windows 95 Packard Bell

  17. #17
    im getting around 40 fps which is pretty awful for my gtx 680 so im wondering what the deal is

  18. #18
    Quote Originally Posted by sTyLnK View Post
    Cata was surprisingly very smooth.
    lol really a smooth launch of an expansion of an existing game with 6 Years behind it and you are comparing it with GW2 Launch...... Top Comparison

    OT - Have to grin and bear it until the GFX drivers are updated for GW2, shouldn't be too long

    Guild Wars 2
    Vansar Vespasian - Human Warrior
    Lucipher Vandrake - Human Ranger

  19. #19
    High Overlord kuruptz's Avatar
    Join Date
    Jul 2012
    Location
    Sweden
    Posts
    159
    i got AMD Radeon 6620G

    its a laptop with Medium / low i got 27 - 30fps ( not in WvWvW ofc lol )

  20. #20
    gtx 460 here usually around 40-50 fps,also whenever I'm in black citadel Imperator's Core I need to turn reflection off or my fps drop to like 6-12.Anyone got this problem or is just the 460 not good enough?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •