1. #1

    Guild wars 2 with snow leopard (osx 10.6.8) ?

    Hey fellas, I wanted to ask if any of you had experiences running guild wars 2 with snow loepard (osx 10.6.8). I know the minimum requirement says OsX 10.7 and the fact that it says its Minimum requirement should mean that with anything less than osx 10.7, the game wont run but i thought i should ask anyway.

    Anyone?

  2. #2
    The Lightbringer Rukh's Avatar
    Join Date
    Dec 2008
    Posts
    3,547
    You own a mac. Part of owning a mac is buying updates when apple commands it.

  3. #3
    Quote Originally Posted by Rukh View Post
    You own a mac. Part of owning a mac is buying updates when apple commands it.
    Yeah, yeah, anyone else?

  4. #4
    I don't see why it wouldn't run - its not like they are using 10.7+ only APIs anyway. And even if they do, Mountain Lion is a $20 update...

    Still, if you are still on 10.6 than your Mac is probably a bit older and does not have a reasonable GPU to offset the inevitable OS X - side performance hit (unless its a Mac Pro), so Bootcamp would be a better option for you.

  5. #5
    I'm running GW2 on Snow Leopard and works fine tbh, the errors you will get is just because GW is in BETA for Mac and yes occasionally you will get errors.. For some reason restarting my Macbook Pro solves those problems (so just you know), or switch characters / make new one.

    Also im running GW2 on a Macbook Pro late 2008 model and for me GW works pretty decent, some FPS problems in instances if people spam loads of spell but its fine overall.

  6. #6
    Running fine on mine (both on the Snow Leopard and Mountain Lion partitions).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •