1. #1

    Blizzard Launcher Download Problems

    Hey there guys !

    I have been trying download WoW through the blizzard launcher and for some reason, the speeds keep dropping to 0 and stays like that for like hours. I had kept it on last night and checked today morning to find out only .9% has been completed.

    This is after I made sure its off the firewall list, ran as administrator and enabled p2p. I am literally out of options at this point.

    Some advice on how to go about it would be nice .

    Thanks in advance !

  2. #2
    Herald of the Titans FuxieDK's Avatar
    Join Date
    Apr 2012
    Location
    København
    Posts
    2,585
    Is your portforwarded?
    Does your ISP throttle p2p transfer? In Denmark it's illegal, but I know some ISPs in other countries does it..
    Do you have a monthly max transfer, you might have exceeded?

  3. #3
    Quote Originally Posted by FuxieDK View Post
    Is your portforwarded?
    Does your ISP throttle p2p transfer? In Denmark it's illegal, but I know some ISPs in other countries does it..
    Do you have a monthly max transfer, you might have exceeded?
    Well i dont live in the Europe region and besides, I have an unlimited package, so it shouldnt be the case. And what do you mean by port forwarding?

  4. #4
    Herald of the Titans FuxieDK's Avatar
    Join Date
    Apr 2012
    Location
    København
    Posts
    2,585
    Your location-tag suggest you're fromEurope ;-)

    http://portforward.com/ explains port forwarding

  5. #5
    Quote Originally Posted by FuxieDK View Post
    Your location-tag suggest you're fromEurope ;-)

    http://portforward.com/ explains port forwarding
    Thanks for that, but then the settings there didnt help. I cant quite point out the problem as I m not a networking guru. I just see my speeds dropping to zero when dling the game, rather my torrents are working just fine.

  6. #6
    When I have problems with the Blizzard Launcher (SC2, D3, WOW) I go to the "ProgramData" folder and delete the "Battle.net" and "Blizzard Entertainment" folders. This kinda resets the launchers/updaters/setups for those 3 Blizzard games. I have to download some parts of the most recent patches again, but the launchers work.

  7. #7
    Quote Originally Posted by dR-vIce View Post
    When I have problems with the Blizzard Launcher (SC2, D3, WOW) I go to the "ProgramData" folder and delete the "Battle.net" and "Blizzard Entertainment" folders. This kinda resets the launchers/updaters/setups for those 3 Blizzard games. I have to download some parts of the most recent patches again, but the launchers work.
    Thanks for the tip, but didnt work though :S.

  8. #8
    Herald of the Titans FuxieDK's Avatar
    Join Date
    Apr 2012
    Location
    København
    Posts
    2,585
    Sound like you'll have to ask in Tech Support on Blizzard's forum..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •