1. #1
    Pit Lord Kezotar's Avatar
    Join Date
    Oct 2010
    Location
    Europe
    Posts
    2,495

    MMO-Champion is Laagy and slow...

    So straight forward. Everytime.. Everytime I go on MMO champion is slows down my browser, watching videos get freezy-ish and they start going slow, the main page with mmo-champion starts going slow and just goes pretty much slow. I don't know why this happens' Is this only me or what?

    Just for information. This happens only on mmo champion, i've browsed so many other websites and nothing happens. No slowyness. So any help or is the owner saving some bucks?
    I7 - 4930K / 16 GB - 1600MHZ / R9 290 Core 1220 MHZ - Memory 1550 MHZ

  2. #2
    Moderator Kasierith's Avatar
    Join Date
    Jul 2010
    Location
    St Petersburg
    Posts
    11,494
    I have never had such a problem on this site. What browser are you using?
    “…the whole trouble lies here. In words, words. Each one of us has within him a whole world of things, each man of us his own special world. And how can we ever come to an understanding if I put in the words I utter the sense and value of things as I see them; while you who listen to me must inevitably translate them according to the conception of things each one of you has within himself. We think we understand each other, but we never really do.”
    XKCD is always relevant. Always.

  3. #3
    delete your cache. run a program like ccleaner

  4. #4
    Pit Lord Kuthe's Avatar
    Join Date
    Dec 2011
    Location
    Australia
    Posts
    2,303
    Can't say it's a fact.
    But it doesn't affect any of the computers I visit MMO-C on.

    Might be you, sure your not straining your computer with excess things open at once, and MMO-c just adds to it?
    We stopped searching for monsters under our beds when we realized that they were inside us.

    Tell me something, my friend. You ever dance with the devil in the pale moonlight?

  5. #5
    Only prob I have is when I first load MMO, and if I'm running a stream on twitch or listing to music on pandora, they lag for a few seconds. Other than that nothing really bad lag wise.

  6. #6
    Pit Lord Kezotar's Avatar
    Join Date
    Oct 2010
    Location
    Europe
    Posts
    2,495
    I'm having 8 gigs of ram and only a youtube browser, I will try to run cc cleaner and post results. Really I dunno why. I'm checking at memory usage and it's at 250mb.
    I7 - 4930K / 16 GB - 1600MHZ / R9 290 Core 1220 MHZ - Memory 1550 MHZ

  7. #7
    Moderator d3v's Avatar
    Join Date
    Sep 2008
    Location
    East Flanders, Belgium
    Posts
    4,776
    What browser are you using to view MMO-Champion (and YouTube)?

  8. #8
    Pit Lord Kezotar's Avatar
    Join Date
    Oct 2010
    Location
    Europe
    Posts
    2,495
    I'm using Google Chrome. Seems like somehow using CCleaner solved it. I regulary use it (1 time a week). Not sure what happened, but it only was with MMO-Chmapion. Thanks for the tip!
    I7 - 4930K / 16 GB - 1600MHZ / R9 290 Core 1220 MHZ - Memory 1550 MHZ

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •