1. #1
    Legendary! Evil Inside's Avatar
    Join Date
    Oct 2010
    Location
    Down Under
    Posts
    6,918

    Pet traps bugged?

    So I've gotten into pet battles after the massive valor/daily grind, played around with it for a while and I noticed that the traps arent working as intended, at least for me.. I was fighting an undead wild pet, after I got it down to low health(low as in one-shot kill low) and used the trap, however it didnt work so I tried it again. And again it didnt work, this went on for about 7-8 turns I kid you not, if I understand correctly the trap is supposed to increase the capture chance by 20% after every failed try, so if it was working as intended I should have been able to capture it within 5 tries or less.

    Has anyone else had this issue? It's quite annoying when I find a rare pet but the trap just keeps missing.
    ||i5 3570k @ 4.4GHz||H100 push/pull||AsRock Z77 Extreme4||16Gb G.Skill Ripjaws 1600MHz||HD6970/HD6950 crossfire|| Coolermaster Storm Trooper||Corsair TX850 Enthusiast Series||Samsung 840 Pro 128gb(boot drive)||3x 1tb Western Digital HDD||

    Bdk Nagrand / Astae Nagrand
    Pokemon X FC: 4656-7679-2545/Trainer Name: Keno

  2. #2
    Legendary! Reg's Avatar
    Join Date
    Sep 2009
    Location
    Manhattan
    Posts
    6,748
    Haven't had a single issue with pet traps, and I've pretty much only done pet battles this expansion lol

  3. #3
    High Overlord Dragon-Hawks's Avatar
    Join Date
    Feb 2010
    Location
    England
    Posts
    115
    I can't say I have has this particular problem. I think the most I have had fail in a row is 4.

    I have had some problems when you try to attack or throw a trap it just doesn't do anything.

  4. #4
    Legendary! Asmekiel's Avatar
    Join Date
    Sep 2010
    Location
    Maybe over there
    Posts
    6,494
    The only problem I have is that when I press 4 or 5, nothing happens. The buttons light up, but don't actually trigger. This might be an addon problem though, haven't tested it.

  5. #5
    Fluffy Kitten Rivin's Avatar
    Join Date
    Oct 2009
    Location
    Washington, USA
    Posts
    13,590
    The chance to capture is probably multiplicative, not additive, so it won't reach 100%. You probably had a really poor streak of bad luck.

  6. #6
    Legendary! Evil Inside's Avatar
    Join Date
    Oct 2010
    Location
    Down Under
    Posts
    6,918
    Quote Originally Posted by Asmekiel View Post
    The only problem I have is that when I press 4 or 5, nothing happens. The buttons light up, but don't actually trigger. This might be an addon problem though, haven't tested it.
    I've had this happen sometimes as well, it seems to be random, it would work normally on one battle and then not work on the next.

    ---------- Post added 2012-11-05 at 10:04 PM ----------

    Quote Originally Posted by Rivin View Post
    The chance to capture is probably multiplicative, not additive, so it won't reach 100%. You probably had a really poor streak of bad luck.
    Hmm well that sucks, guess I have to keep trying >.< RNG gods really hate me as of late.
    ||i5 3570k @ 4.4GHz||H100 push/pull||AsRock Z77 Extreme4||16Gb G.Skill Ripjaws 1600MHz||HD6970/HD6950 crossfire|| Coolermaster Storm Trooper||Corsair TX850 Enthusiast Series||Samsung 840 Pro 128gb(boot drive)||3x 1tb Western Digital HDD||

    Bdk Nagrand / Astae Nagrand
    Pokemon X FC: 4656-7679-2545/Trainer Name: Keno

  7. #7
    Stood in the Fire Amalisa's Avatar
    Join Date
    Dec 2009
    Location
    Jerusalem, Israel
    Posts
    352
    I've had it happen that I press the trap, it does not cast the trap but it uses up my turn =/

    RIP Amalisa 2006 - 2013 - Burning Steppes to Kazzak and everything in between.
    Officially quit WoW, May 2013, now just a troll

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •