Page 2 of 3 FirstFirst
1
2
3
LastLast
  1. #21
    Quote Originally Posted by ZeroEdgeir View Post
    Whenever this error comes up, it is never the same addon it says is at fault.
    yea same here. workaround? i use /reload ui and after that i can change em. quite faster then relog

  2. #22
    I get this issue sometime with LUI. It is weird. Sometimes I change talents/glyphs with no problems, other times I get message saying I have to disable LUI if I want to perform this action. It is annoying. I just wish it was consistent on whether it will cause a problem or not.

  3. #23
    Warchief HeatherRae's Avatar
    Join Date
    Aug 2009
    Location
    Louisiana
    Posts
    2,246
    It isn't an addon. It will tell you various addons are to blame, but they're not.

    It's a problem with Blizzard's code. The only way around it is to not inspect anyone when you log on.
    Tiriel <Demise> of US-Kel'Thuzad

    Thank you to Yoni for this AMAZING signature!

  4. #24
    Yeah, we had a taint issue with the glyph frame during Cataclysm too. This one is unrelated, the symptoms are just similar.
    UI & AddOns expert | Interface & Macros moderator - My work

  5. #25
    Warchief HeatherRae's Avatar
    Join Date
    Aug 2009
    Location
    Louisiana
    Posts
    2,246
    Quote Originally Posted by Treeston View Post
    Yeah, we had a taint issue with the glyph frame during Cataclysm too. This one is unrelated, the symptoms are just similar.
    Yeah, it's not the same, but it's... It's basically a symptom of the really bad code they use to handle certain parts of the UI. It's just shoddy work, near as I can tell.
    Tiriel <Demise> of US-Kel'Thuzad

    Thank you to Yoni for this AMAZING signature!

  6. #26
    its Blizzard code

    what to reproduce it easily?

    - login without any addons
    - in Wow options change the Social-> New whisper from inline to New Tab (if isn't already)
    - whisper yourself (or anyone whisper you)
    - go change the glyph
    - enjoy your taint

    yes, whisper new tab produces taint

  7. #27
    You can also cause it by using UIFrameFlash() on anything with 0 addons loaded.

  8. #28
    Inspecting someone also seems to cause the error.

  9. #29
    I am Murloc! Thelxi's Avatar
    Join Date
    Feb 2012
    Location
    NYC
    Posts
    5,199
    It's been this way for a while, so I wouldn't get your hopes up a fix in in the near future if at all.

  10. #30
    Quote Originally Posted by Treeston View Post
    It got introduced during the 5.0 patch. They change their UI code too, you know.
    I've had it all throughout cata.

  11. #31
    Yea I have this problem too argh
    "I hate to advocate drugs, alcohol, violence, or insanity to anyone, but they've always worked for me." -Hunter S. Thompson

  12. #32
    Just /reload. Done.
    | Simple is beautiful.
    | Blog | Roth UI | Roth UI FAQ | GoogleCode | Zork | Guild | zorker.de

    "I wonder what the non-pathetic people are doing tonight?" - Rajesh Koothrappali (The Big Bang Theory)

  13. #33
    As far as I know, it's Blizzard's fault. Just like tons of other things, they say it's not. Like how viewport and similar mods will cause graphic overlay issues in certain places, like Uldum, and there is literally nothing the author can do to make that not happen because Blizzard did something on their end that causes otherwise fine coding to not work properly.

    Once upon a time, druids in shapeshift forms that got knocked back would also be "stunned" for a short period of time and I was told numerous times "oh lol clear your cache and WTF folders, it's an addon issue." Bitch getting stunned after a knockback on my druid while in form, but not while not in form, and not on any other character, and all my druid friends have this issue too, is your fucking fault. Trying to feed me bullshit about how an addon could stun my character, but only in shapeshift forms! As if.

    Anyway, long story short, either get rid of the addon(s) that cause it, or live with it and hope Blizz gets their end of their shit together.

  14. #34
    Quote Originally Posted by zorker View Post
    Just /reload. Done.
    Doesnt always work. If i remember correctly, when Fatality causes the error for me, its never enough to just /reload - i have to log out on that char to change talents.

  15. #35
    Quote Originally Posted by iamthedevil View Post
    I've had it all throughout cata.
    Like I've said above, it's a different issue causing the same symptoms. The dropdown taint bug (which is what had caused this issue in Cata) has been fixed in 5.0 (or at least it was fixed in the PTR FrameXML - can't check if that change got pulled [for whatever reason] before the patch went live).
    UI & AddOns expert | Interface & Macros moderator - My work

  16. #36
    Mechagnome soulyouth's Avatar
    Join Date
    Jan 2009
    Location
    Sydney, Australia
    Posts
    678
    http://www.wowinterface.com/download...xDropdown.html

    is the taint you talk about, what leatrix talks about ?

  17. #37
    That's the dropdown taint bug. I believe that one was fixed during the 5.0 patch, but as I said above, I'm not sure.

    This new taint bug is different - it can happen even without any addons (global leak of _ in both secure and insecure Blizzard code, if I remember correctly).
    UI & AddOns expert | Interface & Macros moderator - My work

  18. #38
    Warchief HeatherRae's Avatar
    Join Date
    Aug 2009
    Location
    Louisiana
    Posts
    2,246
    Quote Originally Posted by Treeston View Post
    That's the dropdown taint bug. I believe that one was fixed during the 5.0 patch, but as I said above, I'm not sure.

    This new taint bug is different - it can happen even without any addons (global leak of _ in both secure and insecure Blizzard code, if I remember correctly).
    ^^ I've had it happen without a single addon enabled. But it will consistently blame an addon if you have any enabled. It likes to blame Power Auras, VuhDo, Grid, DBM, Prat, etc.
    Tiriel <Demise> of US-Kel'Thuzad

    Thank you to Yoni for this AMAZING signature!

  19. #39
    DBM-Core does it for me, so i just have to reloadui every time to make it work again

  20. #40
    Quote Originally Posted by Treeston View Post
    That's the dropdown taint bug. I believe that one was fixed during the 5.0 patch, but as I said above, I'm not sure.

    This new taint bug is different - it can happen even without any addons (global leak of _ in both secure and insecure Blizzard code, if I remember correctly).
    I think that one was fixed. You can /dump issecurevariable("_") to see if its tainted. I can change talents and glyphs still manually tainting it (/run _ = "blah"), and when it does happen and I am unable to change them "_" is usually still secure.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •