1. #1

    Bartender 4 & Ambershaper

    So I've got this issue, that I hear a lot of people have been having, and that's the vehicle bar for Ambershaper when you get MCd, doesn't swap over properly with Bartender 4.
    If I have my keybinds bound to the 1-4 slots on BT4, the keybinds don't show up at all on the vehicle bar.
    If I have my keybinds bound to the 1-4 slots on Blizz' keybindings, they still work for my BT4 buttons, show up on the vehicle bar, but don't allow you to push the keybind. (ie. you still have to click)
    Does anyone know if there's a fix for this or anything?
    Hakushi - Main Shaman - 587 Enh/573 Ele 8/8 HM DS (5% Nerf Spine/Madness), 7/7 HM FL, 6/6 HM MSV, 6/6 HM HoF, 4/4 HM ToES, 13/13 HM ToT, 14/14 HM SoO
    Oxyra - Semi-Main DK - 570 Blood 6/6 HM MSV, 6/6 HM HoF, 4/4 HM ToES, 13/13 HM ToT, 4/14 HM SoO
    Raiding with Fused - Illidan

  2. #2
    Have you gone into the settings for bar one under BT4 (or whichever bar you're using as your primary ability bar), gone under the "state configuration" tab, enabled it and set it as a "possess bar"?

    That's the setting that would do that functionality. It's a bit buggy with this fight, but it should work.

  3. #3
    Ya, forgot to mention, it works with every other vehicle bar and MC mechanic ingame.
    It's set to page correctly with possess etc. yes
    Hakushi - Main Shaman - 587 Enh/573 Ele 8/8 HM DS (5% Nerf Spine/Madness), 7/7 HM FL, 6/6 HM MSV, 6/6 HM HoF, 4/4 HM ToES, 13/13 HM ToT, 14/14 HM SoO
    Oxyra - Semi-Main DK - 570 Blood 6/6 HM MSV, 6/6 HM HoF, 4/4 HM ToES, 13/13 HM ToT, 4/14 HM SoO
    Raiding with Fused - Illidan

  4. #4
    I have the exact same problem, vehicle interface works with any other quests, but during this boss fight I'm forced to click as the keybinds simply don't work, anyone with Bartender4 able to do it successfully?
    <Guiles Theme Song> @ Magtheridon-US Horde 20-man, HM-2/7M, currently recruiting all
    Website: http://www.guilesthemesong.wowlaunch.com
    Stream: http://www.twitch.tv/timoseewho

  5. #5
    Bump for assistance before we go back into raid.
    Hakushi - Main Shaman - 587 Enh/573 Ele 8/8 HM DS (5% Nerf Spine/Madness), 7/7 HM FL, 6/6 HM MSV, 6/6 HM HoF, 4/4 HM ToES, 13/13 HM ToT, 14/14 HM SoO
    Oxyra - Semi-Main DK - 570 Blood 6/6 HM MSV, 6/6 HM HoF, 4/4 HM ToES, 13/13 HM ToT, 4/14 HM SoO
    Raiding with Fused - Illidan

  6. #6
    I'm also experiencing this issue. Using Bartender4. My vehicle controls and keybinds for other vehicles in game work fine. On this fight, the vehicle bar shows up, but keybinds don't work.

    Has anyone found a solution?

  7. #7
    I click it manually with mah mouse. 6 secs CD on Amber Strike and its not like you have to spam the self-interrupt.
    Although i'd love getting a fix for this issue, i can live without it for now.

  8. #8
    Are you sure that was Bartender and not other addon(s) conflicting with it and your Bartender is updated? I killed Un'sok twice (last week + this week), using Bartender on both kills, was transformed a few times and didn't have any issue with using buttons for the skills.

  9. #9
    Quote Originally Posted by Qualia View Post
    Are you sure that was Bartender and not other addon(s) conflicting with it and your Bartender is updated? I killed Un'sok twice (last week + this week), using Bartender on both kills, was transformed a few times and didn't have any issue with using buttons for the skills.
    Same here. I use bartender with no issues on this fight.

    You may want to be sure the option to use the vehicle bar for main is enabled though I think it is by default.

  10. #10
    I have this problem, and the main reason is this, i think:

    My ability bar that I have in the center of my UI (which is also the possess bar that works correctly for all other vehicle encounters) is NOT "Bar 1" in bartender, but rather "Bar 10". My bar #1 is hidden, and contains all my normal rotation abilities (living bomb, fireball, etc). Bar 10 has all my cooldowns like combustion, ice block, evocation, etc. Now, when I un-hid my Bar 1, I discovered that the vehicle bar was switching to my Bar1, even though I had possess bar set to Bar 10. Bar 10 pages to the possess bar correctly in all other vehicles with these settings, however.

    The only workaround, aside from moving all my spells around and using Bar1 as my central bar, was to just Enable Blizzard Vehicle UI in bartender, and go with the stock vehicle bar. If you're still having issues, you might have to do that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •