1. #1

    Corsair Enthusiast Series TX650 V2 strange noise

    Hello

    I just bought a Corsair Enthusiast Series TX650 V2 and when i play games or on full load the psu makes a strange noise like this one

    http://www.youtube.com/watch?v=dXCr1ho_ILA&feature=plcp.

    I was wondering if someone here has this psu and had the same problem ? ( as after a quick google search it seems it is a common problem with the Corsair Enthusiast Series TX650 V2 )

    What i would like to know is if this can be fixed with opening the psu (maybe it's a loose bolt/fan or something ) or i have to send it back in order to get a new one ?

  2. #2
    TOTALLY NOT
    Banned
    tetrisGOAT's Avatar
    Join Date
    Jun 2008
    Location
    Sweden
    Posts
    12,650
    That's not coil whine at least. I would think it'd be related to the fan being fed current, but not enough to spin it had you not mentined it happens with load-scenarios.

    Do not open it, I would suggest RMAing it.

  3. #3
    Stood in the Fire TaintedOne's Avatar
    Join Date
    Aug 2010
    Location
    USA
    Posts
    380
    Quote Originally Posted by tetrisGOAT View Post
    Do not open it, I would suggest RMAing it.
    Second this and add in almost all cases opening your psu voids the warranty
    | Intel i5-4670k | Asus Z87-Pro | Xigmatek Dark Knight | Corsair Vengeance LP White 1.35V 8GB | Sapphire R9 270x | Crucial M4 128GB | 2xWD 500GB Black | Cooler Master Haf-X | Corsair AX1200 | Dell 2412m | Ducky Shine 3 | Logitech G13 | Razer Goliathus XL | Razer Carcharias | Razer Naga - working like new since >2009< |

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •