1. #1

    Unhappy I cannot login wow from turkey

    Hey guys i tried to loging wow all day but i have a problem and my friends also we cant login wow europe site and game i made ticket about it but cant follow it anymore beacause we cant check it anymore anybody knows is there any problem Turkey > Europe connecting problem blizzard said ? ehm Thanks

  2. #2
    Mechagnome Alwek's Avatar
    Join Date
    Jul 2010
    Location
    Daysleeper in Engineering class.
    Posts
    588
    Could also be dependent on the server you're playing on, not necessarily that Blizzard has blocked Turkey which wouldnt make sense. Or perhaps your network.

    http://forum.wow-tr.com/forum.php Maybe you can see if other turkish players has the same issue as you on this site.
    Umarim aradigin cevabi orda bulursun

  3. #3
    Is it bad that when I saw this thread title I assumed it was a joke about trying to play WoW on a Turkey (bird) seeing how it's USA thanksgiving today?

  4. #4
    Mechagnome Alwek's Avatar
    Join Date
    Jul 2010
    Location
    Daysleeper in Engineering class.
    Posts
    588
    Quote Originally Posted by Halifax View Post
    Is it bad that when I saw this thread title I assumed it was a joke about trying to play WoW on a Turkey (bird) seeing how it's USA thanksgiving today?
    ha ha ha.. very funny.



    xD
    Hehe well you can't be blamed for the misspelling there

  5. #5
    Quote Originally Posted by Halifax View Post
    Is it bad that when I saw this thread title I assumed it was a joke about trying to play WoW on a Turkey (bird) seeing how it's USA thanksgiving today?
    I thought exactly the same >_>

  6. #6
    well blizzard got blocked from iran. and a easy work around was a vn connection from turkey. so i assume turkey>wow eu works fine. maybe call them? and is it from the site and game? or only from there game?

  7. #7
    Mechagnome Alwek's Avatar
    Join Date
    Jul 2010
    Location
    Daysleeper in Engineering class.
    Posts
    588
    I browsed the turkish forum I linked earlier if there was something going on, seems like there was a problem with one of the major internet providers. The problem maintained for an hour or so but it seems to have been fixed for most.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •