1. #1

    Installing 64 bit over 32 bit with no CD

    Hey,

    I'm currently looking to install a 64 bit version of Windows 7 in my computer over the 32 bit version but running into some problems. The CD reader on my laptop is completely broken and it won't read anything so I cannot install it using the CD. Whenever I try running the installer, it gives me the "Cannot run 64 bit programms on 32 bit" error.

    I've tried using the microsoft program to create a Bootable USB, went into my BIOS and set the USB as the 1st bootable option but it still doesn't seem to want to boot from it.

    Is there anything else I can do to install it? Tried looking through google but I couldn't seem to find anything of help since most of the answers are on the microsoft site and they assume you've bought it from the microft store which gives you extra downloads like a install file which will allow you to run it on 32 bit, but mine is from the MSDNAA‏, where microsoft don't actually give you any extra downloads of that sort.

  2. #2
    1) When you created that Bootable USB key, it sounds like you didn't actually make that USB key bootable. Try this:

    http://arstechnica.com/business/2009...b-flash-drive/

    2) You really don't want to install a copy of 64-bit Windows 7 over top of your existing 32-bit version. Seriously you really don't(even if by some miracle it allows you to). Install cleanly is always the best option. Backup your documents and stuff before you do anything.

  3. #3
    Herald of the Titans
    Join Date
    Apr 2010
    Location
    Vineland, Cumberland, NJ, USA
    Posts
    2,600
    Well you have a few options:
    -Try different usb ports? Perhaps the one you're using doesn't like your thumb drive.
    -If I were you, I'd invest in buying a new optical drive, it couldn't hurt.

    If you can access the setup.exe from the thumb drive while you are normally running your pc you should be able to run it. Then when the option comes and asks you which version you would like to install make sure its the 64 bit version.

  4. #4
    Quote Originally Posted by D_K_night View Post
    1) When you created that Bootable USB key, it sounds like you didn't actually make that USB key bootable. Try this:

    http://arstechnica.com/business/2009...b-flash-drive/

    2) You really don't want to install a copy of 64-bit Windows 7 over top of your existing 32-bit version. Seriously you really don't(even if by some miracle it allows you to). Install cleanly is always the best option. Backup your documents and stuff before you do anything.
    I did make the bootable USB using that exact same program following the exact same steps, even after I picked the USB to be the #1 on the boot list it still wouldn't start the 64 bit setup, my computer would just boot up as normal.

    And yes I know, I'm not doing a "upgrade" I'm just creating a fresh install of windows without keeping the old files.

    Quote Originally Posted by Linkedblade View Post
    Well you have a few options:
    -Try different usb ports? Perhaps the one you're using doesn't like your thumb drive.
    -If I were you, I'd invest in buying a new optical drive, it couldn't hurt.

    If you can access the setup.exe from the thumb drive while you are normally running your pc you should be able to run it. Then when the option comes and asks you which version you would like to install make sure its the 64 bit version.
    I have tried switching USB ports, did not allow me to boot from it. That's the problem, running the actual install program. When I try to run it from the drive while on my desktop, it gives me the "cannot run 64 bit on 32 bit" error so I cannot start the install program.

  5. #5
    Quote Originally Posted by iNexus View Post
    I did make the bootable USB using that exact same program following the exact same steps, even after I picked the USB to be the #1 on the boot list it still wouldn't start the 64 bit setup, my computer would just boot up as normal.

    And yes I know, I'm not doing a "upgrade" I'm just creating a fresh install of windows without keeping the old files.



    I have tried switching USB ports, did not allow me to boot from it. That's the problem, running the actual install program. When I try to run it from the drive while on my desktop, it gives me the "cannot run 64 bit on 32 bit" error so I cannot start the install program.
    Make sure to run off an usb 2.0 port.

    Use the command prompt to make your usb bootable. Check here how to http://www.youtube.com/watch?v=aFJwiILbsdo

  6. #6
    Field Marshal Twest's Avatar
    Join Date
    Apr 2010
    Location
    Washington
    Posts
    62
    Have you tried installing from the hdd. I partitioned a small portion just big enough to hold the copy and ran it from there. Worked like a charm.

  7. #7
    Dreadlord Darkrulerxxx's Avatar
    Join Date
    Oct 2011
    Location
    Southern California
    Posts
    928
    sometimes even setting the boot priority will not let it boot from the usb. for example, with my computer, i have to actually pick the option to force boot with my bootable usb in the bios section and voila it works. Its not the case with everyone as my previous rig i didnt need to do that but i would recommend trying a force option in the bios and it should work

    ---------- Post added 2012-12-02 at 07:37 PM ----------

    sometimes it does not recognize the usb as a bootable option when trying to set it as priority but it definitely works if you use a force option

  8. #8
    Quote Originally Posted by Darkrulerxxx View Post
    sometimes even setting the boot priority will not let it boot from the usb. for example, with my computer, i have to actually pick the option to force boot with my bootable usb in the bios section and voila it works. Its not the case with everyone as my previous rig i didnt need to do that but i would recommend trying a force option in the bios and it should work

    ---------- Post added 2012-12-02 at 07:37 PM ----------

    sometimes it does not recognize the usb as a bootable option when trying to set it as priority but it definitely works if you use a force option
    Thanks, this worked perfectly running 64 bit right now .

    Can't believe I missed out on such an obvious solution :/

  9. #9
    TOTALLY NOT
    Banned
    tetrisGOAT's Avatar
    Join Date
    Jun 2008
    Location
    Sweden
    Posts
    12,875
    Obvious solutions are only obvious when you know them. There's a lot of trial and error up to that point.
    With computers, there are so many ways things can go wrong, but only one where they go right.

    Glad you got it sorted out!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •