1. #1
    Brewmaster
    Join Date
    Jul 2010
    Location
    Ireland
    Posts
    1,447

    Huge Witch 2 lag using Radeon 7970

    Hey all. My friend is currently unable to run the Witch 2 without huge amounts of lag(under 10 fps, about 3 second delay on key press).

    His computer spec is I5-sandy bridge, Radeon 7970, 8gb ddr3 ram etc (all good parts). His drivers are up to date and all setting have been put to low. Has anyone else had this problem. It runs perfectly fine on my system(the same but a radeon 6970) so it is definitely not his spec been to low

    If anyone else had this problem I would like to know and know how you fixed it, if there was a fix.

    Also to add, this happens even after the training at the beginning(which many people have had problems with).

    Ty in advance.

  2. #2
    Are all his drivers up to date?
    CPU:i5 [email protected] GPU:Gigabyte GTX760 WF3 Mobo:Asrock Z87E-ITX RAM:8Gb GSkill Ares@1600MhzCase:Atomic Orange Bit Fenix Profigy Cooling: Corsair H100i HDD:1Tb WD Cav Black SSD: Samsung 830 128Gb PSU:Seasonic M2II620 KB:Razer Black Widow Mouse:Razer Naga 2014

  3. #3
    He isn't trying to turn on the hyperthreading (or whatever it is) and the fancy extra bells and whistles that CDP put into W2 is he? Because W2 has some frighteningly steep requirements for maxxing out its settings.

    Heroic Recruitment -- Hersh's multi-PoV kill vids. -- Raids & Dungeons & Hunter kitty
    no one huntars like gaston

  4. #4
    I got a 7970 and i experience similar results. Albeit not 10FPS and 3 seconds delay, textures load slowly and i'm at around 25-35fps maxed out with a 1180MHZ clocked 7970. Especially Geralt's hair suffer from slow texture loading.

  5. #5
    Quote Originally Posted by MMKing View Post
    I got a 7970 and i experience similar results. Albeit not 10FPS and 3 seconds delay, textures load slowly and i'm at around 25-35fps maxed out with a 1180MHZ clocked 7970. Especially Geralt's hair suffer from slow texture loading.
    I think that's the uber-sampling option saying it's word there.
    "Marketing is what you do when your product is no good."

  6. #6
    Brewmaster
    Join Date
    Jul 2010
    Location
    Ireland
    Posts
    1,447
    Sorry guys for wasting your time. It actually seems to be the card it's self that is the problem after looking into it more. League of Legends was over 100 fps, so we assumed that it was fine (as well as perfect performance on other non-steam games). After trying other games such as tourchlight 1/2 all of them are lagging. Sorry for needless thread.

  7. #7
    Quote Originally Posted by fiif View Post
    Sorry guys for wasting your time. It actually seems to be the card it's self that is the problem after looking into it more. League of Legends was over 100 fps, so we assumed that it was fine (as well as perfect performance on other non-steam games). After trying other games such as tourchlight 1/2 all of them are lagging. Sorry for needless thread.
    It might not be the card you know.. Did you try to run furmark for like 10mins?

  8. #8
    Brewmaster
    Join Date
    Jul 2010
    Location
    Ireland
    Posts
    1,447
    Sorry, I should have worded that reply better. It is the control panel that is the problem, some setting were changed in the past causing problems now with some games. These setting for some reason can no longer be accessed and that is causing problems with games. It is the AA setting that were changed, thus games that have the options to use them are causing large amounts of lag.

  9. #9
    Quote Originally Posted by fiif View Post
    Sorry, I should have worded that reply better. It is the control panel that is the problem, some setting were changed in the past causing problems now with some games. These setting for some reason can no longer be accessed and that is causing problems with games. It is the AA setting that were changed, thus games that have the options to use them are causing large amounts of lag.
    Sounds like the driver is fucked (technical term) and you need to reinstall it with CCC. - CCC normally comes with a working "defaults" button under Gaming -> 3D Application Settings -> Bottom left corner. Alternatively, if you created a profile then you could opt to delete it by going to Application Profiles.
    Kuroiwolf - 90 Brewmaster Monk
    Youtube Account Twitch TV
    Computer: Intel I7-3770k @ 4.5GHz | 16GB 1600MHz DDR3 RAM | AMD 7970 GHz @ 1200/1600 | ASUS Z77-V PRO Mobo|

  10. #10
    Just FYI the pc is mine what happened was ages ago when I booted with my hdmi in the graphics card my monitor would not pick it up so i had to reboot from the motherboard
    Fast forward to now hdmi still in motherboard not in the near 400 euro graphics card
    Sorry for wasting yer time

    one idiot gamer
    Pandasoon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •