1. #1
    Mechagnome Ineko's Avatar
    Join Date
    Jun 2012
    Location
    Australia
    Posts
    711

    FPS trouble in Borderlands 2

    So I just bought Borderlands 2 and I thought "oh yea, the computer I just spent $3000 to build should run this well" nope.....

    i5 3570k @ 4.2ghz
    GTX 680 directcuII
    16GB corsair vengeance @ 1833mhz
    (I did spend around $400 on things like sound cards, sleeved cables, fans lights etc.)

    So anyway, when I look over any large expanse of land or buildings, or get into any gun fights for that matter, the FPS drop to what feels around the 30 mark. I've tried turning PhysX off but that didn't help at all leading me to believe that it's not the problem. It is REALLY annoying.... I can run witcher 2 maxed (except for ubersamlping of course) and BF3 but borderlands just doesn't want to work.

    Yet, the video nVidia uploaded to their own channel of a PhysX demonstration which was done with a 660ti with Borderlands 2 maxed out, they seemed to run fine in intense situations with heavy PhysX effects going on.

    I've had to lower at least a few settings and spend like 1 or 2 hours adjusting settings in nVidia control panel and in-game with every game I've bought so far. Sorta makes me think what's the point... I didn't spend $2500 on hardware to turn my settings down... gah, just ranting because I'm angry.

    Back to the question, any help besides "turn PhysX off" to get nice fps in Borderlands 2 would be appreciated.

    Thanks, Ineko.

  2. #2
    Restore settings in Nvidia control panel > 3d settings > manage 3D settings, then change to "let the 3D application decide" and turn all max settings manually in game
    P.S. you spend to much money on such system, for 3k$ i could get sli 680 or 690 with i7 3770k CPU

  3. #3
    Mechagnome Ineko's Avatar
    Join Date
    Jun 2012
    Location
    Australia
    Posts
    711
    Quote Originally Posted by abracadabro View Post
    Restore settings in Nvidia control panel > 3d settings > manage 3D settings, then change to "let the 3D application decide" and turn all max settings manually in game
    P.S. you spend to much money on such system, for 3k$ i could get sli 680 or 690 with i7 3770k CPU
    I realize that but even then I bought an expensive sound cards, braided cables, extra fans and headset adding up to $500. But yea, I did lose out a bit.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •