Thread: Stealth issues

  1. #1

    Stealth issues

    Anyone else having problems with stealth randomly breaking for no reason? I will be in bgs, dungeons and even out doing dailies stealthed and it will just randomly come out of stealth. I know im not walking into flares or hitting something that brings me out, just randomly pops out. I'm already frustrated enough with the way rogues are, mine use to be my main, now he is basically parked besides doing some dailies and random bgs and dungeons. I have quit a few other lvl 90s and I feel rogues now are way behind other classes, especially pvp, so I'm done with him until blizz helps out the rogues a bit.

  2. #2
    Yes, If I go from mount into steath it will take me out of steath asap. Before i hit the ground or anything. It's been buggy for me.

  3. #3
    Are you using Subterfuge? They said they fixed it, but it has been proccing for essentially no reason since 5.0 (pre-mop).

    Another problem I was having was with an addon that automatically summoned pets. If you use Yaymounts or something similar, consider turning off the pet portion.

  4. #4
    The best was when auctions selling would break stealth. That was my all time fav.

  5. #5
    Quote Originally Posted by Enhshamanlol View Post
    Yes, If I go from mount into steath it will take me out of steath asap. Before i hit the ground or anything. It's been buggy for me.
    Do you have a pet out? This is the most probably cause.


    There is a major (imo) bug with battlepets at the moment that I've logged numerous times but heard nothing about.

    IF you dismount using an action that isn't just the dismount button, the first action that will happen is that a Pet will summon, cancelling whatever action you did.
    It's annoying fishing, but it's VERY annoying as a Rogue.

    You land, dismount with Stealth... then WHAM your pet summons, breaks you out of stealth instantly and your stood for all to see while your stealth is on cooldown. Normally I dismount running stealthed towards my enemys so this was a MASSIVE pain until I found out what it was causing it.

    If you use a flying Pet it doesnt do this as the pets already summoned... BUT all the new battle pets added are also bugged, so none of the new flying ones from 5.0 can take off. They dismiss when you take off.. you can summon them again in the air and they fly, but then they dismiss again as soon as you land and take off again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •