1. #1

    After installing RAM and hard drive, monitors are not displaying.

    The monitors, as well as the keyboard and mouse, on my computer aren't working properly anymore. The mouse + keyboard aren't even on, and the monitors have power, but they don't seem to be detected by the computer. Changing the brightness, going to the menu, ect. give me a message to the effect of the monitors being in power save mode. This happened after I installed RAM (which is compatible with my motherboard), and a new hard drive (which is identical to the current one). The graphics card was removed and reinstalled as well, to make more room. Logic tells me that is the obvious issue, but the card isn't lose. It's screwed in, the pin is down, and it doesn't move at all. The monitor cables and the keyboard/mouse were as well removed and put back.

    edit: The way the fans are acting, it might not be the video card. When the computer starts normally, the fans are very loud for a moment, and then they slow down. Now they're continually extremely loud, as if the start up process isn't working properly/never stops.. could it be an issue with the ram then?


    RAM: 16gb ddr3 (cosair vengeance)
    Graphics: radeon 6850 (sapphire)
    Monitor: asus 1650x1080 x2
    Last edited by Larynx; 2012-12-25 at 07:04 PM.

  2. #2

  3. #3
    Have you tried clearing the BIOS?

    What size of PSU have you got?

  4. #4
    I didn't mess with the power at all. didn't notice any static, and made sure to be grounded.

    ---------- Post added 2012-12-25 at 02:16 PM ----------

    Quote Originally Posted by Carlaena View Post
    Have you tried clearing the BIOS?

    What size of PSU have you got?
    Considered, but have not.
    Power is about 550 I believe? I need to upgrade it, but it's enough for the graphics card. Maybe there isn't enough with the new RAM? It was a pretty huge upgrade. 6 gb to 16.

  5. #5
    You could try disconnecting a couple of pieces to see if it is a power problem. Unplug the CDROM and your new HD just to see if it posts.

    Another things to check would be to the firmware revision of your mboard and make sure it is compatible with that much memory, it may need updating.

    Failing that, I would try a hard reset of the bios (via the mboard) to make sure all memory settings are reset.

  6. #6
    What MoBo are you running? Is it one of the Asus ones? Hopefully not the Z77 series. Also, did you have your previous HDDs as a raid or some such thing?

  7. #7
    Are there any beeps on startup? Are there any red lights that stay on inside the case after startup?

    Check your motherboard manual, and look for beep codes to coincide with what you are experiencing. I would instinctively assume a bad ram stick, or the motherboard isn't feeding it the proper voltage etc. On my ASUS board there is a MEMOK button that can be pressed to force the mobo to tune to the currently installed memory. Start by installing 1 stick of memory, and try all 4 sticks on their own. If 3 boot, you have a bad stick etc.

    If none of the sticks boot, google your motherboard and look up a list of compatible memory. *edit* Re-read your post and noticed you said it is compatible. Check each memory stick individually now. Also as previous posters have mentioned it could be your bios revision does not support 4GB per slot. It would be nice to know your motherboard to assist in troubleshooting this problem.

    The new hard drive should not be causing this issue. The monitor should always display at least the bios POST message even if an incorrect (or no) boot drive/partition is selected.
    Last edited by Elgand; 2012-12-26 at 07:00 AM.

  8. #8
    RAM-wise, what does your motherboard max out at? If its more than your MOBO can handle it might cause issues; other than that the only thing I can think of is something is loose.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts