Page 2 of 2 FirstFirst
1
2
  1. #21
    High Overlord
    Join Date
    Nov 2011
    Location
    Sweland
    Posts
    173
    I've had some weird issues with these 3 spells for a looong time now, been driving me nuts. It's weird that I haven't seen many warlocks noticing it until lately.

  2. #22
    The SoC is consumed as soon as it is finished casting.

  3. #23
    All those problems with Soulburn, Soul Swap and the combination of both could be fixed by giving us a new spell which innately uses a soulshard (like Haunt) to apply all three DoTs to a target at once. This way we could also apply Glyph of Soul Swap without prohibiting the use of Soulburn + Soul Swap for 30 seconds, a major hindrance in the application of the Glyph in my oppinion.

  4. #24
    Stood in the Fire JV Chequer's Avatar
    Join Date
    Nov 2012
    Location
    Brazil
    Posts
    454
    Quote Originally Posted by luckydevours View Post
    All those problems with Soulburn, Soul Swap and the combination of both could be fixed by giving us a new spell which innately uses a soulshard (like Haunt) to apply all three DoTs to a target at once. This way we could also apply Glyph of Soul Swap without prohibiting the use of Soulburn + Soul Swap for 30 seconds, a major hindrance in the application of the Glyph in my oppinion.
    Indeed.
    You should post it on official.

  5. #25
    High Overlord
    Join Date
    May 2010
    Location
    France
    Posts
    148
    This. Agreed!

    Infracted. Post more constructively, please.
    Last edited by xskarma; 2013-01-02 at 02:41 PM.

  6. #26
    Quote Originally Posted by Schaendwich View Post
    Hello fellow Locks,

    Since a couple of weeks there is something that bugs me and I just wanted to ask if any of you experience the same problem as me and if there maybe even mght be an easy solution:

    I realized this as a major problem on Windlord in HoF for the first time. When I am using SoC and right after I want to SB:SS, the SoC consumes the SB midflight and my SS takes off all the dots from the target. Until I realized thid, 3-4 seconds went by and my dots are totally screwed up. And waiting 2 seconds until the seed actually hit the target cant be the solution either :/.

    Any suggestions? Much appreciated as always!

    regards
    Well if that's true that certainly explains my issues with this on this fight, yesterday too. I'll check next reset to see if thats really the cause!

    ---------- Post added 2013-01-03 at 02:11 PM ----------

    Quote Originally Posted by meekus View Post
    I've had some weird issues with these 3 spells for a looong time now, been driving me nuts. It's weird that I haven't seen many warlocks noticing it until lately.
    Well, I suppose most warlocks notice there's something 'off', sometimes, but I for one have difficulties putting my finger on the exact cause. It just happens every now and then and completely unexpected for me, too, and often I'm really way too busy with the encounter to try and reproduce, by the end of the encounter I'll have forgotten all about it, such as Windlord, if not for this topic I'd never have given the issues I had a second thought.

  7. #27
    From a couple of test on the dummies, these are the observations I have found so far:

    - It happens when you have Soulburn active at the time a seed explosion should take place.
    - The original explosion will not take place, the debuff will simply disappear.
    - It casts a new, instant, off the global cooldown Soulburn: Seed of Corruption on your current target (though the spell animation will show it being cast on the original seed target).
    - It will only cast the instant SB: Seed if you're in range of the original target. If you are not in range of the original target then the Seed debuff will disappear with no explosion and you will keep your Soulburn buff with no new recasts, regardless of being in range of your current target or not.

  8. #28
    Thanks Sakpoth for the effort, now we at least know what technically goes wrong .

    I posted about this on the EU Forums, but my thread got moved to the Warlock Forums and has no responses at all. I also sent an ingame bug report. Still i dont really feel that this will make anyone really look into this. Any suggestions about what else we can do to get some attention?

  9. #29
    Quote Originally Posted by Schaendwich View Post
    Thanks Sakpoth for the effort, now we at least know what technically goes wrong .

    I posted about this on the EU Forums, but my thread got moved to the Warlock Forums and has no responses at all. I also sent an ingame bug report. Still i dont really feel that this will make anyone really look into this. Any suggestions about what else we can do to get some attention?
    did people really avoid what i wrote months ago?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •