1. #1
    Mechagnome MayronEU's Avatar
    Join Date
    Mar 2012
    Location
    England
    Posts
    583

    Need help with Steam - Game will not play.

    Hi and thank you for reading this. When I try to play "SkyDrift" on Steam is begins to download the Microsoft Visual C++ 2010 Redist package which I already have by the looks of it. I have tried running the game many times and it keeps trying to re-download it again and again. The box then disappears and nothing happens. This is what shows for around 5 seconds before disappearing:



    I have only tried right clicking on the game and going to properties and going to Local Files to Verify Integrity of Game Cache as I've been told many times in the past that this can fix strange issues such as this but it has not helped. This game works fine on my Desktop computer but not on my Laptop. My Laptop has a reasonably good spec so this should not be an issue.

    If any one knows of a possible fix to this problem or some advice then I would be greatly appreciated if you could share it with me! Thank you so much for your time in advance!

  2. #2

  3. #3

  4. #4
    Pandaren Monk skatblast's Avatar
    Join Date
    Dec 2010
    Location
    Indiana
    Posts
    1,957
    Post on the steam forums bro

  5. #5
    let me try that

  6. #6
    Mechagnome MayronEU's Avatar
    Join Date
    Mar 2012
    Location
    England
    Posts
    583
    Quote Originally Posted by skatblast View Post
    Post on the steam forums bro
    Every time I post something on the steam forums it gets ignored. At least I get things answered on mmo-champion

    ---------- Post added 2013-01-04 at 12:42 PM ----------

    I could not get SkyDrift to work unfortunately. I've tried uninstalling Microsoft Visual C++ 2010 Redist as well as the game itself and reinstalling etc but nothing works. Ah well thanks anyway

  7. #7
    Install it once, then restart your pc.
    Kuroiwolf - 90 Brewmaster Monk
    Youtube Account Twitch TV
    Computer: Intel I7-3770k @ 4.5GHz | 16GB 1600MHz DDR3 RAM | AMD 7970 GHz @ 1200/1600 | ASUS Z77-V PRO Mobo|

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •