Page 1 of 2
1
2
LastLast
  1. #1

    WoW model viewer for 5.2 models

    Now I have used wow model viewer a bit, bit I am having trouble getting the 5.2 models to be shown in it. I mean i cna even use an MPQ viewer to go into the files and see the file for the mob I need but then I can't have viewer get to it, so I can't show what I want to >.<
    Would anybody be able to help me understand how to get it to work?

  2. #2
    High Overlord Thunderspeed's Avatar
    Join Date
    Sep 2012
    Location
    Sligo, Ireland
    Posts
    188
    Do you have "Discovery Items" and "Discovery NPC" enabled ? Otherwise they won't show up.

    And are you sure you've hooked up your PTR Folder ?


    Thanks Elyaan | My Work | Requests:CLOSED

  3. #3
    Over 9000! ELYPOP's Avatar
    Join Date
    Jul 2009
    Location
    London, England.
    Posts
    9,780
    File -> Discovery Items.
    Open up a character model.
    Search "Item".
    Go to the bottom end of the list, and go through the items there. They're the most recently added.

    Have fun with that.

    Quote Originally Posted by Thunderspeed View Post
    Do you have "Discovery Items" and "Discovery NPC" enabled ? Otherwise they won't show up.
    Discovery NPC isn't necessary unless you want NPC gear. And they're named "NPCxxxxx" (replace the x's for numbers).
    "You're only given one little spark of madness, you mustn't lose it."
    - Robin Williams (1951-2014)

  4. #4
    Well, I have that on, but more importantly I am looking for models for mobs, Oondasta to be precise. With discovery on and everything as it "should" be to to able to see it, I still cannot :x

  5. #5
    Over 9000! ELYPOP's Avatar
    Join Date
    Jul 2009
    Location
    London, England.
    Posts
    9,780
    Quote Originally Posted by Maxweii View Post
    Well, I have that on, but more importantly I am looking for models for mobs, Oondasta to be precise. With discovery on and everything as it "should" be to to able to see it, I still cannot :x
    Oh. Unique NPC models are found under the Creature directory. And they're not named by NPC. Oonadasta is under Zandalaridevilsaur.

    "You're only given one little spark of madness, you mustn't lose it."
    - Robin Williams (1951-2014)

  6. #6
    I've seen his MPQ file, I know that just.
    Bah this sounds dumb but I have the PTR folder loaded, discover on, all files in there and such. I mean even the specific file I looked to see that has him, is in there. But I can't access it.
    Hm. Maybe try reloading the ptr into it? Cus I honestly am dumbfounded at this

  7. #7
    Over 9000! ELYPOP's Avatar
    Join Date
    Jul 2009
    Location
    London, England.
    Posts
    9,780
    Quote Originally Posted by Maxweii View Post
    I've seen his MPQ file, I know that just.
    Bah this sounds dumb but I have the PTR folder loaded, discover on, all files in there and such. I mean even the specific file I looked to see that has him, is in there. But I can't access it.
    Hm. Maybe try reloading the ptr into it? Cus I honestly am dumbfounded at this
    Options -> Settings.

    Click Reset.

    When the box pops up, click the x in the top corner (not cancel!).

    Now, find your PTR folder from the browse box that pops up. Just click the PTR folder and click OK.

    Click OK on the popups/prompts.

    Close WMV normally, via the x, and then reopen it.

    Go to the bottom of the creature's list, and it should be there, under Zandalaridevilsaur.
    "You're only given one little spark of madness, you mustn't lose it."
    - Robin Williams (1951-2014)

  8. #8
    Quote Originally Posted by Elyaan View Post
    Options -> Settings.

    Click Reset.

    When the box pops up, click the x in the top corner (not cancel!).

    Now, find your PTR folder from the browse box that pops up. Just click the PTR folder and click OK.

    Click OK on the popups/prompts.

    Close WMV normally, via the x, and then reopen it.

    Go to the bottom of the creature's list, and it should be there, under Zandalaridevilsaur.
    First off you are being just beyond helpful and I appreciate this greatly!
    I did these exact steps, three times to be sure I didn't mess anything up. And still nothing.
    As you see on your's it goes from "Yseradragon" to the zandalari creatures, mine goes "yseradragon" right to "Zebramount".

  9. #9
    Over 9000! ELYPOP's Avatar
    Join Date
    Jul 2009
    Location
    London, England.
    Posts
    9,780
    Quote Originally Posted by Maxweii View Post
    First off you are being just beyond helpful and I appreciate this greatly!
    I did these exact steps, three times to be sure I didn't mess anything up. And still nothing.
    As you see on your's it goes from "Yseradragon" to the zandalari creatures, mine goes "yseradragon" right to "Zebramount".
    No worries.

    And hmm. Odd. Is your PTR fully patched?

    And what WMV are you using?

    https://wowmodelviewer.atlassian.net...W+Model+Viewer

    Make sure you're using the latest Beta version (0.7.0.5-mingw3).
    "You're only given one little spark of madness, you mustn't lose it."
    - Robin Williams (1951-2014)

  10. #10
    Checked and the PTR is fully patched, just re-installed MWV Player.
    While I downloaded and installed mingw3, it loads in as mingw2... which is curious now that I notice that

  11. #11
    Over 9000! ELYPOP's Avatar
    Join Date
    Jul 2009
    Location
    London, England.
    Posts
    9,780
    Quote Originally Posted by Maxweii View Post
    Checked and the PTR is fully patched, just re-installed MWV Player.
    While I downloaded and installed mingw3, it loads in as mingw2... which is curious now that I notice that
    Yeah, it's labelled wrong after installing. It's fine. So, did that work?
    "You're only given one little spark of madness, you mustn't lose it."
    - Robin Williams (1951-2014)

  12. #12
    Quote Originally Posted by Elyaan View Post
    Yeah, it's labelled wrong after installing. It's fine. So, did that work?
    No sadly it did not.

    See this is my confusion, as far as everything goes I have done 100% of what needs to be done to be able to view it, even reproduced steps you said (which you showed the guy) and yet, for me, nothing.

  13. #13
    Over 9000! ELYPOP's Avatar
    Join Date
    Jul 2009
    Location
    London, England.
    Posts
    9,780
    Quote Originally Posted by Maxweii View Post
    No sadly it did not.

    See this is my confusion, as far as everything goes I have done 100% of what needs to be done to be able to view it, even reproduced steps you said (which you showed the guy) and yet, for me, nothing.
    It's worked fine for everyone that I know.

    *Shrug.*

    Sorry.
    "You're only given one little spark of madness, you mustn't lose it."
    - Robin Williams (1951-2014)

  14. #14
    Quote Originally Posted by Elyaan View Post
    It's worked fine for everyone that I know.

    *Shrug.*

    Sorry.
    Your help is greatly appreciated :c I think I am just in an infinite loop of Oondasta's trickery. Or wait.. infinite loop....

    DANM YOU NOZDORMU

  15. #15
    High Overlord Thunderspeed's Avatar
    Join Date
    Sep 2012
    Location
    Sligo, Ireland
    Posts
    188
    Quote Originally Posted by Elyaan View Post
    It's worked fine for everyone that I know.

    *Shrug.*

    Sorry.
    @Ely just Curios as to how many times the latest beta release crashes for you or if I'm just being far too experimental...


    Thanks Elyaan | My Work | Requests:CLOSED

  16. #16
    Over 9000! ELYPOP's Avatar
    Join Date
    Jul 2009
    Location
    London, England.
    Posts
    9,780
    Quote Originally Posted by Maxweii View Post
    Your help is greatly appreciated :c I think I am just in an infinite loop of Oondasta's trickery. Or wait.. infinite loop....

    DANM YOU NOZDORMU
    No problem.

    Quote Originally Posted by Thunderspeed View Post
    @Ely just Curios as to how many times the latest beta release crashes for you or if I'm just being far too experimental...
    It hasn't crashed for me at all. *Shrug.*
    "You're only given one little spark of madness, you mustn't lose it."
    - Robin Williams (1951-2014)

  17. #17
    Adding new MPQs often doesn't work. Try just downloading a fresh version of the model viewer and when you start that up the first time it will ask whether to read from live Wow or the PTR version.

    Tell it to use the PTR, then run <discovery NPC> and <discovery item>.

  18. #18
    Ok, in the last build I had this problem too, open the PTR launcher, go to Help and Repair Tool, then reset the Modelviewer, you can do what Elyaan said or just delete the config file inside UserSetings in the modelviewer folder, I hope this helps you !_!

  19. #19
    This is strange... my WMV was working fine but I recently reinstalled the PTR and now I'm having the same trouble as the OP with 5.3 -- It can display all the new items no problem, but there is just no trace of any of the 5.3 NPCs at all.

    I've reset it countless times, reinstalled the WMV, ran the repair tool, made sure every MPQ is loaded... i've done everything I can think of.

    I'd love to see if anyone ever found a fix for this?

  20. #20
    Redownloading fixed my issue with the PTR items.

    Does anyone know how to stop every item list from having a billion Martin Fury, Art Template, 69 TEST, [01928][974] items? Cropped up a couple versions ago and never went away, makes scrolling through items a total pain.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •