1. #1

    Tips to stop random huge FPS drops and artifacts?

    I built this beast computer a couple days ago, i5k Sandy Bridge, GeForce 660 GTX, 8GB 1600 MHz HyperX ram and an Intel 520 generation SSD.

    It's a shameless beast of a beast. 650W power supply.

    But it stutters in GW2 sometimes - I have everything turned on high from both the Nvidia Control Panel and in game settings. Like I'll be running around at 50-70 fps then I'll get weird artifacts on screen and random fps drop to 20-30 fps.

    The artifacts look as if the world geometry is falling apart and weird lines appear everywhere for a fraction of a second.

    Anyone have any suggestion to fix this, like lowering a specific setting that's known to cause problems? Thanks!

  2. #2
    Stood in the Fire Fernling306's Avatar
    Join Date
    Oct 2011
    Location
    United States
    Posts
    490
    Quote Originally Posted by ragnarokvr1 View Post
    I built this beast computer a couple days ago, i5k Sandy Bridge, GeForce 660 GTX, 8GB 1600 MHz HyperX ram and an Intel 520 generation SSD.

    It's a shameless beast of a beast. 650W power supply.

    But it stutters in GW2 sometimes - I have everything turned on high from both the Nvidia Control Panel and in game settings. Like I'll be running around at 50-70 fps then I'll get weird artifacts on screen and random fps drop to 20-30 fps.

    The artifacts look as if the world geometry is falling apart and weird lines appear everywhere for a fraction of a second.

    Anyone have any suggestion to fix this, like lowering a specific setting that's known to cause problems? Thanks!
    Sounds like driver issues or a bad video card.

  3. #3
    Bloodsail Admiral Lazuli's Avatar
    Join Date
    Oct 2012
    Location
    Your Moms House
    Posts
    1,088
    Are you up to date on drivers? 310.90 is current http://www.geforce.com/

    Btw GW2 is highly unoptimized and hates nvidia cards... I have the same problems, just gotta deal with it or buy AMD.

  4. #4
    I run a 660 GTX also, I had issues till I turned the "reflections" to none. Didn't really notice any visual differences. Getting 60+ fps now consistently. I would try updating your drivers first though before lowering any settings.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •