1. #1

    Misdirection Immediately Fades

    Is anyone else having this problem? I cast Misdirection and with my first shot, Misdirection applies and then immediately fades. I went back and forth with Blizz resetting my UI etc, and they finally said they were working on this problem. It's maddening because I can only cast Misdirection for that one shot. Makes it hard to play the game and it doesn't pull any extra mobs off of me and onto my pet. I noticed it after this week's restart but I don't see any other posting online about this problem. It would make me feel hopeful of a solution sooner rather than later if I knew others were having the same issue.

  2. #2
    I haven't noticed this problem, but I often have MD trigger off of nothing when we're getting ready to pull. I'm standing there, cast MD on tank cos we're about to pull and then it just randomly goes off and goes on cooldown.

    Anyone experience this? Can't figure out what is causing it.

  3. #3
    I was using it very happily on Blade Lord yesterday.... dunno where these issues are coming from.

  4. #4
    Quote Originally Posted by mediic View Post
    I haven't noticed this problem, but I often have MD trigger off of nothing when we're getting ready to pull. I'm standing there, cast MD on tank cos we're about to pull and then it just randomly goes off and goes on cooldown.

    Anyone experience this? Can't figure out what is causing it.
    that has happened to me before in cata in DS. always made me nervous thinking i pulled the boss

    very odd

  5. #5
    High Overlord
    Join Date
    Jun 2012
    Location
    Sydney
    Posts
    131
    Quote Originally Posted by mediic View Post
    I haven't noticed this problem, but I often have MD trigger off of nothing when we're getting ready to pull. I'm standing there, cast MD on tank cos we're about to pull and then it just randomly goes off and goes on cooldown.

    Anyone experience this? Can't figure out what is causing it.
    This has happened to me too

  6. #6
    Dreadlord Jawless Jones's Avatar
    Join Date
    Sep 2012
    Location
    The last place you look
    Posts
    963
    its not just MD

    mage invis sometimes ends for no reason as well

    ive had the same thing with angelic feather disappearing off the ground as well
    Quote Originally Posted by Zombiebob
    I'm still waiting on someone to tell me where all these people that suddenly care about Warrior balance were during Cataclysm when they were blow up dolls with plate armor on.
    Quote Originally Posted by cutterx2202 View Post
    Stop complaining to solve your lack of ability, and start reading and practicing to gain ability. Stop trying to bring people down to your level instead of striving to raise yours.

  7. #7
    Quote Originally Posted by mediic View Post
    I haven't noticed this problem, but I often have MD trigger off of nothing when we're getting ready to pull. I'm standing there, cast MD on tank cos we're about to pull and then it just randomly goes off and goes on cooldown.

    Anyone experience this? Can't figure out what is causing it.
    I've seen this as well, but it is fairly rare. Though lately it is of no concern because Glyph of Direction is bugged to make Misdirection have no CD. So when I see it happen, I quickly right click it off and re-apply it. Probably be astronomical for it to happen twice in a row.

  8. #8
    Herald of the Titans Asrialol's Avatar
    Join Date
    Oct 2009
    Location
    Hunter Forums <3
    Posts
    2,781
    Quote Originally Posted by mediic View Post
    I haven't noticed this problem, but I often have MD trigger off of nothing when we're getting ready to pull. I'm standing there, cast MD on tank cos we're about to pull and then it just randomly goes off and goes on cooldown.

    Anyone experience this? Can't figure out what is causing it.
    Misidrection has a cooldown?
    Oh, right. Bugged glyph. Kinda love it.

    Haven't noticed this issue myself so can't really comment or speculate. Perhaps there is some sort of third-party effect triggering it?

  9. #9
    Happens to me all the time. Thought it was applying MD before Hunter's Mark but it just tends to disappear randomly for me. I've never had it happen in combat though, only before the pull.

  10. #10
    Only happened to me on Grand Empress, when Im supposed to MD the adds that comes. Every time, though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •