1. #1

    XFX HD 7970 Ghz Problem

    so I ordered this GPU http://www.newegg.ca/Product/Product...96&PID=3938566

    I got the GPU, installed it and everything seemed to go great. Installed AMD's latest 12.10 drivers and started up Crysis 2 on ultra. I get into the first mission and about 5 minutes in my monitor loses signal to the video card and the video card fans spin up to 100% very loud. I can't get out of the black screen so I have to do a reset. I thought maybe it was just a one time thing but it happened everytime I played Crysis 2, same thing in Battlefield 3 and Dota 2 tho oddly enough it doesn't happen in World of Warcraft. I tried using AMD's beta 12.11 drivers but it just keeps black screening. I set the voltage in CCC to 20% but that hasn't made a difference, even underclocking the card doesn't help.

    Do I need to RMA this card or is there some easy fix I don't know about? I love the cards performance it's absolutely amazing, I just wish I could play a game for more than 5 minutes.

  2. #2
    Possibly vsync is enabled and you sure don't have a 99% gpu load while in crysis 2 you have. Just check your temps with gpu-z

  3. #3
    The Lightbringer CheezusCrust's Avatar
    Join Date
    Feb 2011
    Location
    Nuuk, Greenland
    Posts
    3,286
    Quote Originally Posted by Faithh View Post
    Possibly vsync is enabled and you sure don't have a 99% gpu load while in crysis 2 you have. Just check your temps with gpu-z
    You mean disabled right?

    What are you temps when playing the game?

  4. #4
    Quote Originally Posted by inux94 View Post
    You mean disabled right?

    What are you temps when playing the game?

    It happens if Vsync is on or off, the gpu load hits around 75-80% and the temperature stays around 61-65 c while playing

  5. #5
    The Lightbringer CheezusCrust's Avatar
    Join Date
    Feb 2011
    Location
    Nuuk, Greenland
    Posts
    3,286
    Temps look fine, can you try the card in another rig?

  6. #6
    Tried the card in my brother's tower, same thing. I tried my HD 7850 in my tower just to be sure it wasn't a problem with my other hardware and it ran fine.

  7. #7
    What's the PSU in your rig? Does it have sufficient wattage?

    edit: never mind, didn't read your post thoroughly.
    SYSTEM SPECS
    Case: CM 690 II | Mobo: ASUS P8Z68-V Pro
    CPU: 2500K @ 4.7Ghz| CPU Cooler: Mugen 2
    GPU: 6950 1GB | RAM: Corsair XMS3 8GB @ 1600
    SSD: m4 128GB | HDD: F3 1TB| PSU: XFX 650W

  8. #8
    My friend had the exact same problem with his video card ended up being the card was faulty I suggest taking it back and getting a replacement.
    You could always run a vga stress test before taking it back.

  9. #9
    Quote Originally Posted by OldSchool View Post
    My friend had the exact same problem with his video card ended up being the card was faulty I suggest taking it back and getting a replacement.
    You could always run a vga stress test before taking it back.

    Weird thing is I ran several stress tests in furmark with absolutely no problem. I might just RMA the card and go with a GTX 670, I've only had problems with the AMD cards I've owned. I'm worried I won't get the same performance in battlefield 3 and Crysis 2 that I did with the 7970.

  10. #10
    The Lightbringer CheezusCrust's Avatar
    Join Date
    Feb 2011
    Location
    Nuuk, Greenland
    Posts
    3,286
    If the same thing happened on your brother's rig, it's a bad card.

  11. #11
    Just rma the card and the 670 is a better card imo for 1080p.

  12. #12
    XFX cards aint the most reliable tbh. We have had to RMA them more than any other type. I just use a reference MSI R7970 and have zero issues maxing out any game
    i5 3570K @ 4.8GHZ / Thermaltake Water Extreme 2.0 Cooling / Asus Maximus V Formula - Thunder FX Mobo / 8GB GSkill Trident X RAM @ 2400MHZ / MSI R7970 3GB @ 1200/1700 / OCZ Agility 120GB SSD OS Drive / 2x2TB Raid 1 Data / Thermaltake Toughpower Grande 750W PSU / Thermaltake Chaser MK-1 Chassis
    - 24/7
    - Stable Test

  13. #13
    I hate my XFX 7970 (non GHz edition). Stupid thing doesn't overclock at ALL. And the voltage is locked on it even though the picture on newegg had the bios switch (mine doesn't). Sadly I sent in the rebate right away like an idiot so no refund.

    XFX is the lowest price for a reason and when you are spending hundreds of dollars it is not worth it to save 20 bucks and be unhappy. Sorry just had to rant.

    And no, the 670 is not better than the 7970 GHz... lol

    I would RMA it and get a gigabyte, msi, sapphire, asus, something else.
    Last edited by mojo6912; 2013-01-14 at 12:58 PM.

  14. #14
    Hi I also have a problem. Free Running with R7970 things as well, but just runs the game's larger capacity HD, quiet sound is heard from the computer VGA and restartuojasi. Could it be a problem dep PCI Expres 2.0 because it requires that the number of PCI-Expres 3.0. or may be a problem with that

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •