1. #1

    Cloud Serpents not counting for 150 mounts achieve?

    Is this happening to anyone else? I've gotten all three of the cloud serpent mounts from Order of the Cloud Serpent but my mount counter hasn't gone up on the achievement in progress. I checked before I got my first one and it stayed at 132/150. Then I got another one about a day later and still, no change on the counter. I got the last one today and it still didn't give me more progress on the achievement. I'm going to get my Onyx serpent from the Shado-Pan quest in a few days and I really hope that it gives me more on my counter but with how things look right now, it doesn't seem likely.

    Is this happening to anyone else or is this a bug or what?

  2. #2
    Don't know if there's been a blue post/tweet but as far as I can tell, none of the MoP mounts count for more than 1 of their type. For example, the 12 turtles the Panderan give only count as 1 unique mount; same deal for Cloud Serpents, Shado-Pan riding tigers, etc.

  3. #3
    What the hell? Why would that be the case. Dammit blizzard... I'm glad I didn't buy the others but used alts to get them for free or else there goes a big waste of money. I wonder if that is intended or not.

  4. #4
    I got credit for each turtle, but I only got +1 for each unique of the cloud serpents, cranes, ect.
    Omnipotent WCL || Omnipotent Site || Stream: 5-9pm PST Tues/Wed/Thurs || Worst Btag Ever: Slenderman#1355

  5. #5
    Legendary! The Glitch's Avatar
    Join Date
    Nov 2009
    Location
    Litwak's Arcade Sunny Scotland!
    Posts
    6,138
    Thats strange all the cloud serpeant mounts and turtles counted on my mount counter;o I know a few folks have been having issues with glitches in the pet/mount UI, (giving multiple mounts and pets of the same etc, hell some guildies had a counter of 700+ mounts when they logge din one day) So maybe its just a UI glitch?

  6. #6
    Dreadlord ItsRedd's Avatar
    Join Date
    Dec 2012
    Location
    Amsterdam
    Posts
    865
    Pretty sure I got +12 count for my turtles...

    But now that I read this, I was wondering the other day whether I shouldn't have more mounts than the counter says. Seems like it's stuck in the 160s for ages now.
    I do know that the counter on the armory is bugged. Shows about 25 mounts more than I actually have. (or.... does the game show 25 too few? x.x) Says 165 ingame and 188 on the armory.

    I guess I'll be manually counting them tonight.... meh.

    Edit

    I see several mounts on my armory that I don't have. It's the horde version of mounts that I do have. (Armored brown bear, black war mammoth, etc)
    Last edited by ItsRedd; 2013-01-17 at 11:25 AM.

  7. #7
    I do remember getting credit for all the turtles, but the other ones, nothing. Ugh kind of annoying... Still wondering if this is intended or not.

  8. #8
    Maybe I'm wrong about the turtles but I had 187 mounts according to my Mount tab in-game. After buying and learning them I still had 187 but my armory updated to 217 (was already a discrepancy between armory and in-game ournal before learning the mounts).

    Edit: Should have read someone's previous post. Forgot that having one mount specific to a faction unlocked it for the other faction so that explains some of the discrepancy. Still don't know why my in-game mount tab didn't update after learning the turtles.

  9. #9
    Brewmaster xindykawai's Avatar
    Join Date
    Jan 2011
    Location
    Lost in the twisting nether
    Posts
    1,485
    hum seems like a bug to me, i got credits for all my pandaria mount oO...

  10. #10
    Opened a ticket ingame and finally got a response. Apparently its not totally a bug, but it does happen to some people. To fix it, you have to log onto every character on your battle.net account (even your other accounts if you have them linked on there) and then the mount counter will fix. So happy to know that I'm not doomed after all

  11. #11
    Quote Originally Posted by ace1231337 View Post
    Opened a ticket ingame and finally got a response. Apparently its not totally a bug, but it does happen to some people. To fix it, you have to log onto every character on your battle.net account (even your other accounts if you have them linked on there) and then the mount counter will fix. So happy to know that I'm not doomed after all
    Thanks for the update.

  12. #12
    Counted mine last night and it added up perfectly.
    Originally Posted by Zarhym
    Someone needs to take away your keyboard until you're better able to read the explicit meaning in sentences without implying whatever you want in order to be contrary.

  13. #13
    Moderator Kerdoz's Avatar
    Join Date
    Apr 2011
    Location
    Sweden
    Posts
    7,078
    Quote Originally Posted by ace1231337 View Post
    Opened a ticket ingame and finally got a response. Apparently its not totally a bug, but it does happen to some people. To fix it, you have to log onto every character on your battle.net account (even your other accounts if you have them linked on there) and then the mount counter will fix. So happy to know that I'm not doomed after all
    Wow. Lets hope that does not happen to me. I do not want to subsribe one month on my 2 frozen accounts

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •