1. #1
    Scarab Lord breadisfunny's Avatar
    Join Date
    Dec 2012
    Location
    wisconsin
    Posts
    4,038

    computer is taking longer and longer to shut down.

    lately my computer has been taking quite some time to shut down. anywhere between 15-20 seconds just to log out during the shut down process. not sure if its some sort of virus/rootkit/malware/trojan i may have acquired. my scanners show nothing. (yes i realize the best nasties are ones that can't be detected or are zero day exploits just trying to help others pinpoint.) i have not defragmented my now 1 year old computer yet. i have windows 7 home premium so i think it already does that in the background does it not? or is that something else im thinking of and i still need to defragment? this only happens when i go to shut down the computer and not at any other time does it slow down.

  2. #2
    Run defreg and it will analysis first. Checkdisk is useful too.

    It could well be alot of stuff running in the background that the system has to shutdown, look at what is running in the background, you may find that a reinstall fixes it all,

  3. #3
    Quote Originally Posted by breadisfunny View Post
    lately my computer has been taking quite some time to shut down. anywhere between 15-20 seconds just to log out during the shut down process. not sure if its some sort of virus/rootkit/malware/trojan i may have acquired. my scanners show nothing. (yes i realize the best nasties are ones that can't be detected or are zero day exploits just trying to help others pinpoint.) i have not defragmented my now 1 year old computer yet. i have windows 7 home premium so i think it already does that in the background does it not? or is that something else im thinking of and i still need to defragment? this only happens when i go to shut down the computer and not at any other time does it slow down.
    Go and d/l a free trial of this program, better yet they do have an online scan tool as well I believe.......................Prevx 3.0, its more then likely not a virus or root-kit but at least you can eliminate that.

    You could also disable your internet or adapter and try a shut down and see if its any quicker, perhaps something is trying to communicate to a server as you shut down.

  4. #4
    Bloodsail Admiral looz's Avatar
    Join Date
    Nov 2010
    Location
    Finland
    Posts
    1,136
    Check what happens if you manually quit from steam some time before shutting down the computer, in case you have it running.
    i5 4690k ♦ Z97-A ♦ GTX 760 SLI ♦ 8 GB ♦ 120Gb + 1Tb + 4Tb ♦ Define R4

  5. #5
    Sounds more like you have a process or two still running in the background when you shut down your system, which causes a longer shutdown time because windows has to close it. Could be nothing, could be something that was installed when you installed a program or new piece of hardware.

    Not sure if your defrag is set to run at a certain time I know mine never was. But it is something you can easy check and set up yourself if its not.

  6. #6
    Epic! Idrinkwhiterussians's Avatar
    Join Date
    Dec 2010
    Location
    In a bar. Somewhere that carries Khalua, cream and Vodka
    Posts
    1,548
    If you have an SSD, do NOT defrag it. This causes unnecessary writes on the SSD, thereby reducing the life expectancy.

    HDD go ahead and do so, if necessary. You could also do it overnight.
    Quote Originally Posted by Cyanotical View Post
    anyone want doughnuts? i hear there is a great shop in Vancouver

  7. #7
    Scarab Lord breadisfunny's Avatar
    Join Date
    Dec 2012
    Location
    wisconsin
    Posts
    4,038
    Quote Originally Posted by darklogrus View Post
    Sounds more like you have a process or two still running in the background when you shut down your system, which causes a longer shutdown time because windows has to close it. Could be nothing, could be something that was installed when you installed a program or new piece of hardware.

    Not sure if your defrag is set to run at a certain time I know mine never was. But it is something you can easy check and set up yourself if its not.
    okay how do i check when defrag is set to run in windows 7? is it in the control panel? and if so where in the control panel?

  8. #8
    Immortal Notarget's Avatar
    Join Date
    Feb 2010
    Location
    Dark Side of the Moon
    Posts
    7,447
    Start > type: defrag > Disk Defragmenter

    Also try this...

    Open a note pad, copy and paste the following:

    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control]
    "WaitToKillServiceTimeout"="2000"

    Save it, then rename it to .bat instead of .txt, run it and hit yes.

    -------------------------------------------------------------------

    You can try this as well if above isn't enough:

    2. Create a Fast Shutdown Shortcut
    As of Windows 2000, Windows has come with a remote shutdown tool to shut down and restart Windows. You can control this tool through the command line, but a much faster alternative is to create a shortcut.
    Right-click your Windows 7 desktop and select > New > Shortcut.
    Enter > shutdown.exe -s -t 00 -f in the location field, click > Next, give the shortcut a descriptive name, e.g. Shut Down Computer, and click Finish.

    The letters (options) added above tell the tool to shut down (-s) with a timeout of zero seconds (-t 00), and to force running applications to close without forewarning the user (-f). Basically, it unites the registry hacks from the first tip in the shutdown process. You can see a full list of options when typing > shutdown.exe into the command prompt, which you can open via > [WINDOWS] + [R] then type > cmd into the text field and click > OK.
    You can move this shortcut from the desktop to your quick launch bar or pin it to the taskbar. Double-click the shortcut to instantly shut down the system.

    If you keep having this problem try this:

    Try performing a clean boot to determine if it resolves the issue.

    Performing a Clean Boot:

    Click Start Orb > type msconfig in the searchbox
    Click msconfig in the search results
    Click the General tab, and click Selective Startup
    Under Selective Startup uncheck Load Startup items
    Click the Services tab, check the Hide all Microsoft Services box, and then click Disable All
    Click OK, and when you are prompted, click Restart.

    If the problem does not return while your computer is in clean boot mode, a background program is likely causing interference. You can try to determine which background program is causing the problem while the computer is in clean boot mode.

    To try to determine which background program is causing the problem, start by turning off all drivers, third-party programs or services, and startup items that load with Windows. Then, if the problem is resolved, turn back on half of these services to try to isolate the interfering service. If the problem is not resolved at this point, you will repeat this process until you have isolated the interfering service. Finally, if you are able to determine which specific program or service is causing the problem, contact the program manufacturer to determine whether there is a solution. You can also disable the program or service to resolve the problem.
    Last edited by Notarget; 2013-02-19 at 06:52 PM.
    CPU: Intel i5-3570k (4.5GHz) MB: ASUS Z77 Sabertooth (uefi 2003)
    GPU: Asus 280X TOP (1080MHz/1700MHz) RAM: Corsair LP/LV white 8GB 1600MHz
    SSD: Samsung 840Pro 256GB + Crucial m4 128GB (040H) PSU: Seasonic 620M CASE: Corsair 500R (White/Black) Monitor: LG 237L-BN IPS
    Current build! ||Old Build || Bitdefender Total Security 2015 || AV-TEST 2014

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •