1. #1

    Logitech G600 input lag

    Basically as we all know, Avaga 9800 sensors have slight input lag. Can anyone with this mouse record this? You know, cam showing mouse and cursor, just to compare. Im torn apart if to buy this mouse or not, because I want MMO mouse, and rest of them doesnt even compare ergonomics-wise to me (naga, corsair m90, cyborg rat 7).

  2. #2
    I bought this mouse and notice some lag, but also randomly it just changes my camera angle while im doing things. Its frustraing, usualy it turns me around when im flying.

  3. #3
    Thats fixable, use auto game detection instead of onboard memory. However, to get rid of lag Avago released firmware update, but G600 have no flashable firmware (fail), so I ask for a video to see how bad it is.

  4. #4
    How much input lag are we talking about here? it needs to be pretty high to be noticeable with a 30FPS video.
    Intel i5-3570K @ 4.7GHz | MSI Z77 Mpower | Noctua NH-D14 | Corsair Vengeance LP White 1.35V 8GB 1600MHz
    Gigabyte GTX 670 OC Windforce 3X @ 1372/7604MHz | Corsair Force GT 120GB | Silverstone Fortress FT02 | Corsair VX450

  5. #5
    Anyone? I really would like to know how bad it is or should I wait (probably years) for improved version? :/

  6. #6
    im using a g600, not really noticing any input lag at all


    AddOn Author of: SpellNotReadyYet, Rune of Powa

  7. #7
    Mechagnome RaZz0r's Avatar
    Join Date
    Dec 2009
    Location
    sweden
    Posts
    518
    Im using the g600 atm and i don't really notice any input lag.
    However i do have a problem with the cursor flying off in a random direction for no reason.
    Witch really screws me over in some games and its really annoying.
    And i don't really know a fix for that as far as im aware.
    Last edited by RaZz0r; 2013-01-28 at 03:31 PM.

  8. #8
    See my second post in this thread..

  9. #9
    Mechagnome RaZz0r's Avatar
    Join Date
    Dec 2009
    Location
    sweden
    Posts
    518
    Quote Originally Posted by Valium104 View Post
    See my second post in this thread..
    I Can't believe that actually worked
    right then i have no complains about the g600

  10. #10
    Quote Originally Posted by Valium104 View Post
    Basically as we all know, Avaga 9800 sensors have slight input lag. Can anyone with this mouse record this? You know, cam showing mouse and cursor, just to compare. Im torn apart if to buy this mouse or not, because I want MMO mouse, and rest of them doesnt even compare ergonomics-wise to me (naga, corsair m90, cyborg rat 7).
    Are you currently using 1000 polling rate, if so, do you have the same issue on 500 polling rate?

  11. #11
    Quote Originally Posted by Shinzai View Post
    Are you currently using 1000 polling rate, if so, do you have the same issue on 500 polling rate?
    I dont have this mouse, I would love to buy it if not for those issues. However, its faulty sensor, which is fixable by firmware, but mouse doesnt allow it by design. For those who dont have this problem, it seems Logitech upgraded firmware on those G600 produced later. Changing polling rate or doing anything besides firmware flash wont help.

  12. #12
    Quote Originally Posted by Valium104 View Post
    I dont have this mouse, I would love to buy it if not for those issues. However, its faulty sensor, which is fixable by firmware, but mouse doesnt allow it by design. For those who dont have this problem, it seems Logitech upgraded firmware on those G600 produced later. Changing polling rate or doing anything besides firmware flash wont help.
    Well, I've been using my G600 for rapid macro/micro in Starcraft 2 and don't notice it having any delay issues, though I have heard it can have a 1ms delay sometimes. I've not experienced any issues with it so far myself, on 6000 DPI it responds instantly and accurately for myself, the only issues come up with my own accuracy and reaction times.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •