1. #1

    Agony not refreshed with Sb:SS¿?

    Hi, I have been fighting with an issue. Sometimes, it seems random , when I cast SB:SS I see that UA and Corruption are refreshed but no Agony.

    I was using Nugrunnig that has a feature to see the strength of every dot and change color bar looking at this strength compared to you actual "strength". I change a little this add-on to get a more visual effect and put green or red bars regarding the strength of dots.

    Then when Afflidots come , as this add-on do the same, I begin to use this add-on, thinking that Nugrunning or my changes to nugrunning was the failing, but with affdots I see the same.

    I play with both add-ons, and both add-ons are configured to do the same, Red color to say me that I don't have to refresh because the dot applied is stronger than the new dot that I can apply with my current stats. Grey color to tell me that dot strength is the same than mine and Green color to say me that I have to refresh because I have more buffs than dots in the target.

    and sometimes when I use SB:SS Agony don’t get refreshed , in both add-ons the color of the UA and corruption change but no agony and I have to recast agony manually.

    both add-ons calculate the strength of the dot in a different way but both are telling me that sometimes agony is not refreshed by SB:SS. and this seems to happen when agony has more than 12 sec remaining .

    someone has seen this behaviour too¿?

    and no, is not a Hit issue, i have 15% (5100 rate)
    Last edited by Zarach; 2013-01-29 at 11:09 AM.

  2. #2

  3. #3
    I don't play Affliction, but could it be possible due to the stacking mechanic of Agony?

    You can't refresh certain buffs if you've got a "stronger" one of the same kind already on you, like Slice and Dice for Rogues. Maybe it works the same for Agony.

  4. #4
    Quote Originally Posted by Jessicka View Post
    Hit rating. When you apply dots with SB:SS all the dots chance to hit is still calculated individually.
    I have 5100 rate 15% hit chance. there is not a hit issue. updating original post xd
    and always happens to Agony , never with Corruption or UA.
    Last edited by Zarach; 2013-01-29 at 11:12 AM.

  5. #5
    it happens on occasion for me too, and i doubt it has anything to do with hit since im hitcapped and it still happens or rather not entirely bcoz of hit, it can be for any reason tbh, it can be bcoz of what Jessicka said, or Saveiro or it can even be linked to lack of mana, at this point i dont really know, all i know is that it still happens when im hitcapped, altho not very often, im mostly inclined to think that it has some to do with the implementation of soul shard system that for whatever reason, it maintains a 1% chance to miss, like the old days but it is really any1s guess.

  6. #6
    Sometimes game client does not recieve agony updating event, so addons don't know that it happened and don't react propertly. Addon issue, not SS:SB.

  7. #7
    ah ok, that makes sense i guess, so the spell have actually been updated on the target but your addon just fails to recive the event.

  8. #8
    Quote Originally Posted by Ridcully View Post
    Sometimes game client does not recieve agony updating event, so addons don't know that it happened and don't react propertly. Addon issue, not SS:SB.
    It has been an issue discussed on the AffDots topic for a couple of months now.
    The dot IS refreshed as far as I know, your addons just don't show it. How you choose to deal with that is up to you.

  9. #9
    I've never had this issue with ForteX.

  10. #10
    Quote Originally Posted by Filth the Warlock View Post
    It has been an issue discussed on the AffDots topic for a couple of months now.
    The dot IS refreshed as far as I know, your addons just don't show it. How you choose to deal with that is up to you.
    Are you still having this issue? I added a fix some time ago, haven't seen errors with Agony since then. Maybe it still exists in some situations.

  11. #11
    Quote Originally Posted by Ridcully View Post
    Are you still having this issue? I added a fix some time ago, haven't seen errors with Agony since then. Maybe it still exists in some situations.
    It could be something else, but I've had some issues with agony. I'll let you know if I manage to reproduce it.

  12. #12
    Quote Originally Posted by Ridcully View Post
    Are you still having this issue? I added a fix some time ago, haven't seen errors with Agony since then. Maybe it still exists in some situations.
    I can tell you that yesterday in raid i have this issue 2 o 3 times. and i have the last version of afflidots

  13. #13
    It's an addon issue because with WeakAuras I have never seen this issue before.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •