1. #1

    WoW Comp crash !

    Yo guys ! This is my first post, so HELLO ALL !

    For thing... I have little problem with my old comp. I think that he doesn't work as it should. In options (World Of Warcraft) i used to set up medium/high and it's working on 30-45 fps.

    Specyfication:
    Processor: AMD Athlon(tm) II X4 640.
    Memory: 8GB SAMSUNG DDR3 (2 X 4GB)
    Graphics Card: 1GB Gforce GTS450

    But i have WINDOWS XP ... i know i know. This allows to use 4 gb of my ram. Is there a problem ? In my op.system ?

    Regards,
    Cruggz.

  2. #2
    Bloodsail Admiral Twoddle's Avatar
    Join Date
    Feb 2011
    Location
    UK
    Posts
    1,026
    What is the question?

  3. #3
    Exactly what is the problem?
    Intel i5-3570K @ 4.7GHz | MSI Z77 Mpower | Noctua NH-D14 | Corsair Vengeance LP White 1.35V 8GB 1600MHz
    Gigabyte GTX 670 OC Windforce 3X @ 1372/7604MHz | Corsair Force GT 120GB | Silverstone Fortress FT02 | Corsair VX450

  4. #4
    oh. Is there any way to pimp up my fps ? Coz i feel that my comp is slimy while playing WoW. I'm after format with actual hardware drivers.
    Last edited by Cruggz; 2013-02-04 at 02:29 PM.

  5. #5
    Call Xzibit.

    How is your computer slimy? I don't really understand.
    Do you have issues with low FPS and want to upgrade your computer? Do you think there is something wrong with your current parts?
    Intel i5-3570K @ 4.7GHz | MSI Z77 Mpower | Noctua NH-D14 | Corsair Vengeance LP White 1.35V 8GB 1600MHz
    Gigabyte GTX 670 OC Windforce 3X @ 1372/7604MHz | Corsair Force GT 120GB | Silverstone Fortress FT02 | Corsair VX450

  6. #6
    Bloodsail Admiral Twoddle's Avatar
    Join Date
    Feb 2011
    Location
    UK
    Posts
    1,026
    30-45 fps seems about right on medium settings with a 3GHz CPU. Same specs as my machine, Windows XP, 3GHz CPU, 2GB RAM.

  7. #7
    No, I don't want to upgrade my computer. I think there is something wrong with my current parts. Some time ago i dont felt any problem while playing. Now i feel like my comp has reduced preference. FPS drops, slimy.

  8. #8
    So when did this "slimy" stuff start?
    Did you change something?
    Is it only in WoW?
    Intel i5-3570K @ 4.7GHz | MSI Z77 Mpower | Noctua NH-D14 | Corsair Vengeance LP White 1.35V 8GB 1600MHz
    Gigabyte GTX 670 OC Windforce 3X @ 1372/7604MHz | Corsair Force GT 120GB | Silverstone Fortress FT02 | Corsair VX450

  9. #9
    Bloodsail Admiral Twoddle's Avatar
    Join Date
    Feb 2011
    Location
    UK
    Posts
    1,026
    How long ago were you getting faster performance? I know for sure that Blizzard like to crank up the demands of the game every now and then without telling us!

    What do you mean by slimy?

  10. #10
    Heh sorry for my eng. Slimy - slow, heavy.

    Twoddle How long ago ? Hm... When I bought it ( year ago ) and It starts nearly 2 moths ago.

    n0cturnal nope. I playing Torchlight 2 too, and there is same problem. This is all the time. Not that begins at some point while playing or doing something on my comp.

  11. #11
    Bloodsail Admiral Twoddle's Avatar
    Join Date
    Feb 2011
    Location
    UK
    Posts
    1,026
    Then it could be overheating. Check all the fans are spinning properly and hoover out all the dust. If you're up to it download a program to check your temperatures Speccy for example.

    PS. It's possible it could also be due to other applications hogging the CPU usage. Try closing everything down before you run a game or even do a malware scan.
    Last edited by Twoddle; 2013-02-04 at 03:07 PM. Reason: PS

  12. #12
    Ok! Really thanks. Ill do that and post what's up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •