1. #1

    Shadow Unit Frames isn't working on PTR

    For some reason i was inside BT doing my warlock quest and SUF stops to works this it's the error displayed by lua:

    Message: ...ace\AddOns\ShadowedUnitFrames\ShadowedUnitFrames.lua:270: attempt to index field '?' (a nil value)
    Time: 02/10/13 01:43:13
    Count: 1
    Stack: ...ace\AddOns\ShadowedUnitFrames\ShadowedUnitFrames.lua:270: in function `LoadUnits'
    ...ace\AddOns\ShadowedUnitFrames\ShadowedUnitFrames.lua:83: in function `OnInitialize'
    ...ace\AddOns\ShadowedUnitFrames\ShadowedUnitFrames.lua:759: in function <...ace\AddOns\ShadowedUnitFrames\ShadowedUnitFrames.lua:757>

    Locals: self = <table> {
    defaults = <table> {
    }
    OnInitialize = <function> defined @Interface\AddOns\ShadowedUnitFrames\ShadowedUnitFrames.lua:29
    fakeUnits = <table> {
    }
    modules = <table> {
    }
    HideBlizzardFrames = <function> defined @Interface\AddOns\ShadowedUnitFrames\ShadowedUnitFrames.lua:573
    ComboPoints = <table> {
    }
    CheckUpgrade = <function> defined @Interface\AddOns\ShadowedUnitFrames\ShadowedUnitFrames.lua:87
    raidpetUnits = <table> {
    }
    partyUnits = <table> {
    }
    Units = <table> {
    }
    unitList = <table> {
    }
    noop = <function> defined @Interface\AddOns\ShadowedUnitFrames\ShadowedUnitFrames.lua:550
    dbRevision = 29
    LoadDefaultLayout = <function> defined @Interface\AddOns\ShadowedUnitFrames\modules\defaultlayout.lua:83
    tagFunc = <table> {
    }
    db = <table> {
    }
    Druid = <table> {
    }
    raidUnits = <table> {
    }
    SmartFormatNumber = <function> defined @Interface\AddOns\ShadowedUnitFrames\modules\tags.lua:346
    playerUnit = "player"
    maintankUnits = <table> {
    }
    mainassistUnits = <table> {
    }
    arenaUnits = <table> {
    }
    enabledUnits = <table> {
    }
    L = <table> {
    }
    FireModuleEvent = <function> defined @Interface\AddOns\ShadowedUnitFrames\ShadowedUnitFrames.lua:502
    GetClassColor = <function> defined @Interface\AddOns\ShadowedUnitFrames\modules\tags.lua:356
    Hex = <function> defined @Interface\AddOns\ShadowedUnitFrames\modules\tags.lua:322
    battlegroundUnits = <table> {
    }
    FormatShortTime = <function> defined @Interface\AddOns\ShadowedUnitFrames\modules\tags.lua:365
    FormatLargeNumber = <function> defined @Interface\AddOns\ShadowedUnitFrames\modules\tags.lua:334
    moduleOrder = <table> {
    }
    Layout = <table> {
    }
    Tags = <table> {
    }
    RegisterModule = <function> defined @Interface\AddOns\ShadowedUnitFrames\ShadowedUnitFrames.lua:473
    LoadUnitDefaults = <function> defined @Interface\AddOns\ShadowedUnitFrames\ShadowedUnitFrames.lua:287
    LoadUnits = <function> defined @Interface\AddOns\ShadowedUnitFrames\ShadowedUnitFrames.lua:256
    raidPetUnits = <table> {
    }
    Print = <function> defined @Interface\AddOns\ShadowedUnitFrames\ShadowedUnitFrames.lua:708
    ProfilesChanged = <function> defined @Interface\AddOns\ShadowedUnitFrames\ShadowedUnitFrames.lua:529
    unitTarget = <table> {
    }
    bossUnits = <table> {
    }
    ProfileReset = <function> defined @Interface\AddOns\ShadowedUnitFrames\ShadowedUnitFrames.lua:517
    }
    instanceType = "scenario"
    (for generator) = <function> defined =[C]:-1
    (for state) = <table> {
    1 = "player"
    2 = "pet"
    3 = "pettarget"
    4 = "target"
    5 = "targettarget"
    6 = "targettargettarget"
    7 = "focus"
    8 = "focustarget"
    9 = "party"
    10 = "partypet"
    11 = "partytarget"
    12 = "raid"
    13 = "raidpet"
    14 = "boss"
    15 = "bosstarget"
    16 = "maintank"
    17 = "maintanktarget"
    18 = "mainassist"
    19 = "mainassisttarget"
    20 = "arena"
    21 = "arenatarget"
    22 = "arenapet"
    23 = "battleground"
    24 = "battlegroundtarget"
    25 = "battlegroundpet"
    }
    (for control) = 1
    _ = 1
    type = "player"
    enabled = true
    (*temporary) = nil
    (*temporary) = nil
    (*temporary) = nil
    (*temporary) = "attempt to index field '?' (a nil value)"



    Any suggestions? i even tried remove all suf files and copy/paste it again. And still gives that error. And I cant see any frames.

  2. #2
    Legendary! Evil Inside's Avatar
    Join Date
    Oct 2010
    Location
    Down Under
    Posts
    6,984
    Probably cause its not meant to be used on the PTR, and cause PTR is 5.2, not 5.1..
    ||i5 3570k @ 4.4GHz||H100 push/pull||AsRock Z77 Extreme4||16Gb G.Skill Ripjaws 1600MHz||Gigabyte Windforce GTX 970|| Coolermaster Storm Trooper||Corsair TX850 Enthusiast Series||Samsung 840 Pro 128gb(boot drive)||1TB WD HDD, 2x 3TB WD HDD, 2TB WD HDD||

    Bdk Nagrand / Astae Nagrand
    Pokemon X FC: 4656-7679-2545/Trainer Name: Keno

  3. #3
    Quote Originally Posted by b0sanac View Post
    Probably cause its not meant to be used on the PTR, and cause PTR is 5.2, not 5.1..
    Well all adons are working properly but not SUF. I used SUF at the begin of PTR without any problems, and just now he stops to work

  4. #4
    You probably want to check the usual sources whether there's any PTR version available yet. If there isn't, there's nothing you can do but wait for one to get released I'm afraid.
    UI & AddOns expert | Interface & Macros moderator - My work

  5. #5
    Dreadlord soulyouth's Avatar
    Join Date
    Jan 2009
    Location
    Sydney, Australia
    Posts
    771
    working fine for me, I have my curse client set to get alpha builds for my ptr addons thought.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •