1. #1
    Epic! chaosjones's Avatar
    Join Date
    Feb 2012
    Location
    Old Tristam
    Posts
    1,564

    Strange keyboard bug

    Taken from the post i made on eu forums:

    Just Reformated my pc cause i got a new cpu and mobo.

    Installed and reisntalled all drivers 3 times so that does not seem to be the problem.
    What is the problem is that if i open wow my keyboard stops working all over the board. if i close down wow it works again. if i open diablo 3 it works but when i open wow i can't use my keyboard at all. This keyboard worked perfectly fine before the reformat.

    Too clarify better:
    When nothing is open keyboard works
    When Diablo 3 is open keyboard works
    If wow is open keyboard stops working. can't even type in a notepad

    Can anyone help?

    link to dxdiag cause its too long to post here
    http://www.filedropper.com/dxdiag_3

    Edit also tried with 3 difference keyboards same issue

    Active Wow Player | Active D3 Player | Active Eve Player | Active Wot Player | Scrub Openraid Raid Leader| Eve Gametime | Youtube / Twitter

  2. #2
    Moderator Sj's Avatar
    Join Date
    Jan 2011
    Location
    New Orleans
    Posts
    5,752
    Are you using multiple keyboard languages? Sometimes that can affect your keyboard's functioning.

    Is it a USB keyboard? Wired or wireless? Try pressing both Ctrl keys while in game and see if that fixes the problem.


    Edit: With WoW closed, go to your WoW folder and delete your Cache folder and rename your Interface and WTF folders to InterfaceOLD and WTFOLD. It's possible that an addon is blocking input.

    You also may want to run anti-virus and anti-malware software. You may have picked up a keylogger and sometimes they can interfere with keyboard input as well (doesn't sound like this is the case but better safe than sorry).

  3. #3
    Moderator Nyanmaru's Avatar
    Join Date
    Oct 2007
    Location
    Eschborn
    Posts
    5,374
    Is it a fresh WoW installation or dead weight from the old install?

    Does it also happen if you use a different USB port?
    What happens if you reattach the keyboard when WoW is running?

    And check the language bar thinggy if you got some extra unwanted things in there...

  4. #4
    Did you install WoW from the disk, downloader, or have an existing install floating around that you continued to use?

    Are there any other applications reproducing this issue?

    You can try deleting/renaming your WTF folder which will reset wow to standard settings. (it'll knock out your Addon settings too, mind you.)

  5. #5
    Epic! chaosjones's Avatar
    Join Date
    Feb 2012
    Location
    Old Tristam
    Posts
    1,564
    found a breakthrough. well it jsut makes it more strange.

    I have 2 instances of world of warcraft almost 100% identicaly. the only difference is that one is on a ssd and the other on a hdd.

    before i reformated my pc i took the SSD wow folder and put it into my hdd so i would not loose that instance of the client and when i was done reformating i moved it back again.
    Now if i try to use the second instance of the client the much older one i can use my keyboard but not the one on SSD
    Gonna try move the client from the ssd to another hdd to see if it still does the same thing. if it does ill just delete everything and copy my client to my ssd. don't really care about the addons.

    EDIT:

    Seems to be that instance of the client is broken somehow so ill just copy my old client onto my ssd and see what happens.

    EDIT2: god i hate moving stuff between a HDD and SSD only 100mb/s -_-'

    EDIT3:

    Now it works even on the SSD it seems that the instance i had of the wow client from my ssd was corrupted somehow. now its time to find addons again.
    Last edited by chaosjones; 2013-02-20 at 07:46 PM.

    Active Wow Player | Active D3 Player | Active Eve Player | Active Wot Player | Scrub Openraid Raid Leader| Eve Gametime | Youtube / Twitter

  6. #6
    Is it bad that i first imagined a weird keyboard shaped beetle upon reading the title?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •