View Poll Results: Do you have lag/fps/freeze issues on elegon

Voters
111. You may not vote on this poll
  • Yes, i have lag/fps/freeze issues

    50 45.05%
  • No, 100% fine

    61 54.95%
Page 2 of 2 FirstFirst
1
2
  1. #21
    The Lightbringer judgementofantonidas's Avatar
    Join Date
    Aug 2012
    Location
    East Coast USA
    Posts
    3,400
    Quote Originally Posted by deztruction View Post
    Who else has been having issues with elegon since the past 2 weeks.

    My Graphics cards overheats to crap on this fight now, no idea what blizzard did. My PC runs any other game perfectly fine on max settings and hardly goes over 60 degrees, i raid 25 man no other fight does this.

    wasn't elegon last tier?


    Lawful good does not always mean Lawful nice

  2. #22
    I am willing to guarantee it is one of two things
    1) An addon issue
    2) PC issue

    Shut off all your addons and see if it is still crappy, if that isn't it you should look into upgrading your graphics card. While most content in wow isn't intense on graphic cards they have made some things like elegon's room, the original durumu maze (before it was revised) that really looked cool but anyone that was without a graphics card made in the last couple of years is going to have issues with it unless you lower your graphic settings (especially with how a lot of the spell effects have been enhanced this expansion). I was really sad when they changed the durumu maze because people don't upgrade their computers regularly and complained about lagging.

  3. #23
    Field Marshal Thiassi's Avatar
    Join Date
    Apr 2013
    Location
    Louisisana
    Posts
    89
    I have an old computer, Core 2 duo running at 3.6 GhZ with an "upgraded" sapphire toxic HD 5850 and 6GB RAM, running at good settings at 15-20 fps. I only ever had one issue and it ended up being a driver issue. Switched to the newest beta drivers and haven't had any issues since. I used to have my AMD drivers set to automatically update, when they released the faulty drivers I didn't notice and thought it was a hardware issue. I'd suggest you try updating your drivers as well as checking your addons.
    Last edited by Thiassi; 2013-08-02 at 08:20 PM. Reason: Added Suggestion.

  4. #24
    Quote Originally Posted by Theholypally View Post
    Forgive me but wouldnt it cause more issues to turn up graphics? currently my shadow settings is on low, and id be glad to try it, but idk just seems odd. Would setting it to 'good' work?
    It's very counterintuitive. Apparently the way shadows work stimulates some performance bug in the graphics chip/drivers for those graphics cards. Setting the shadow quality to "Good" or higher is the workaround.
    "There is a pervasive myth that making content hard will induce players to rise to the occasion. We find the opposite. " -- Ghostcrawler
    "Almost every time I have gotten to know a critic personally, they keep up with the criticism but lose the venom." -- Ghostcrawler

  5. #25
    this is an old thread. But, in 5.2 Blizz did something to the way the graphics or the number of drawn elements are handled, which in most cases means you'd normally turn graphics down. However, for this particular fight (supposedly Primordius is the same but never seen the problem there) it works the opposite way and turning up shadows actually decreases the lag. It is NOT an addon issue, nor is it a pc issue. The topic has been covered quite a few times both here and the official forums, so when you get to the fight simply increase your shadows settings and you'll live happily ever after. Durumu was a whole 'nother story btw. It didn't lag anybody out, however you simply couldn't see anything either. The fix to that encounter was invaluable to nearly every guild. Then End.

  6. #26
    Quote Originally Posted by deidios View Post
    I am willing to guarantee it is one of two things
    1) An addon issue
    2) PC issue

    Shut off all your addons and see if it is still crappy, if that isn't it you should look into upgrading your graphics card. While most content in wow isn't intense on graphic cards they have made some things like elegon's room, the original durumu maze (before it was revised) that really looked cool but anyone that was without a graphics card made in the last couple of years is going to have issues with it unless you lower your graphic settings (especially with how a lot of the spell effects have been enhanced this expansion). I was really sad when they changed the durumu maze because people don't upgrade their computers regularly and complained about lagging.
    And I guarantee you it's neither of those things.

    http://www.youtube.com/watch?v=IBmNL...ature=youtu.be (#1 SSB Gold run on Bleeding Hollow)
    "Your lights will go out. The darkness will envelop you. And you will fear the shadows that move within it."

  7. #27
    Scarab Lord Shampro's Avatar
    Join Date
    Jun 2011
    Location
    The Crucible
    Posts
    4,852
    I had a similar issue on Primordius and wierdly enough, putting the shadows option on ''good'' actually fixed it. I was like wtf? But it basicly fixes the issue. Atleast for the particular issue, which is similar to the Elegon lag problem. Wierdly enough, I usually play with everything on High/good aside from shadows and sunshaft, never thought it would actually help me on lag on an encounter. Try that

  8. #28
    I have no problem with this fight in 25m or lfr.


    You know what I still have a problem with since cata release.

    Those stupid fucking twilight flames on torches. Anytime those come up and I'm zoomed in on them for whatever reason my computer gets the hiccups. I don't know why or what...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •