1. #1
    The Insane peggleftw's Avatar
    Join Date
    Sep 2009
    Location
    Surrey, England
    Posts
    16,243

    lost some quests completed since the patch! :(

    has anyone else lost some quests completed towards the seeker achievment? before the patch i was at just over 2900/3000, it said this both ingame and on the armory, and i just checked today and its showing 2570/3000 both ingame and on the armory. is this inteded, or have i lost some quests due to a bug?

    i have put a ticket in, but it will be a few days until i get an answer probably, so im hoping somebody here knows whats going on D:
    Too cool for a signature

  2. #2
    Quote Originally Posted by peggleftw View Post
    has anyone else lost some quests completed towards the seeker achievment? before the patch i was at just over 2900/3000, it said this both ingame and on the armory, and i just checked today and its showing 2570/3000 both ingame and on the armory. is this inteded, or have i lost some quests due to a bug?

    i have put a ticket in, but it will be a few days until i get an answer probably, so im hoping somebody here knows whats going on D:
    I've run into this issue in earlier patches as well. What I concluded was that I lost some quests in zones that I had not gotten the X quests completed achievement for said zones.

  3. #3
    Moderator Kerdoz's Avatar
    Join Date
    Apr 2011
    Location
    Sweden
    Posts
    7,573
    Mine was changing from day to day. And then suddenly I did get the achievement and the Title while the tracker was showing 2200/3000.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •