1. #1

    Anyone keep getting dced from wow since 5.2 happened?

    I get dced about every 5-20 mins when playing wow. I can log right back on most of the time, but it prevents me from doing anything but dailys/scenarios.

  2. #2
    I have that bug too, it's called "wife" in my case.

    But seriously, no, haven't seen that. I know it's Blizz's response for everything but maybe try clearing WTF folder or disabling older addons.

  3. #3
    Stood in the Fire MmoFanatic's Avatar
    Join Date
    Nov 2010
    Location
    sweden
    Posts
    368
    yup i get random dc around 1 time each day

  4. #4
    No, but I'll tell you what is annoying the fuck out of me...

    On Elegon now I drop to about 3 fps as soon as you step on the platform and get the glowy titan body buff.

    I don't know what the hell Blizzard changed with visual effects, but even when I set everything to lowest possible quality to test it, I still get about 3 fps on that fight.

    I get another drop in frame rate during Titan gas on Will also, but that is relatively short. Elegon it's practically the whole damn fight.

    And no I'm not running WoW on a toaster. Plenty of other people have the exact same complaint on that fight, I think it' probably something specific to my brand and generation of video card.

    But I hate it and want them to fix it or give me a way to fucking turn the effect off.

  5. #5
    Everyone drops FPS on elegon. I have a $1300 gaming rig and still only push about 20 fps max on that fight. They need to tone down the spell effects.

  6. #6
    Mechagnome
    Join Date
    Nov 2011
    Location
    Finland
    Posts
    637
    Litltle bit offtopic but, after 5.2 i get 2/3 of the times fps drop from steady 60fps-->18~ fps in blade's edge arena, after the fps drop starts it wont go up to 60fps untill i restart client.

    comp specs:
    i7 2600k 3.8Ghz
    6950 2Gb (overclocked from ccc)
    8GB 1333 ram

    Never had anykind of lag/fps drops before 5.2 :/

  7. #7
    You probably already did this: Update your addons. If that doesn't fix it delete your Interface/WTF/Cache folders, and see if that does. I would backup your WTF folder though just incase it doesn't you can get your UI back.

    Many addons cause DCs after patches if you don't update them.

    Quote Originally Posted by Coldhearth View Post
    Everyone drops FPS on elegon. I have a $1300 gaming rig and still only push about 20 fps max on that fight. They need to tone down the spell effects.
    Uh, I maintain 60+ FPS at all times on that fight but my computer cost about 3 times as much... My guess is your $1300 "gaming rig" is company built or you built it for that price a few years ago? All I can say is that my friend's 3570k/670 build definitely gets well over 40FPS on that fight on Ultra and I built his computer for only $1100.
    Last edited by tyrindor; 2013-03-25 at 10:21 AM.

  8. #8
    Pandaren Monk Mukki's Avatar
    Join Date
    Mar 2011
    Location
    ANC! ANC! ANC!
    Posts
    1,899
    Quote Originally Posted by tyrindor View Post
    You probably already did this: Update your addons. If that doesn't fix it delete your Interface/WTF/Cache folders, and see if that does. I would backup your WTF folder though just incase it doesn't you can get your UI back.

    Many addons cause DCs after patches if you don't update them.



    Uh, I maintain 60+ FPS at all times on that fight but my computer cost about 3 times as much... My guess is your $1300 "gaming rig" is company built or you built it for that price a few years ago? All I can say is that my friend's 3570k/670 build definitely gets well over 40FPS on that fight on Ultra and I built his computer for only $1100.
    An i5 2500k with a 6870 can run it perfectly too.

  9. #9
    Dreadlord Tarx's Avatar
    Join Date
    Apr 2012
    Location
    Greece
    Posts
    787
    I got the same problem with dceds

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •