1. #1

    Cast sequence issues with razer naga

    Hi everyone, after some quick frustration with my new naga epic mouse I'm hoping to find some saving grace on the forums. Im trying to use a cast sequence macro with a modifier for my warlock. When I que the side panel of my naga for 2 it does indeed activate the spell however it will not allow me to use a modifier to activate a cast sequence.

    This is what I'm using currently

    #showtooltip Incinerate
    /use 10
    /castsequence [nomodifier] Incinerate
    /castsequence [modifier:Shift] Fire and Brimstone, Incinerate

    Is there anyway to use a modifier macro on a keybind with the naga?

  2. #2
    As long as you use the side buttons of your naga to mimic the tenkey pad (or numberpad) of your keyboard, the shift key will serve to activate some utilities of the latter. Example: when you press shift+numpad2 it returns the command downarrow. Test it on your naga and you'll see. Ctrl and alt seems work properly for modifiers in macros related to numpad keys (and so to naga side buttons), only shift have this incovenient issue.

    Sry for my bad english btw.

  3. #3
    Moderator Endus's Avatar
    Join Date
    Feb 2010
    Location
    Waterloo, ON
    Posts
    21,056
    Quote Originally Posted by Kalrog View Post
    As long as you use the side buttons of your naga to mimic the tenkey pad (or numberpad) of your keyboard, the shift key will serve to activate some utilities of the latter. Example: when you press shift+numpad2 it returns the command downarrow. Test it on your naga and you'll see. Ctrl and alt seems work properly for modifiers in macros related to numpad keys (and so to naga side buttons), only shift have this incovenient issue.

    Sry for my bad english btw.
    To expand on this, this behaviour is hard-coded into the operating system. There are workarounds, but they involve registry hacks and the like, and change your keyboard's performance in everything.

    If you want to use shift-modifiers, you can't set your thumb buttons to the numberpad, basically.

  4. #4
    Actually, when I first encountered this problem it was on the regular 1-0 and not on the num pad. I will however try the control and alt functions to see if they work and ty for responding. I did send a support ticket to razer but they shot it down saying its not there problem and they only handle razer product problems. Go figure.

    ---------- Post added 2013-04-10 at 10:19 PM ----------

    ty the control and alt functions do work shame the shift doesnt work and having to use tab to switch targets it only leaves me control

  5. #5
    I don't know about the Epic, but my regular Naga allows me to change the buttons in the "Configurator" {Pre-Synapse version, I don't know if the Synapse interface is the same}. I just went in and changed the side buttons to use things like the Function keys and various other keys I can't easily reach.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •