Page 7 of 12 FirstFirst ...
5
6
7
8
9
... LastLast
  1. #121
    Quote Originally Posted by Keejos View Post
    That would be a 'no'.

    Thank you very much, It tasted great.

  2. #122
    I had doubts about switching or not to arcane, thanks to this bug I'm gonna swap. Really frustrating to have 2 invocation fail in a row.

  3. #123
    Quote Originally Posted by blaxter View Post
    I had doubts about switching or not to arcane, thanks to this bug I'm gonna swap. Really frustrating to have 2 invocation fail in a row.
    arcane is still running with RoP, right?

  4. #124
    Quote Originally Posted by Sephrie View Post
    arcane is still running with RoP, right?
    Yes, arcane still runs RoP

  5. #125
    Pandaren Monk Myz's Avatar
    Join Date
    Feb 2010
    Location
    Belgium
    Posts
    1,807
    Depends on the build you play with.

  6. #126
    Everyone needs to head over to the blizzard bug report forum and post on how it is not working. It isn't getting the attention it deserves because no one is posting there it seems.

    This is the only one I managed to find that was anywhere near the first page. http://us.battle.net/wow/en/forum/topic/8874518115#3
    Last edited by Lyreth; 2013-06-11 at 03:39 PM.

  7. #127
    Quote Originally Posted by Lyreth View Post
    Everyone needs to head over to the blizzard bug report forum and post on how it is not working. It isn't getting the attention it deserves because no one is posting there it seems.
    Post a link, I will gladly post in such a thread.

  8. #128
    updated post with link.

  9. #129
    If you are playing arcane.... try Incanters Ward as a passive (necer activate it!).... it pretty much feels like the cata/wotLK style of arcane..... you got a nice regen... full mobility and an evocatio for a burst phase!

  10. #130

  11. #131
    This seems like it could be a client/UI problem? I play on two computers, and on my main computer I see this all the time since 5.3 (like 10%-20% of the time invocation fails to trigger) but I have yet to reproduce the issue on my backup computer which I raided with tonight. Weird...

  12. #132
    Probably I'm wrong but I think it only happens to me when I have the vp trinket equipped. I'm going to use elegon's trinket for next save and we'll see... (for fire at least is almost as good as the vp 2/2)

  13. #133
    I think its a hard one to fix, some people seem to be getting it a lot. While others never or rarely experience it.

    For me i have tried it only two times since 5.3, first was during horridon progress week 1 after patch, 2end time was yesterday during iron qon. Other than that, I have had no problems at all.

  14. #134
    Yeah definitely a weird bug - worked every single time through 12 bosses, except for 3 failures in a row during the start of Primordias

  15. #135
    Mechagnome Serendia's Avatar
    Join Date
    Feb 2012
    Location
    Germany
    Posts
    623
    Haven't experienced any problems yet.

  16. #136
    It has nothing to do with the VP-Trinket. I dont use it und the bug happens very often to me (I estimate about 20%). You also dont get the healing from evocationglyph when the bug appears.

  17. #137
    Quote Originally Posted by Samisher View Post
    It has nothing to do with the VP-Trinket. I dont use it und the bug happens very often to me (I estimate about 20%). You also dont get the healing from evocationglyph when the bug appears.
    I find it happens in bunches when it bugs, was fine on qon and twins, but on lei shen last night my god what a pain in the ass

  18. #138
    Quote Originally Posted by Quilm View Post
    I find it happens in bunches when it bugs, was fine on qon and twins, but on lei shen last night my god what a pain in the ass
    This. Happened rarely throughout raid on Monday until Twins when I had to recast 6 times.

  19. #139
    High Overlord Adeltor's Avatar
    Join Date
    Oct 2011
    Location
    K 1914 AX
    Posts
    139
    Fucking hell, this is really annoying and has been there for so long time. I even have protective macros, that prevent me to cast Fireball, Inferno Blast or whatever before finishing casting Evo. Can anyone actually tweet GC about this shit? It should be hotfixed, i dont really wanna wait till patch 5.4 hits. This is so annoying for your DPS and rotation, once i had to cast it 3 times, which resulted in almost 10 seconds trying to cast that shit... srsly, this is outrageous!
    .
    Quote Originally Posted by zomgDPS View Post
    I want to feel the zomg in my dpspants when I throw pyros at someones face. How do you keep that feeling of 'zomg' in your pants while still nerfing throughput?

    Sig by Shyama!

  20. #140
    Immortal Polarthief's Avatar
    Join Date
    Oct 2009
    Location
    (USA) Florida
    Posts
    7,882
    Quote Originally Posted by Adeltor View Post
    Fucking hell, this is really annoying and has been there for so long time. I even have protective macros, that prevent me to cast Fireball, Inferno Blast or whatever before finishing casting Evo. Can anyone actually tweet GC about this shit? It should be hotfixed, i dont really wanna wait till patch 5.4 hits. This is so annoying for your DPS and rotation, once i had to cast it 3 times, which resulted in almost 10 seconds trying to cast that shit... srsly, this is outrageous!
    He's already aware and says "it's a tricky thing to fix".

    My question is why the fuck aren't we being given some form of alternative? RoP? LOL yeah okay. IW? Now I'm automatically gimping myself.

    It's basically just a big middle finger to us.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •