Page 1 of 12
1
2
3
11
... LastLast
  1. #1

    Invocation not working properly since 5.3

    Anyone noticed that many times once you finish casting evocation you dont actually get the Inovcation buff ?

  2. #2
    I have noticed over the past few month's that my evo will randomly stop mid cast. The only area where I get this issue is in org near a set of training dummies. Not sure if its add-on related or just something buggy in-game. Is it happening to you in raids?

  3. #3
    I only just noticed it this morning doing the Battlefield: Barrens. At first I thought I was getting interrupted or ending the cast early. But there were times I stood perfectly still out of combat and did not start to cast something immediately upon finishing. Still no buff (sometimes).

  4. #4
    Yep, guess I'm just gonna go the lazy route with incanters till it's fixed, not gonna sit there evocating 2,3 even 4 times till I get the buff.

  5. #5
    Warchief Akraen's Avatar
    Join Date
    Dec 2011
    Location
    SC, USA
    Posts
    2,130
    Same here - noticed it many times on Tortos last night and thought it was me messing up, but it wasn't.

  6. #6
    Same thing here. Luckily it never happened during a fight but its still rather annoying.

  7. #7
    Have had the same problem during the raid today, gg.

  8. #8
    Mechagnome Virtuous's Avatar
    Join Date
    Feb 2010
    Location
    England
    Posts
    632
    Oh, I usually don't even notice myself doing Invocation but noticed it wasn't buffing me, thought it was me ending the cast too early.

    :|
    Auchindoun EU
    "If you say 'plz' because it's shorter than 'please', I'll say 'no' because it's shorter than 'yes'"
    Tuch me

  9. #9
    1/10 casts dont give the buff after like 50 evocs :S

  10. #10
    Quote Originally Posted by Virtuous View Post
    Oh, I usually don't even notice myself doing Invocation but noticed it wasn't buffing me, thought it was me ending the cast too early.

    :|
    I thought exactly the same... feels bad.

  11. #11
    Bloodsail Admiral spaace's Avatar
    Join Date
    Jan 2009
    Location
    Ontario, Canada
    Posts
    1,112
    I thought I was just missing my casts last night.. this explains it.
    I was like "wtf am i doing wrong?!"
    3DS FC: 5172 - 0403 - 7277
    Pokemon Y Safari Steel Type (Feroseed, Forretess, Brozong)
    Bravely Default
    White Mage|XIV Stream

  12. #12
    Had it happen like 25% of evo's used during Brawler's Guild fights but, thankfully, never during the raid ( it did happen to another mage quite a few times ).

  13. #13
    Man, and I thought I was just clipping it too early last night, this explains it.

  14. #14
    I noticed this happening on the ptr about a week ago, but thought it was just me being crazy. Noticed it again on live last night and again, thought I was just clipping it accidentally. I'm gonna be real annoyed if it's an actual bug introduced from the patch that we have to deal with :/

  15. #15

  16. #16
    And here I was thinking that I was derping and casting too early. TO THE BUG REPORT FORUMS!

  17. #17
    Mechagnome jtmzac's Avatar
    Join Date
    Jun 2012
    Location
    Sydney, Australia
    Posts
    700
    I thought it was just lag from all the people playing... Well I hope it gets fixed soon.
    MB: Asus Maximus V Extreme CPU: [email protected] custom water loop GPU: Gigabyte GTX 680 RAM: Corsair 4x4GB 1600Mhz 7-8-8-24
    SSD: Samsung 830 256GB PSU: Corsair AX850 CASE: Corsair 800D
    Armory

  18. #18
    yeah this is still happening it's pretty frustrating

  19. #19
    Bloodsail Admiral Saegno's Avatar
    Join Date
    Feb 2010
    Location
    Kansas City, Ks
    Posts
    1,013
    Good to know this wasn't me screwing up.
    Hopefully we get a hotfix soon.

    Quote Originally Posted by Lohe View Post
    If you're semi-hardcore or semi-casual what's the other half? To me, they're both the same thing.
    Canicus - 577 - Arcane Mage - US Mal'Ganis Horde - 12/14H T16

  20. #20
    Warchief Phookah's Avatar
    Join Date
    Mar 2012
    Location
    Zebes, SR-21
    Posts
    2,176
    I hadn't noticed the buff not coming up, however I did notice the heal from glyphed invo not procing while I was doing dailies. This explains it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •