1. #1

    Unable to launch WoW or any Blizz games

    Has anyone else run into this insane problem where the launcher splash screen never comes up?
    All i get is the grey box and it gets stuck saying "checking for updates" or "updating blizzard update agent"

    Blizzard themselves have been completely inept at solving the issue, and from searching on b.net and google I'm not the only one who has run into this.
    Unfortunately nobody ever seems to follow up with how exactly they fixed this other than the odd person saying something like "i did X and it works now" with X being one of the random 10 generic blizz responses like "delete folder" or "run windows update"

    I've been through everything blizzard suggested at least twice on the off chance one of their canned tech support responses actually helped but no luck.

    So has anyone else had this problem and been able to resolve it?
    P.S. Can not run the repair tool as it's only in the launcher splash screen that I can not actually get to!

  2. #2
    You've probably already checked, but make sure you don't have any firewall rules blocking it.

  3. #3
    Herald of the Titans TEHPALLYTANK's Avatar
    Join Date
    Jun 2010
    Location
    Texas(I wish it were CO)
    Posts
    2,688
    Have you tried running WoW instead of the launcher? Your game file should have WoW and World of Warcraft Launcher in it.
    Quote Originally Posted by Bigbamboozal View Post
    Intelligence is like four wheel drive, it's not going to make you unstoppable, it just sort of tends to get you stuck in more remote places.

  4. #4
    Blizzard Araxom's Avatar
    Join Date
    Jan 2013
    Location
    Irvine, CA
    Posts
    332
    Hi Atomic, please PM me if you're continuing to run into the issue and I'll be happy to help you troubleshoot this. I don't want to spam you with a bunch of steps you've already tried, but it shouldn't be too complicated to get this worked out. I'll be available for the majority of the day - otherwise, you are welcome to give our support a direct call at one of the following numbers. (Please keep in mind that although I will be sure to respond to a PM, I may not be able to do so immediately - thanks for understanding!)

    USA/Canada 1-800-592-5499 10:00 AM — 6:00 PM Pacific
    Australia 1-800-041-378 8:00 AM — 12:30 PM AEDT
    5:00 PM — 11:00 PM AEDT
    United Kingdom 0800 0288246 10:30 AM — 6:30 PM GMT

  5. #5
    I ran into this problem earlier this year.
    Try the following: Empty your cache and temporary internet files from your Internet Explorer. You are using Firefox and never ever use IE? Me too. Do it nevertheless

    I read that the launcher is based on IE and sometimes malfunctions. This could explain our issues.

  6. #6
    Delete your C:\ProgramData\Battle.net folder (this is the updater agent), then it will re-download when you launch wow and things should work.

    C:\ProgramData\ is a hidden folder so if you can't see it either type in the file path manually or toggle the option to show hidden files.

  7. #7
    Quote Originally Posted by Araxom View Post
    Hi Atomic, please PM me if you're continuing to run into the issue and I'll be happy to help you troubleshoot this. I don't want to spam you with a bunch of steps you've already tried, but it shouldn't be too complicated to get this worked out. I'll be available for the majority of the day - otherwise, you are welcome to give our support a direct call at one of the following numbers. (Please keep in mind that although I will be sure to respond to a PM, I may not be able to do so immediately - thanks for understanding!)

    USA/Canada 1-800-592-5499 10:00 AM — 6:00 PM Pacific
    Australia 1-800-041-378 8:00 AM — 12:30 PM AEDT
    5:00 PM — 11:00 PM AEDT
    United Kingdom 0800 0288246 10:30 AM — 6:30 PM GMT
    we have blues at mmo-champ? :P i didn't know.

  8. #8
    After you do what Oratory says, you will see that now the bar is stuck at 70%. To get past that, open internet explorer in the background and then start the launcher again.

  9. #9
    Dreadlord Lovecrafts's Avatar
    Join Date
    Nov 2012
    Location
    South Dakota
    Posts
    829
    Quote Originally Posted by banestalker View Post
    we have blues at mmo-champ? :P i didn't know.
    We've had them for awhile, who do you think helps pay for this site. Blizzard has their fingers in a lot of pies.
    Quote Originally Posted by MoanaLisa View Post
    Let's be clear: It's Pandaria, not 'panda land'. Everyone got the message?
    -Yes, yes let the anger FLOW through you.
    WoD is just another lazy expansion, they reskin outlands and resort to time travel to keep the cash cow flowing. Honestly you people will buy anything!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •