1. #1
    Mechagnome Mcaffee's Avatar
    Join Date
    Jan 2011
    Location
    The Netherlands
    Posts
    506

    Curse client V5 issues

    Hi all,

    For the last few days I have been having this issue with the curse client v5 not working as it should.
    Each time I get the message that the application can not be started so I went to the Curse forums and tried everything mentioned to solve it, I have uninstalled then re-installed, deleted 2.0 folder, re-installed .net framework and nothing works.

    Then I checked to see if there were others with issues on the Curse forums and yup there are, people are writing tickets but nobody gets a reply and some tickets get removed completely without getting an answer, this you can see from pissed off people opening another ticket for the same issue.

    So my questions are:
    Who here on MMO-C has the same problem ?
    Have you received and answer from Curse that solved the issue and will you share?
    Has anyone come up with a solution by themselves and are you willing to share?

  2. #2
    Did you restart your computer after uninstalling the frameworks and reinstalling?

  3. #3
    The Curse client has been one of the most god awful experiences ever since they upgraded to the "new" design and engine. It starts incredibly slow or just hangs for minutes on end and don't even try to minimize it while playing WoW, you won't get it back up any time soon. Tickets go unanswered or eventually with a generic response that solves nothing.
    But hey, it has the free option and it has no competition. So there's that.

  4. #4
    Quote Originally Posted by Moshic View Post
    But hey, it has the free option and it has no competition. So there's that.
    I've never gotten Curse v4/5 to work, so I use Waddu.

  5. #5
    Mechagnome Mcaffee's Avatar
    Join Date
    Jan 2011
    Location
    The Netherlands
    Posts
    506
    Quote Originally Posted by Jabin View Post
    Did you restart your computer after uninstalling the frameworks and reinstalling?
    Ofcourse and still nothing, weird thing is that I never had an issue with the client until that auto update and since then nada.

    I've never gotten Curse v4/5 to work, so I use Waddu.
    I will give that a try.

  6. #6
    Quote Originally Posted by tordenflesk View Post
    I've never gotten Curse v4/5 to work, so I use Waddu.
    Nice, but I get a lot of critical errors. Probably because it hasn't been updated since March 2012.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •